1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Trouble with adding a new SATA drive

By brett_b ยท 10 replies
Jul 16, 2008
  1. Greetings from Arlington, VA -

    I'm having trouble getting my system to work with a new SATA drive. I've tried various BIOS ( settings, various jumper settings on the drives, and various connection arrangements among my three drives, but when ever I connect the SATA drive and change the BIOS setting to recognize it, i.e. turn to "Auto", my system will simply not boot and simply reports "F1 to continue or F2 to Setup." My OS is on D0 - ST3120026A LBA 120Gb on Ultra DMA5.

    I've also look at trying to change the boot sequence, but the BIOS doesn't give me many options and doesn't even acknowledge the SATA drive; I'm limited to D0, D1, CD-ROM, or USB. Drives D0 and D1 are connected to a Promise Tech PCI Ultra100 IDE Controller TX2. I even tried removing both the controller card and drive it came with (D1 - WDC WD2000JB-00DUA3 200 Gb on Ultra DMA5), and connect drive D0 directly to the motherboard, but much to my dismay, my BIOS gave me the same response.

    Any insights and assistance would be geatly appreciated!

  2. CCT

    CCT TS Evangelist Posts: 2,610   +6

    Please tell us the make and model of computer OR make and version of motherboard if a u-build.


    Download and run Everest Home (it is free):


    Once you download it, click on it and let it install and then run it from the icon on your desktop.

    Click on the + sign beside 'Computer', then on 'Summary', then go to the VERY Top of the screen and click on 'report'.

    Note: the 'Very Top' isn't one line down, it means what it says.

    Cursor over 'quick report-summary' and then click on 'plain text' and then click on 'save to file' and change the 'save in' folder to 'Desktop' and then click 'Save'.

    Clear all your open windows and on the Desktop click on that 'report.txt' icon - this will open it in a text editor
    (probably Notepad) and then use your mouse to highlight ALL the 'debug' entries and delete them, then use your mouse to hilight all the remaining text then copy and paste it to here.

    For future reference: once you open Everest, click on file, preferences, report and uncheck the 'include debug information in the report' box. People rarely want to see that stuff.

  3. raybay

    raybay TS Evangelist Posts: 6,908   +10

    Go to the website of your hard drive manufacturer for very complete information on installing SATA, and do a Google search on how to install a SATA Drive, for even a lot more.

    Too much info to post here.
  4. zipperman

    zipperman TS Rookie Posts: 1,168   +7

    Installing a SATA drive

    This is very complicated and worth haveing a Technision do it.
    You need to know how to install the RAID drivers.
    You need the Motherboard manual and cd for how.
  5. Justin

    Justin TS Rookie Posts: 914

    If he wanted a "technision" [sic] to do it, he wouldn't be posting on this forum.

    As mentioned in the first reply, telling us what motherboard you have would be useful. Also, do you have any other SATA drives you can attempt to use?

    Also, you mentioned an IDE controller - but obviously you can't connect an IDE drive to a SATA controller. You *are* connecting the SATA drive to your motherboards onboard SATA ports, correct?

    If you are, keep in mind that some motherboards have the option of disabling or changing the configuration mode for onboard controllers.
  6. Rick

    Rick TS Evangelist Posts: 4,512   +65

    This is not a driver problem!

    (Although it probably will be by the time the poster gets his drive booting...)

    Please continue...
  7. Rick

    Rick TS Evangelist Posts: 4,512   +65

    Something I've not heard you mention is the Promise card's BIOS. I'm pretty sure that card has its own BIOS. You can tell when you get a quick little screen after your BIOS POST screen that says something like "Promise Fasttrack 100 blah blah blah". At that screen, you should be able to enter setup by pressing CTRL-F (could be other keys, but it should tell you what keys to use to enter your controller card setup)

    You see, even if the motherboard's BIOS is properly setup to boot using your PCI card, your PCI card's BIOS needs to be configured also. If you can imagine it, your motherboard starts the boot up process. Then passes it off to your PCI card. Then your PCI card's BIOS has to determine what drive it boots to. If your card doesn't have its own BIOS, then can ignore the above.

    Your old IDE hard drive should *start* to boot though, when plugged directly into your motherboard. If it doesn't work, the only answer is your hard drive isn't working (check your data and power cables, jumpers on each drive connected to the cable), your boot order is not correct (triple check the order) or somehow you've disabled your onboard IDE controller. Other possibilities include hardware failure... A screwed up BIOS, failing motherboard, failing hard drive, bad cables... But it is probably none of these things.

    As for your SATA drive... Much like your IDE drive, the answers are your hard drive is not working (check your data and power cable - no jumpers to worry about), your boot order is not correct (keep checking it, because it probably lies in here somewhere) or somehow you've disabled your onboard SATA controller. Other possibilities include hardware failure... A screwed up BIOS, failing motherboard, failing hard drive, bad cables... But it is probably none of these things.

    First thing is first though... Let's get your system booting up, first. Then we can address driver issues, cloning your drive etc.. Any other clues you can provide? Perhaps the model of your motherboard? We might be able to give yo more specific instructions.
  8. zipperman

    zipperman TS Rookie Posts: 1,168   +7

    Thats your opinion

  9. brett_b

    brett_b TS Rookie Topic Starter

    Update & Add'l Info - Trouble w/ adding a new SATA drive

    Thank you all for your responses ~ beats the heck out of the Help Desks and Knowlege Bases at Microsoft, Promise Technologies, Western Digital,
    and Seagate; and Lord knows, I poured through them all. Okay, I think I may not have fully explained how I got to where I am. I took the
    advice from "CCT" and downloaded Everest Home from MajorGeeks.com and have included my systems stats below. But first, here's my saga:

    1. My Dell 8300 shipped with a single drive (Seagate ST3120026A 120Gb), which was connected to the mobo via the primary IDE pin slot;
    and life was good.

    2. Later I picked up a second drive for additional storage (Western Digital WD2000JB-00DUA3 200Gb), however, this drive also included
    a PCI card - Promise Technology Ultra100TX2 IDE Controller - apparently necessary to realize the drive's full throughput. So, I installed
    the card's drivers, then the card, and finally the new drive; and life was even better, except as mentioned by Rick, there was now an obvious hand off from the mobo BIOS to the PCI-IDE Controller card's BIOS that looked something like this:

    Ultra100TX2 BIOS Version 2.0.0210.2
    D0 - ST3120026A - LBA - 111Gb - Ultra DMA5
    D1 - WD2000JB-00DUA3 - LBA - 186 Gb - Ultra DMA5
    D2 - Not Detected
    D3 - Not Detected
    IDE Bus Master Enabled

    I then get two beeps, and the message:

    Strike F1 to continue, F2 to run setup

    No worries, I simply strike F1 and my system would boot just fine with both drives working like a charm.

    3. Then, a few years later, I got the great idea of keeping my original Segate drive, which was my primary master with my OS and replacing the second add-on Western Digital drive that came with the Ultra100TX2 controller card. So, removed the WD drive and the controller card, and plugged my original Seagate back in the mobo's Primary IDE connector; but no joy! The BIOS would simply repeat the two beeps along with the message to strike F1 to try to reboot, F2 to run setup. So, put everything back the way it was and was back in business as before.

    4. I then decided to just add my third new drive instead of replacing the second one. I installed my new SATA drive (ST3750330AS 750 Gb) via my mobo's SATA connector "0" and restared. At the BIOS message, I chose F2, entered the setup went to "Drive Configuration" and selected "SATA Primary" and changed it from "off" to "auto" and re-booted. Unfortunately, when I selected F1, it went no where and just kept repeating strike F1 to try to reboot, F2 to run setup. So, I shut down, move the new drive to SATA connector "1", but no luck. It seems the SATA connectorstake priority in the boot sequence, but there's no apparent way to change this, and with no OS on the SATA drive, nor anyway to get the OS on the drive, I seem to be stuck.

    So that's where I am. I'm thinking that I might have to uninstall the PCI IDE contoller card and it's drivers, then put everthing back in it's original configuration, but given that the system seems to look at the SATA connectors first, that move doesn't seem like it would do me any good, plus, I run the risk of really screwing things up. At least right now, I'm able to boot up using my first two drives.

    Thanks again for all the assistance.


    --------[ EVEREST SYSTEM REPORT ]------------------------------------------------------

    Operating System Microsoft Windows XP Professional
    OS Service Pack Service Pack 3
    DirectX (DirectX 9.0c)

    CPU Type Intel Pentium 4, 2600 MHz (13 x 200)
    Motherboard Name Dell Dimension 8300
    Motherboard Chipset Intel Canterwood i875P/E7210
    System Memory 2560 MB (PC3200 DDR SDRAM)
    BIOS Type Phoenix (07/21/03)

    IDE Controller Intel(R) 82801EB Ultra ATA Storage Controllers
    IDE Controller Intel(R) 82801EB Ultra ATA Storage Controllers
    SCSI/RAID Controller Promise Technology Inc. Ultra IDE Controller
    Floppy Drive Floppy disk drive
    Disk Drive ST312002 6A SCSI Disk Device (120 GB, 7200 RPM, Ultra-ATA/100)
    Disk Drive WDC WD20 00JB-00DUA3 SCSI Disk Device (127 GB)
    Optical Drive _NEC DVD+RW ND-1100A (DVD:4x/2.4x/12x, CD:16x/10x/40x DVD+RW)
    Optical Drive SAMSUNG DVD-ROM SD-616T (16x/48x DVD-ROM)
    SMART Hard Disks Status OK

    C: (NTFS) 114400 MB (75325 MB free)
    F: (NTFS) 131069 MB (131000 MB free)

    --------[ DMI ]---------------------------------------------------------------------------------------
    BIOS Properties:
    Vendor Dell Computer Corporation
    Version A02
    Release Date 07/21/2003
    Size 512 KB
    Boot Devices Floppy Disk, Hard Disk, CD-ROM, LS-120
    Capabilities Flash BIOS, Shadow BIOS, Selectable Boot, EDD, BBS
    Supported Standards DMI, APM, ACPI, ESCD, PnP
    Expansion Capabilities PCI, AGP, USB

    Motherboard Properties:
    Manufacturer Dell Computer Corp.
    Product 0M2035

    Chassis Properties:
    Manufacturer Dell Computer Corporation
    Chassis Type Mini Tower

    Processor Properties:
    Manufacturer Intel
    External Clock 800 MHz
    Maximum Clock 3200 MHz
    Current Clock 2600 MHz
    Type Central Processor
    Voltage 1.5 V
    Status Enabled
    Upgrade ZIF
    Socket Designation Microprocessor

    Cache Properties:
    Type Internal
    Status Enabled
    Operational Mode Write-Back
    Associativity 4-way Set-Associative
    Maximum Size 8 KB
    Installed Size 8 KB
    Error Correction None

    Cache Properties:
    Type Internal
    Status Enabled
    Operational Mode Varies with Memory Address
    Maximum Size 512 KB
    Installed Size 512 KB
    Error Correction Single-bit ECC

    --------[ Overclock ]-------------------------------------------------------------------------------

    CPU Properties:
    CPU Type Intel Pentium 4
    CPU Alias Northwood HyperThreading
    CPU Stepping D1
    Engineering Sample No
    CPUID CPU Name Intel(R) Pentium(R) 4 CPU 2.60GHz
    CPUID Revision 00000F29h

    CPU Speed:
    CPU Clock 2591.81 MHz (original: 2600 MHz)
    CPU Multiplier 13.0x
    CPU FSB 199.37 MHz (original: 200 MHz)
    Memory Bus 199.37 MHz

    CPU Cache:
    L1 Trace Cache 12K Instructions
    L1 Data Cache 8 KB
    L2 Cache 512 KB (On-Die, ECC, ATC, Full-Speed)

    Motherboard Properties:
    Motherboard ID <DMI>
    Motherboard Name Dell Dimension 8300

    Chipset Properties:
    Motherboard Chipset Intel Canterwood i875P/E7210
    Memory Timings 3-3-3-8 (CL-RCD-RP-RAS)

    SPD Memory Modules:

    DIMM1: Kingston K 1 GB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz)

    DIMM2: Infineon 64D32300GU5B 256 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz) (2.0-2-2-6 @ 133 MHz)

    DIMM3: Kingston K 1 GB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz)

    DIMM4: Infineon 64D32300GU5B 256 MB PC3200 DDR SDRAM (3.0-3-3-8 @ 200 MHz) (2.5-3-3-7 @ 166 MHz) (2.0-2-2-6 @ 133 MHz)

    BIOS Properties:
    System BIOS Date 07/21/03
    Video BIOS Date 06/24/03
    DMI BIOS Version A02

    --------[ MOBO Layout ]--------------------------------------------------------------------------

    See attachment.
  10. Rick

    Rick TS Evangelist Posts: 4,512   +65

    Thanks for the extra information.

    The 137GB limit shouldn't apply here:
    i875P/E7210 - I'm very sure your board does not have the 137GB capacity barrier that has you using a PCI IDE controller card. If you *did* have an issue with capacity, it may have been due to Windows' 48-bit LBA bug, but a reasonably patched up Windows XP or even 2000 system should be OK... But not the hardware. So you can probably just toss that card out of the equation.

    Boot menu
    I'm curious - Any luck with the using the boot menu? The boot menu generates a list of bootable devices in your computer and you can select what drive you'd like to boot to using the arrow and enter keys. During the last few seconds of your BIOS POST screen (probably with the Dell logo), tap the F12 key (It could be another key, but I believe F12 is the correct key for Dimensions around that time period). The menu should pop up and you should be able to boot to your IDE drive.

    Clear your CMOS:
    Since nothing else has worked, I'd like you try to clear your CMOS to fix your boot issues. This resets your BIOS configuration to the factory defaults and can solve some pretty quirky behavior.

    First (obviously), check the power and IDE cables connected to your 120GB Seagate. Put your hands on the inside of the case to discharge any static electricity and disconnect the power cable from the computer immediately afterward. Next, remove the lithium battery (silver coin cell, resembles a quarter), which should be above your SATA ports (If memory serves me). Sometimes you can use your fingernail to push the little metal tab to the outside (away from the battery), but a small flat-head screwdriver, pocket knife etc.. will work too. The battery should kind of pop out, if not, it might need some coaxing, but take it out for a couple of seconds and push it back in until it is firmly in place.

    Plug your computer back in and turn it on. Hopefully it will boot. If it still doesn't boot to your 120GB Seagate, check the drive configuration in the BIOS setup to make sure everything is correct. If that doesn't work, we know it isn't some CMOS issue or configuration problem. You have yourself some sort of hardware issue and I would try a different IDE cable, different IDE port and test the drive in another system (if possible).

    BIOS update:
    Once you do get your system back up and running, I would like to recommend a BIOS update for your system. Even if you can't get it to boot, it might be worth trying anyhow since it and some older versions address boot issues (although it doesn't describe your issue specifically).

    The disclaimer first: Do not turn your system off for any reason and don't flash your BIOS if you anticipate any power outages or other interruptions during the update. Losing power during the flash can render your system board unusable.

    You'll need to access another computer, make a bootable DOS diskette and copy the D8300A07.EXE file you downloaded from Dell's website to it. Boot your system up using the floppy disk and at the command prompt, type A:\D8300A07.EXE... it should start the BIOS flash.

    I hope you get it solved!
  11. CCT

    CCT TS Evangelist Posts: 2,610   +6

    Losing track of just what you are doing here.

    If you hook up the original boot drive (D0) to the mobo primary IDE controller does it boot?
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...