UEFI moved boot drive from boot menu to "Boot Override" list after testing in another PC.

Mugsy

Posts: 720   +152
My boot drive (a 120GB SSD) was working fine except I could not edit my Grub boot menu thanks to the restrictive UEFI bios.

So I tried putting the drive in another (pre-UEFI) computer but it was too old to let me do what I needed.

Giving up, I put the drive back in my new (x570) PC only to discover it is no longer included in the list of available boot drives. If I want to boot from it, I must scroll down to the list of drives under a sub menu labeled "Boot Override" (which lists every drive in every SATA port) and click on it.

Is there a way to get the bios to recognize my SSD as one of the default boot drives again? :confused:

PS: I tried the boot drive from the old PC in this new one and it has the same issue: Not recognized as a boot drive. I'm wondering if simply accessing a drive from a non-UEFI computer somehow flags it as "not a boot drive"? (which makes no since since the same drive was originally used in an old Win7 PC.)

HELP!
 

Mugsy

Posts: 720   +152
Thx for the reply, but it's not just my Linux installation not showing. It's the entire drive (a dual boot drive that includes Windows.)

In the UEFI Bios "Boot" menu, my SSD is no longer listed as a potential boot drive. But below that is a list of every drive connected to every SATA port. Clicking on my drive allows me to boot from it. But since it can not be set as a boot option, I must enter Bios every time to boot from the drive manually.

I Googled "efibootmgr" and will see if the drive can be "fixed" from Ubuntu. TIA.
 

Mugsy

Posts: 720   +152
Thx for the reply.
I ended up having to fix the MBR from the Troubleshooter CLI. :(