Updating firmware Micron SSD

By Sarnat
May 26, 2013
Post New Reply
  1. Hello,
    first all, my native language is Dutch, so sorry for any strange sentences.

    I have problems with my computer. Every hour (roughly) my computer freezes or restarts. Every now and then I get a blue screen (0*00000F4). When I get a blue screen my SSD is gone from the bios. I get an error when starting up. So I have to reset my bios to default standards, where my SSD turns up again.

    I read through the internet and saw that micron SSD's have problems which looks like mine. I have a C400-MTFDDAK064MAM_____00002_____

    There is an update for the firmware but im unsure which one to install.
    I tried but that is a wrong one apparently cause I get an error when trying to update. When starting up it says that \GRLDR.MBR cannot be found. Luckily my pc still starts up but no update is done.

    Im afraid to just try any other one.

    I also read something about disabling Marvel, raid and unplugging the other harddrive but my technical expertise is not that high.
    I dont have raid.

    Can someone help me please?

    Thanks in advance...

  2. Sarnat

    Sarnat TS Rookie Topic Starter

    Ok first stupid mistake made. I started the updater from my data disk and not the SSD.

    It did do "something" but at the end it said there was no SSD to upgrade...

    What now?
  3. Sarnat

    Sarnat TS Rookie Topic Starter

    Problem solved...I used the micron firmware update from my SSD instead of my data drive...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...