USB catch 22

By mikrik · 13 replies
Aug 23, 2009
  1. Hope i'm posting in the right forum, gtrateful for advice if i'm not.

    A freinds' PC stopped detecting any newly attached USB peripherals after having a usb broadband modem installed, new devices were detected so the devices were showing up in device manager, but with yellow questions marks but the option to search for drivers on the internet was no longer available.

    I (unwisely) deleted the root USB hub expecting it to regenerate and sort out any conflicts , but when the machine is booted in ordinary or safe mode windows detects the hardware and asks if it shoudl automatically install the drivers, as you'd expect, BUT I can't press OK as neither the USB mouse or keyboard have been detected at this stage so I can't click or tab about and use enter either !

    Mouse and keyboard work perfectly when booting into the BIOS or using other diagnostic CDs .

    Grateful for any advice on how to proceed
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Can you switch to PS/2 keyboard and mouse for this fix?
  3. mikrik

    mikrik TS Rookie Topic Starter

    Unfortunately not , it's a pretty new Dell Vostro 400 with no PS2 or serial ports, USB only.
  4. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Without being able to do anything within windows XP, fixing the problem gets a lot harder. In fact, I can't think of anything to do except reformat. You could try adding in a smartboard or touchscreen, but I think that is more difficult.
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) I think a repair install might fix it (vs. needing to do a reformat) if you have your XP installation CDs
    2) Or did Dell include a recovery partition?
    3) If need be to at least recover their files See [post=766270]How to recover your folders/files when Windows won’t boot[/post]
  6. mikrik

    mikrik TS Rookie Topic Starter

    Thanks for the ideas guys,
    I'll have my brother in law look for a recovery CDs; it's his machine.
    I'll boot the machine using knoppix and see if i can find a recovery partition.

    Another thought :-
    Are their perhaps any registry keys i could edit to make the machine automatically re-load the USB root hub drivers . Knoppix woudl be good for that also wouldn't it ?
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I just re-read your post and you say it "asks" about reinstalling USB drivers???

    Could you clarify:
    > Is this XP or Vista? and what service pack level?
    > Is it asking about installing an unsigned driver? OR
    > Is this the New Hardware Wizard asking you about how to install the driver OR ????

    Also, look at upper rt corner of screen when you see the Dell logo screen. Will usually give you Fn key options (which might indicate boot uptions / Recovery if a recovery partition is there)
  8. mikrik

    mikrik TS Rookie Topic Starter

    Hi , Apologies for not getting back sooner
    My daughter and grandchild are staying with me at the minute so I'm afraid i haven't managed to get looking at the PC recently.
    To answer your three queries
    1. The machine is running XP but I'm unsure with what service pack , but as it's less than a year old DELL Vostro 400 i'd expect it to be SP2 min
    2. No it is asking to automatically look for a driver for an unidentified device (after detecting a USB controller and then a mouse and then an keyboard)
    3. Yes it is the new hardware wizard.
    If only there was a way to stop the wizard form being interactive and just detect and load the drivers i'd be home in a boat.

    As an alternative Iv'e been searching (fruitlessly with so little time available) for a bootable or a bootable NTFS disc to see if there is a recovery partition on the hard disc , whilst the DELL XP diagnostic or recovery CD is located assuming it ever existed.

    Hope this helps

    I'll have my house back on Monday so i'l be able to put soem real time and effort into this .
  9. mikrik

    mikrik TS Rookie Topic Starter

    Hi , a short update .
    I have now been given the DELL CDs but when using them to boot , I do not get the option to do a restore rather than a reinstall and cannot load anything from the drivers CD because I need to be in windows mode , damn.

    I'm trying to avoid doing a full reinstall as my broither in law uses the machine to run his business and despite frequent reminders he dosen't back the thing up .
  10. raybay

    raybay TS Evangelist Posts: 7,241   +10

    The Dell Windows Disk does offer the repair option on all models, but it is in the next set of screens after you are asked if you want to run Restore Console.
    You are actually on your way to an install when the R for Repair Choice finally comes up.
    I have not yet seen a Dell that will not do this.
    If you need more detailed instructions, I will type up something more useful
  11. mikrik

    mikrik TS Rookie Topic Starter

    You were of course completely correct. I don't knwo why i didn't see it before , or I just chickened out or am just completely confused as I have tried so many discs and different ideas.
    Al was goign well until setup had loaded almost all the drivers and then the mouse and keyboard stopped working again ,when setup reported that it had 34 minutes to go , although the driver install progress bar finished and the screen with the regional language options came up . At this point it wasn't possible to proceed without without clicking next so it was game over at that point .....5 times in a row.
    So it was progress alright , but remaining positive , perhaps I have encountered a different problem with setup that might be addressed alsewhere on the forum ?
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) Even before attempting the repair have you tried to boot from a Knoppix CD to at least first try and safely recover/backup all the personal files on the drive? See [post=766270]How to recover your folders/files when Windows won’t boot[/post]

    2) As to the Setup problem... Setup hanging at 34 minutes sounded very familiar. Google brings up lots of hits, here's one from MS Setup stops responding with 34 minutes remaining
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

  14. mikrik

    mikrik TS Rookie Topic Starter

    Thanks for both posts, some replies below.
    1. I have done a backup with Knoppix but thnaks for the reminder
    2. Setup stops responding .......... Good article but I think it only confirms the issue still remains with the missing root hub drivers
    3. Iv'e seen this great article before but am still having difficulty gettign results , mostly due to my own inability to follow them to the letter (I am referrign back to my inability to find recovery , which yuo pointed out to me!)
    It's after midhnight here and i'm off to bed , wil resume tomorrow after work .
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...