USB Flash Drive not working

By Rukichu · 40 replies
Apr 10, 2009
  1. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Its possible that new malware has come in, though most malware isn't made to render USB flash drives useless D:.

    I forgot to ask, does your computer properly detect other USB devices or flash drive? Thats a quick test if you have one handy.
  2. Rukichu

    Rukichu TS Rookie Topic Starter Posts: 34

    Yeah, that's what I was thinking =/
    My computer recognizes anything and everything I put into my USB ports, except for my flash drive. It's so bizarre
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OOopps. Forgot to get back to you. Too many things going on

    1) Complete your malware check and (assuming it's all good)
    2) As i just recalled you're running SP2, you should upgrade your computer to SP3. See this post USB Device Problems? Check for Windows Updates
    3) Also, while Disk Management problems (as you described where no drives appear) typically mean problems with Logical Disk Manager services (or malware or bad filter drivers) i also just happened across this (literally, "just" as in the last 30 minutes) MS KB (fyi) just released Feb, 2009!
    4) I'd advise the SP3 upgrade, and if problem still occurs, see Part2 of Guide to install/run drivecleanup tool
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Oh. and the new/improved Part1 is still not completed but here's the current draft version you might find helpful as well

    Troubleshoot: Windows Won't Recognize Your USB Hard Drive
    Part 1, General Information and Troubleshooting

    Updated mm/dd/09
    There's a long list of reasons why Windows may stop recognizing your USB drive and/or stop displaying that familiar drive letter in Explorer. Where to begin? Start here with Part 1!
    • Part 1, General Information and Troubleshooting includes
      • Troubleshooting - to start your troubleshooting
      • Things to Try and Things to Check - skim through / refer to these for more to-do's as may apply
      • Partition Tools - partition management and recovery tools
    • See [post=720763]Part 2, Fix a Drive Letter that Doesn't Appear[/post] if a drive letter problem is indicated
    • See [post=720766]Part 3, How to boot from a G-Parted-Live-CD to try fix USB drive problems[/post] for extended troubleshooting
    Note !!NEVER, EVER!! unplug a USB drive before you first either
    • Stop the USB drive. Use Safely Remove Hardware icon. Do not unplug the device until the device is stopped
    • Shutdown Windows
    USB devices are "hot pluggable". This means you can plug them in any time but does not mean you can unplug / power-off anytime! Doing so may corrupt your disk and result in partial or total data loss!!
    • Run Windows Update
      • Click to verify you have the latest USB fixes installed. Then continue with next steps
    • Unplug all other USB devices
      • USB mouse/keyboard should be OK but note tests below that warn otherwise
      • Undock any docking stations
      • Plug the USB drive directly to computer (no hubs)
    • Connect AC adapters
      • Connect USB drive AC adapters even if "the adapter is supposed to be optional" or "you never had to connect it before"
      • Plug-in laptops
    • Start at Device Manager and follow the Windows trail to identify first point of failure
      Check for errors in the following order. Fix any error before continuing
      1. Device Manager
        Windows should 1st detect the USB hardware, then recognize it as a USB disk device. It should install a driver for each
        • USB Hardware
          • Under USB category, rt click each USB Mass Storage device. Select Properties then General tab
          • If Location: string describes your USB drive this is its USB driver . Check status= Working Properly
        • USB Disk
          Under Disk Drives category, find the disk name matching your USB drive. This is its Disk driver
          • Rt click the matching disk name, select Properties, check status= Working Properly
        If error
        • USB driver missing? Windows isn’t detecting the hardware. See Hardware Problems below
        • If disk driver missing? Windows isn’t seeing valid disk format on device. See Disk Format Problems below
        • If driver found but status= error see Fix Driver Errors below
      2. Disk Management
        If both drivers are installed / running OK, your USB drive should
        => Appear as a disk in Disk Management
        => The disk should be divided into one or more formatted partitions
        => Only partitions assigned drive letters will appear in My Computer and Explorer
        • Drive appear as a Windows disk?
          • SAFELY disconnect your drive and turn it off
          • Start->Run, enter diskmgmt.msc. Click View->Bottom->Disk List
          • While watching the Disk List display, 1st connect your USB drive, then power it on. Does Disk List change? Your drive appear?
          • If yes, rt click Properties to confirm it's your USB drive
          • For more about using Disk Management, click here
          If error, see Things to Try and Partition Tools
        • Valid disk paritions?
          For each USB drive found above
          • Is drive partitioned correctly? Are partitions formatted? Correct size?
          If errors, see Partition Tools
        • Drive letter assigned?
          • For each partition on USB, does Disk Management display a drive letter? Did you expect one?
          If expected but not assigned see Part 3, Fix a Missing Drive Letter
    Trying to Fix Things
    • Driver Errors
      1. Remove the disk filters (instructions need be given here)
        To view current filters use Filter Driver Load Order. Select your disk then each filter. If it show N/A, filter is in registry but no file is installed!
      2. Lookup Driver Error Code
      3. Disconnect and power down the drive. Insert USB cable then power the drive back up
      4. Also review Disk Format Problems

    • Disk Format Problems
      1. Try shorter cable if you have one (Poor shielding and long cables can= Noise)
      2. Reinstall the motherboard chipset drivers
      3. Reinstall the USB controllers
        This will remove/reinstall your USB controllers and reset the USB stack
        • Warning: Use a non-USB mouse
          • Either get cable adapter to connect to non-USB port (e.g. PS/2) or
          • Remote connect to your computer (the server) from another computer (the client) Some free remote tools, if the server is
            => XP Pro: MS Remote Desktop
            => Win2000, all versions XP and Vista: LogMeIn (free version)
        • Download Unzip into C:\Windows\System32
        • Copy/paste text below to a text file on your Desktop. Rename it drivecleanup.bat
          drivecleanup > "%USERPROFILE%\DESKTOP\outfile.txt"
        • Shutdown your computer. Disconnect all USB devices. Reboot.
        • Double click to run drivecleanup.bat. Open Device Manager. Under Universal Serial Bus controllers
          You should only see hubs and controllers. (One Enhanced Controller If you have USB 2.0)
          Rt click to uninstall
          - Each hub
          - Then non-Enhanced Controllers
          - Then Enhanced Controller
        • Restart then reconnect your USB
      4. Repair the filesystem
        Expect chkdsk to run very slow (especially on large disks). It’s normal for chkdsk %complete to sometimes take 30+ minutes before changing
        The MS KB below applies to both XP and Vista

        Drive letter: chkdsk /r
      5. Power Management
        - Do not allow windows to turn off USB power
        - fyi: Keep it configured this way normally to help prevent problems
        • In Device Manager, expand USB category
        • For each Root Hub
          => Uncheck Allow computer to turn off this device to save power
      6. Also review Hardware Problems

    • Hardware Problems
      1. Try different USB cable
      2. Different USB ports Try each computer port. No hubs
      3. Different computer
      4. Power Usage
        USB devices draw power from a USB port. However, each USB port limits the total draw at 500mA
        >> if AC adapter isn't supplying enough power the drive may start drawing more

        To check device power draw, find the Hub it's connected to. In Device Manager under USB

    • More stuff to Try
      1. Scan for Viruses. See
        - 8-step Malware Removal Instructions
        - Virus removal from USB Drives
      2. Check Windows Event Log
        Windows Event Log how-to's: Click for XP, Click for Vista
        Check System Log for
        - USB device errors
        - Logical Disk Management service errors
    When All Else Fails
    Click for info to reformat your drive
  5. Rukichu

    Rukichu TS Rookie Topic Starter Posts: 34

    Thanks so much for your help. I'll try my best to get this problem worked out. Unfortunately, SP3 wouldn't install for me so that's out of the question. I'm going to follow the steps in the guide and see if anything will work.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    At least make sure all Windows updates are applied for SP2 then. (Click custome when running windows update)

    And once you verify (again) the 2 device drivers are present (as per the Guide) try drivecleanup tool as well

    /* EDIT */
    And if SP3 won't install for you can't wonder if represents another problem or just another indication of current problem???? Any idea why it won't install???
  7. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Oh really...why is that? Makes me think back, did your malware come up clean?

    EDIT: Might i mention that the maleware may actually be ON the flash drive in question...though you mentioned device manager problems, so maybe not.
  8. User in LV

    User in LV TS Rookie

    Try unplugging all your other USB devices first. I did and my USB jump drive started working again

    I narrowed down the problem to the new printer I am using. It's a Dell Mono Laser MFP 1125. Whenever it is plugged into a USB port, my jump drive stops working. All other devices work, but not the jump drive if the printer is plugged in. I will be contacting Dell for a fix, but others may be experiencing problems due to one of their USB devices also interfering with their jump drive.

    I hope others try unplugging their other USB devices before using their USB jump drive - at least before trying a more technical solution.
  9. Rukichu

    Rukichu TS Rookie Topic Starter Posts: 34

    Okay, I'll try that. Thanks :)
    I'll also continue to look and see if it's a malware problem of some sort. I'll report back later.
  10. atroronto

    atroronto TS Rookie

    I am having the same issue. It was caused when I removed a Malware infection from my computer. I have tried all of the recommended steps that were posted but nothing has worked so far. The USB flash drive will only show up in device manager. It will not show up in disk manager or in my computer. A USB hard drive will work when connected. I have SP 3 installed. It seems to have also stopped the Windows update from working. I receive error number: 0x80070002
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hi atroronto :wave:

    i think you're best to post a new thread with your problem. also when you say "it shows up in device manager" please indicated

    1) Does that mean BOTH drivers show up or only one?
    2) Do BOTH drivers show status= Working Properly or they show something else?
  12. Rukichu

    Rukichu TS Rookie Topic Starter Posts: 34

    Hey guys; I think I may have found my problem!!
    Recently I noticed two very interesting programs that were automatically starting up on my computer. One called "ratifuya.dll" and another called "hafedeku.dll". I disabled both of those start up programs and deleted the registry keys. The other computer problems I've been having have stopped.
    The only thing that HASN'T been fixed is the way my computer sometimes crashes firefox, and the whole situation with my USB drive. I'm pretty sure this is because the "hafedeku.dll" registry key won't let me delete it and I can't find the file anywhere.
    I think I'm going to start a thread in the malware section to get some help on how I can possibly find this file and remove it for good!
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Yep... You're definitely infected with malware (see here)

    Once the malware guys (and gals) certify you "malware free" you should try that SP3 install. If SP3 still won't install, likely it suggests still more underlying issues.

    /* EDIT */
    And best to let the malware people help clean it up..vs. you trying to delete directly from the registry :)
  14. Rukichu

    Rukichu TS Rookie Topic Starter Posts: 34

    yeup, I've been searching all over google for information on that file. I'm sure once my computer is cleaned up, I'll be able to install SP3.
    Thanks again for all the help and I hope removing that virus fixes my problem!

    And yeah, I know I should let the experts help me out with it xD;;
  15. LSanBoeuf

    LSanBoeuf TS Rookie

    Probable Rootkit

    I had the same problem back in May'09. Flash drives would not get a drive letter but appeared in device manager. Other USB devices worked, including my external WD hard drives.

    No AV or anti-spyware could find it. I started looking for rootkits and finally found a freeware tool gmer.exe (don't remember from where but it should be easy to find). This nifty little tool found the ovfsth*.sys rootkit and included tools for isolating and cleaning it. Rootkit_Detective.exe by McAffe (also free) was also helpful because it too saw ovfsth*.sys and renamed the files so they couldn't be loaded on the next reboot.

    In short, both these tools work by accessing files and the registry directly rather than through the standard Windows API. This rootkit was able to hide itself by setting properties and permissions that made the Windows API believe it was an internal system file, and registry entries, which even the Windows API hides from view.
  16. LSanBoeuf

    LSanBoeuf TS Rookie

    Probable Rootkit

    BTW; Once the rootkit was eliminated the USB problem went away, a few other lesser severe anomalies as well, and system performance improved noticeably.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...