1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USB mouse wont install (unknown device)..

By kritonas ยท 19 replies
Jun 4, 2005
  1. Hello all,
    I've been trying for quite some hours to install a new mouse i got and i'm desperate.
    I ordered two of these Chic 1330 mice from ebuyer, and tried to install them on two laptops.

    These mice are p/s2 so i bought two converters (ps2 to usb). I read in their instructions that they can be used with USB and that they are compatible. Also, some people in ebuyer said that they work ok.

    Well as soon as i plug the mouse in the USB i get an Unknown device message. When i try to manually install the drivers, i cant, because they only drivers i get in the driver list are "Unknown device". This is so annoying, and i've spent so many hours on this...

    oh yeah another thing, i dont know if its got anything to do with it, but when i "view hidden devices" in device manager, there is a device called Serial, and its not working (yellow exclamation mark).

    Anyone's got any suggestions?

    *Edit* Oh yeah when i connect the mouse it lights up and stuff (its optical), its just not recognised
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You should try with different PS2/USB adapters.

    Any adapter between PS2 and USB is a hack and definently won't work in all configurations. In my experience they always cause problems sooner or later.
  3. mailpup

    mailpup TS Special Forces Posts: 7,103   +422

  4. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    Hey guys thanks for the replies and sorry for taking so long to reply..

    Nodsu: That's not a bad idea, although i paid 2-3 quid for the mouse, and another 1 on the adaptor, i'm not willing to pay more, i'll probably sell them on ebay and get another one:p I was just curious why this didnt work...Well arent all ps2->usb adaptors wired similarly?

    Mailpup: I tried that...the application that comes with the drivers launches ok, but there is no response from the mouse (which is still recognised as an unknown device)

    any further suggestions?
  5. IronDuke

    IronDuke TS Rookie Posts: 856

    You need to install the drivers before plugging in the mouse.
  6. mailpup

    mailpup TS Special Forces Posts: 7,103   +422

    Is it possible your PC only supports USB 1.1 and that it won't work with your mouse? Or something to do with compatibility anyway.
  7. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    IronDuke: It wouldnt matter if i unplugged and plug again the mouse....at least i dont thinkso.

    mailpup: I tried that on 2 laptops which are brand new with usb2.0 ports...
  8. IronDuke

    IronDuke TS Rookie Posts: 856

    Remove it in Device Manager and let it be detected on restart.
  9. dgower2

    dgower2 TS Maniac Posts: 238

    USB Legacy Device Setting in BIOS?

    There's a setting in my BIOS for enableing legacy devices on USB. I actually don't know what it's for or what toggleing it does, but you could try changing that setting if you have it in your BIOS.
  10. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    Tried that...no result. The strange thing is that i cant find a .inf file in the driver package of the mouse, so that i can install it manually.

    No usb legacy option on my laptops dgower2:/
  11. IronDuke

    IronDuke TS Rookie Posts: 856

    Try downloading Micro$oft's latest mouse driver. I think it is 4.2 and in set-up pick a similar model to yours. Scraping the bottom of the barrel for ideas. :)
  12. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    I tried that, and it didnt work:(
    Sorry for not saying it, i forgot.

    I tried installing the drivers manually by choosing Unknown device->update driver->have disk, and when i choose the m$ driver, i get a "The specified location doesnt contain information about your hardware"

  13. IronDuke

    IronDuke TS Rookie Posts: 856

    I guess it might be time to splash out on a new mouse. Have you tried these mice on another computer? It is beginning to sound like the dead.
  14. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    yeah its quite stupid to still try and fix so cheap hardware problems. i'm really curious why they're not working. I have tried using them with the usb converter on 2 laptops and a desktop, and nothing happens but when i tried on the desktop with the ps2 it works fine.
  15. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Maybe the mice just don't support USB?

    At least USB mice work with the PS2 adapters by detecting that they are plugged into a PS2 port and switching the mouse protocol to PS2.
  16. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    I thought of that nodsu, but its written on the mouse's specs that it's usb compatible, and in the instructions its clearly stated that it can be used with a ps2->usb adaptor.
  17. Strangecolours

    Strangecolours TS Rookie

    I have exactly the same Chic optical PS2 mouse. I bought a PS2 to USB adapter from the local store less than 2 hours ago and have found exactly the same problem (unknown USB device, mouse lights up but no movement - have tried all fixes suggested so far). I was suprised to find someone else had exactly same problem.

    I think the adapters may be poor quality, the brand is GR Kabel (GR Computer Products) - i'll probably take it back and buy a USB mouse instead. :(
  18. kritonas

    kritonas TS Rookie Topic Starter Posts: 49

    I bet it's something really simple, but noone has thought of that...!
  19. Perkins

    Perkins TS Rookie

    Forget the mouse. Starting with Windows XP, and maybe 2000, NT 4.0 or some such (not sure about those) serial support via USB is not enabled by default. Doesn't matter if it is a serial mouse, keyboard, ethernet router or anything else. You can install the driver yourself, though I admit I do not know what drivers you need. My brother would, but he's gone to bed. (Hence why I was looking online for driver info and found this site.) If you want to make sure it is not the hardware, you could try running a linux live cd. Linux still comes pre-installed with the USB drivers for standard 9 pin serial. I'm pretty certain that P/S2 to USB has similar issues, though the drivers for controlling it might be different. I know that P/S2 mice work in a standard serial COM port, so I can think of no reason that they wouldn't with the same drivers as the serial. Windows would simply treat it as a P/S2 mouse converted to a serial mouse. If I find where to get the serial drivers for windows, I'll add it here; otherwise, happy hunting.

  20. kimsland

    kimsland Ex-TechSpotter Posts: 14,524

    If you're purchasing an external mouse for a laptop, you are best to use only a USB (only) mouse anyway.

    As this thread is 4years old, I'm sure it got fixed though.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...