1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Usb ports dont work after replacing motherboard

By au0 ยท 13 replies
Jan 19, 2008
  1. Hey all,
    My asus a8n32 sli deluxe motherboard broke, so I sent it in and got a replacement one from asus(same model). The computer runs fine, but no usb devices work with it. Theres ports on the back of the motherboard,and I've also plugged in the front panel usb ports on my case into the motherboard. If I plug an ipod in, it will receive power to charge, but the device isnt detected (this applies to the back and front ports). If i plug in a flash drive in the back, nothing happens, if i plug it into the front, i get the unknown device message. I tried uninstalling the usb devices in the manager, and I've tried reinstalling my chipset driver. Does anyone have any other ideas? Much Thanks.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Enable USB in the computer's startup BIOS

    You may be RMAing this board, but you may need to do a Windows Repair to confirm, if the above doesn't work.

    The new M/b may be the same. But may not be the same revision or bios revision
  3. au0

    au0 TS Rookie Topic Starter

    hi, thanks for your quick response!
    I forgot to mention that I already checked the bios to see if the usb 1.1 and 2.0 options and hi speed settings were set to "enabled". The speed setting was set to "auto". By windows repair do you mean rolling back drivers? If you meant updating the bios i really don't want to update it unless i have to for sure completely; the first time I had this motherboard I used asus' asusupdate tool for the bios, and it ended up unsuccessfully even though the program told me "update successful, please restart for settings to take effect."
    Thanks again. Hope to hear your reply soon.
  4. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

  5. au0

    au0 TS Rookie Topic Starter

    I have a spare ATA hard drive that I can test with by reformatting and doing a pure clean install on this computer(and then hoping the usb actually works!). The current hard drive now is a serial ATA, but the difference between the serial and regular ATA probably wont matter in this case correct?
  6. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Correct, I hope that you had started already though.
    Please reply with the USB answer: Yes or No USB that is the question!
  7. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 1,997

    If this is a replacement motherboard it is important to ensure that there are no shorts to earth - this can cause all sorts of errors from boot failure to this sort of thing. Check that there are no extra stand-offs under the board - if in doubt take the board out and run it outside the case.
  8. au0

    au0 TS Rookie Topic Starter

    Hi guys,
    so i tried using a brand new hd. Still no luck. My friend tried using nvidia's nforce drivers directly and it didnt work. We've tried external hd's that have its own power. We've tried a usb s3 patch on asus' website no luck. The only thing I haven't tried is changing psu and updating bios (psu was on the brink b4 but i don't know what happened, it works now at least to my knowledge), but according to the bios logs on the asus site none of them really have anything involving usb fixes. Any other ideas before I resort to a bios update?
  9. kimsland

    kimsland Ex-TechSpotter Posts: 13,810

    Actually can't see it as bios update (ie the oldest bios worked with USB)

    The only one thing, is disconnecting the front USB on the motherboard fully. Then checking back USB.

    Other than that, I'd go for in order of most likely (not cost)

    1. PSU
    2. CPU
    3. RAM (this didn't need capitalizing, but I was on a roll)
    4. MB

    Also have you actually bench tested yet, it would be really sad if it were just a pin lying under the board ! (maybe do this first!)

    Please reply back, when ever you have more results.
  10. jobeard

    jobeard TS Ambassador Posts: 12,282   +1,367

    This is the outstanding issue -- gota get the drivers right before anything else
    will work.

    Run a system profile and get the control type/model. Then google for the drivers. *MAYBE* the device mgr can look for an UPDATE DRIVER, but who knows.
  11. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    ensure you plugged in the wires correctly on the motherboard. It's easy to reverse or make a mistake.
  12. au0

    au0 TS Rookie Topic Starter

    The mb comes with a usb 2.0 I/O module. The pin connector is one entire block and its in right for sure. The front panel is connected properly too. Red white green black.
  13. au0

    au0 TS Rookie Topic Starter

    So I've tested my hard drive on my friend's a8n32 sli deluxe. If i plug in a usb device it works perfectly fine. If i place his hard drive on my motherboard the usb devices aren't detected. I've done a fresh installation of windows and updated it to sp2 again and it still doesnt work. I've decided to send it back to asus for another replacement board...
  14. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 1,997

    Before doing that I would reset the BIOS on the board - have a look in the manual for how to do this. This assumes you have updated the BIOS as recommended in an earlier thread.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...