usb ports powering but not reading devices

By marktips
Feb 27, 2006
  1. About 2 weeks ago, all usb ports on my computer quit reading devices. If a device is plugged in it still powers up, but the computer doesnt see it.

    I have updated BIOS, updated drivers, rolled-back drivers, set drivers to "standard", rolled back SP2 updates (XP Pro), re-installed updates, etc.
    rebooting and retrying devices with each change, all with the same result.

    USB ports are both 1.1 and 2.0. Some came "installed" with the machine, 2 are on a 2.0 card I installed myself.

    All ports worked for several months, again until just about 2 weeks ago when all quit in the fashion described.

    Suggestions? Please?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Get a CD Linux, boot that and see if your devices are found/recognised there. USB storage is the best thing to test with.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...