Using old/new components, install Windows 10 but glitches and won't boot in after restart

So my friend had a Dell Inspiration 3487 and decided to buy a new Case, Mobo, GPU, and PSU while reusing the CPU, Harddrive, and Ram from the old system. We have problems with having Windows 10 glitch out-some applications can be open/launched but can't be accessed but can be seen in the taskbar (after installation), not booting into Windows with a black, blank screen(after restarting), and being forced into the boot screen and bios everytime- unless that's what Asus Z97-A is supposed to do. How do I get Windows to work properly?
PC Parts:

  • CPU: i7 4790k (From old pc)
  • MOBO: Asus Z97-A/USB 3.1
  • GPU: GTX 1050 ti
  • RAM: Samsung (2x8GB) 16 GB DDR3 (From old pc)
  • PSU: EVGA 500W
  • HDD: 1 TB HHD (From old pc)
  • CASE: Corsair Carbide Series SPEC-02 Mid Tower
  • OS being installed: Windows 10 Pro Build 1607

Steps taken:

  • 1) We used "Windows Media Creation Tool" to create a bootable drive- using that to - format the primary (OS) partition.
  • 2) We precede to boot up the new pc however the screen shows "No Signal"- we had to remove the 1050ti.
  • 3) We are presented with "American Megatrends" boot screen and there's a "CPU Fan Error" but we ignore that because the cpu fan is fully functioning. We are forced to continue to the BIOS where we boot on the flash drive with Windows 10.
  • 4) We install windows via Custom and continue on to successfully boot into Windows 10 Pro after going through the "American Megatrends" boot screen and the BIOS again; however, after clicking on some applications Windows seems to glitch around- tabs of applications are open as can be seen on the taskbar but we can't view it. We can still click on things, but everything is basically unaccessable or does nothing including Ctrl+Alt+Del.
  • 5) We precede to restart the pc where we are prompted to go through the "American Megatrends" boot screen and the BIOS again and continue on, but can't boot into Windows. After seeing the Windows icon and loading circle- the screen becomes blank(black screen).
  • 6) We try to reinstall Windows through the same process as before and continue to experience the same thing (Open tabs but cant view it and nothing works, restarts, and black screen) and we repeat about 5 times. At one point, when we try to reformat the drive and install Windows, it says we can't because of something about GPT or MBR but I don't remember.

We've already tried restarting the pc to counter the Windows glitch and reinstalling Windows 10 to counter the black/blank screen(not booting into Windows after the failed restart) I've tried looking up solutions:

  • I've considered possibly it's hardware related with the CPU and RAM being old/unsupported but MOBO supports 4th gen Intel CPUs and supports DDR3 DIMM- unless there's something I'm not aware about that. Maybe test running with single channel.
  • Maybe we should mess with CSM setting everything to UEFI only or UEFI first(Whatever that means and if that setting is available in the BIOS.
  • Maybe switch UEFI to Legacy

Cycloid Torus

Posts: 4,859   +1,679
1. Confirm RAM and CPU are on Qualified Vendor List for the motherboard.
2. Investigate and resolve CPU fan issue - some motherboards will not work properly with this error.
3. Confirm that you can achieve POST without going into BIOS/Setup

The fact that you are continually pushed into Setup means that you have not Setup the system yet. Trying to install OS will be full of disappointment until you have proper setup. Turning off 'automatic reboot on error' and 'secure boot' may make this easier. See