Vista broadband connection problems - please help

By Graham_s ยท 13 replies
Apr 17, 2009
  1. ok I am suffering from the common problem of "limited connectivity only" and "unidentified network" when I try to connect to the internet through an ethernet cable. I can connect through the wireless but the reliability and consistency of the internet is pathetic.

    I have tried all the CMD commands,
    done the broadcast flag thing in the registry,
    tried static IPs and DNS info, tried disabling TCP/IPv6,
    tried setting the network as private,
    tried updating drivers,
    tried different ethernet ports in the router (which is linksys by the way, so thats probably the problem),
    tried resetting the LAN info for windows firewall
    tried turning it off completely and then attempt to connect
    tried adjusting the duplex speed
    tried disabling file and printer sharing on the network

    WHY won't it let me connect through a wire but it will through wireless? I hate wireless and this is driving me criminally insane. Can anyone help?
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I guess you don't have other firewall applications running?

    Have you checked that the adapter isn't blocked in firewall's advanced options? (Control Panel -> Administrative Tools -> Windows Firewall with Advanced Security)
  3. Graham_s

    Graham_s TS Rookie Topic Starter Posts: 51

    I have PG2 and I have tried it with that turned off too.

    I just had a go at the advanced firewall thing but didnt get it to work. I take it you meant I should enable all access to and from the computer?
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Try another ethernet cable, and if possible, borrow another router to see if the same problem occurs, that will tell you if it is hardware or settings problem. Sorry to say it could also be down to the telephone connection and/or filters, noise on the line. If you examine the router handbook, you ought to be able to find all the statistics of the router, like noise margin, attenuation etc.
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Not really, just that the policy isn't to block everything.

    If the connection works to your router - ie. you can configure the router using the ethernet connection - then I'd say the router is to blame.
  6. Graham_s

    Graham_s TS Rookie Topic Starter Posts: 51

    i can't even connect to the router, but the router is really crap, as is everything I have used that's been made by linksys. the last time I used the cable was for the whole of last year, and it was working perfectly. Also, my sister is having the same problems on her computer connecting to the router via ethernet, but as soon as a wireless network adaptor is plugged in, bing! we have internet.

    So I am pretty certain it must be another irritating microsoft thing to do wtih vista, or the router is duff.
  7. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Perhaps it is a case of having two alternative connections to the same device - one wireless, the other cabled. Likely the anwser "is one or the other NOT both at once" !!
  8. Graham_s

    Graham_s TS Rookie Topic Starter Posts: 51

    would that be a problem though I have disabled and disconnected the wireless adaptor?
  9. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Who knows? Vista is stil at the stage where not enough is known about the inner workings, but in your position, I would certainly try not just disabling, but completely removing the driver I found most problematic. Alternatively....

    You do say you have tried updating the drivers, but they are worth looking at again, Vista drivers are still improving. Furthermore, The MS supplied generic drivers are somethimes better than the manufacturer-supplied ones. You could try disconnecting the device then removing all drivers, reboot, reconnect, and see what Vista makes of it. Can hardly be worse than your present situation ?

    Is the linksys old, pre-Vista? Is it on the Vista-approved list of devices? if not, bin it.
  10. Graham_s

    Graham_s TS Rookie Topic Starter Posts: 51

    ok, I'll give it a go. Thanks for the suggestions.
  11. VMSandman

    VMSandman TS Rookie

    Have you tried assigning yourself a static IP for the network that you know is not being used?

    (this also sounds like a problem with the network configuration and not the broadband)
  12. Graham_s

    Graham_s TS Rookie Topic Starter Posts: 51

    yes I have tried static IP addresses

    still no luck with this problem. I have uninstalled and removed the wireless adaptor and the damn thing still wont connect. does anyone know where I can find this list of vista-approved devices?
  13. Graham_s

    Graham_s TS Rookie Topic Starter Posts: 51

    i may have had a bit of a breakthrough. When I let Vista assign an IP address automatically, it gives it the IP address "" which, as I have read from my hours and hours of searching for a solution, is an IP address that vista uses when it can't get a response from the router or something? Is that right?

    Does that give anyone any clues on how to fix it?

    I have tried playing with router settings and MAC address filtering and nothing has worked. I am starting to lose my marbles over this. I can't understand why connecting a cable would be more hassle than wireless...

    It also says that DHCP is NOT enabled on my nforce network adaptor. Could this be the problem? I have entered a value in regedit to make sure that it is enabled, but it doesnt seem to have worked...

    EDIT (again) :
    I just noticed that it says that DHCP isn't enabled because I was trying static IP addresses (again...)
  14. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...