Weird PC and DirectX Prob.

By Nanahara ยท 17 replies
Sep 8, 2006
  1. Alright, I'm new here and I'm curious if anyone has ever experienced this problem before. I'll start out by saying I'm not computer illeterate and have several certifications, hardware and software. With that out of the way...

    My system specs are:
    Asus P4P800-E motherboard
    Intel Pentium 2.53GHZ processor
    2ghz RAM
    ATI Radeon 9800XT
    4HDD's (2 SATA 2 IDE)
    DVD R/W
    CD R/W
    Soundblaster Audigy 2 ZS

    Okay. This weekend is when the trouble first started, I run a webserver off my computer and this weenend the harddrive got hacked or died, that I'm not sure of. But my partition table is completely gone. I cannot recover any of the data with any of the programs I've used, and that's several. Ranging from freeware to 6,000 dollars. Wont pick up any partitions or anything. I started getting desprate trying to find a program and ended up picking up a trojan, and some god awful spyware that I didn't feel like messing with seeing how I just lost a lot of really important data and was too stupid to back it up prior. I know this part has nothing to do with Direct3D but I'm getting to that.

    So, I end up formatting before any of this virus spreads. I manage to get half way though the windows installation and it keeps crapping out on me, then all the sudden my computer wont even POST. So I tear the thing apart and end up having to take my BIOS out and reflash it on a serial flashing chip. So I put it back in and it fires up just fine. I managed to get Windows installed ect.

    So I run through my normal stuff, installing programs drivers updating windows ect. I go to play a game I've been playing for a really long time, Final Fantasy XI, it works alright but I forgot to configure the settings so the graphics aren't all nasty and what not, so I log out of the game and config the settings, go to play the game it wont load. So I install Oblivion and it wont work either.

    At this point I wasn't a very happy camper, and decided to wipe out my computer again. I reinstall windows, don't worry about the windows updates, install the drivers, video driver I used the newest ATI version Catalyst 6.8. Reinstall Final Fantasy, update for 4 hours again, and try to play. Nothing. Install oblivion, nothing. Install Unreal Tournament 2004, Nothing. No games work at all. So I am really irritated and read up on what could be wrong, I update windows, read on playonline that FFXI is tested and working great with Catalyst 5.13. So I downloaded that version and install it. Still not working. I reinstall DirectX 9.0c and nothing. Reinstall the 5.13 drivers hoping it will work, nothing. I went on a live chat with PlayOnline Tech. Support, they told me it was the network, when I can play no problem on my Laptop no problem. So they send me to someone else, they say they have no idea, so no go there.

    After that I decide to format and reinstall again only installing the video drivers no Catalyst control center, and see if that worked. Oblivin gave me a DirectX Error and now it isn't doing anything except what it's been doing. Same with Final Fantasy.

    What it does exactly is the game boots up like normal but the screen goes blank. Oblivion doesn't even go to full screen. Just a little black box that turns white after about 30 seconds. They don't use any processor and it just stays like that constantly. I don't think it's my video card, but it could be. I don't know if the virus is keeping it's self on my computer somehow or what, all I know is I can't use DirectX at all. If anyone knows anything about this problem or has any suggestions please share...
  2. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Hi Nanahara,
    I'd first say grab/burn something a bit simpler in the Direct3D department to make diagnostics and tests a bit easier. Something like 3dmark03 or similar will do as this will be smaller/easier to mess with and might even yield better errors messages than most games with how/where Direct3d initialization is failing.

    I have several of the same boards (except P4P800E - "Deluxe" which I'm guessing your's probably is as well). The most important thing is to get the intel chipset garb solid as well as BIOS (which has it's share of quirks) corrent to begin with else AGP acceleration wont work properly and you'll get similar issues to what you're describing here.

    If you have a current version of the Catalyst drivers installed (say 6.1 or higher) with the CCC, please visit the SmartGART tab and have a look what it's reporting. The ATI drivers will install all fine and dandy... and appear to be correct, but be all hosed. Only the SMARTGART section of the CCC will alert what problems may actually be afoot.

    Also, if you do indeed have an P4P800E-Deluxe, what BIOS do you currently have installed? I'd highly recommend either the 1022 or 1019. Newer 1023 or 1024 Beta have their share of strangeness in my experience.

    Lastly, do not give up if you get a system that *appears* to be basically dead from cold power-up. These P4P800 series can get locked in that mode for several (to several dozen!) power on/offs and eventually come-up okay with a "CPU Overclocking Failed" eventually due to, yet again, some BIOS quirks.. consider it par for the course with these and is trivial once you're expecting it.

    I'd also say grab CPU-Z and if you can host shots of all it's tabs or zip/attach it's html report on the last tab, this might also yield insight to what's going on.
  3. Nanahara

    Nanahara TS Rookie Topic Starter

    Thanks for responding, I do have the deluxe version of the motherboard. I'm running version 1009.03, One problem I forgot to mention, is the Catalyst Control Center doesn't even load. It gives the splash screen and just locks up like the games I've been trying to play. Also, I did run 3d Mark right after I posted the first time, but it was 3dmark05 v120. I don't know how much of a difference that is than 03.

    I posted my 3dmark results and my cpuz dump here:
  4. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Hmm.. so it gets through a complete run of 3dmark05 okay? That score looks about right too.

    I'd be concerned about your power given your overclock, if the CPU-Z is correct. A 133mhz bus Northwood at 160mhz will draw some serious amps, and given how many drives you have + 2 gig, you might simply be running into a weakened PSU unable to pull the draw for beefier games like oblivion, etc.

    Your second pair of DIMMs are also way overclocked as they are PC2100 rated at max 133mhz @ 160mhz. This could also be causing your issue.

    Have you tried manually setting the cpu at 19x133, possibly unplugging (power + sata/ide) all but one drive for a test? This should reduce the draw from the system considerably and at least rule out a weakening/insufficient power supply at those speeds.

    Lastly, I noticed you dont have "performance mode" enabled. While this can be a trick to get working, it's really worth it for memory performance. It's the memory acceleration setting in the 2nd/3rd page BIOS, but usually needs the CPU setup manually and timing at [Normal] in the main CPU settings BIOS page to get it to boot this way.
  5. richie7000

    richie7000 TS Rookie Posts: 18

    gday mate...sounds to me you could poss have a poorly seated vga card...or a corupt ver of direct x9.0 or poss the wrong updated vga drivers will keep youre probs in mind.
  6. Nanahara

    Nanahara TS Rookie Topic Starter

    Okay I went into the Bios and turned my processor to the normal clock speed. Then I turned performance mode to Standard, I restarted and it gave me a weird *** error that I got before, it says:
    After that I restarted and turned everything back the way I had it before in the bios and it did it again. Slightly different error, so I went back in the Bios and Loaded Default Settings, booted up just fine. No games work with the default settings either. Also, I don't think it's a power issue, I have a 600w Power Supply
  7. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Hi again Nanahara,
    It wouldn't be a wattage issue if it's a weakening PSU, but instead an amperage problem on the 12v rail. At those kinds of clock-speeds, it'll draw substantially more amps and likely running at your PSU's peak amp rating full-time with no overhead.

    I would recommend the following test:
    1) Download/burn memtest86+ onto a floppy or cdr.
    2) Remove the two PC2100's so you're down to 1gig of PC3200 (2x512). I'd chose the two colored slots for dual-channel.
    3) Adjust your BIOS to Auto for CPU, Normal/Standard for timings, Performance Mode: Off
    4) Ensure your memories are being detected as DDR-333 or DDR-266 (which is actually correct for DDR-400's on a 133mhz FSB CPU).
    5) Boot off the memtest86+ cdr or floppy and let this run for at least 6-7 full passes.

    This will dictate the memory stability at stock speed/fsb/bus.

    Only from here can you start bumping things up to determine the issue. Past this, you can then ramp up your FSB (Overclock) and test with the PC3200's, which are rated to run at 133/166/200. Your PC2100's are only rated to run at 100/133, so 160mhz is not only a big stretch, but will draw substantial amperage from your rail. CPU at 160mhz will also near-double the amperage draw.

    In all honesty, the only success I've *ever* had with the i865 series & overclocking has been had on PSU's with at least 30-35A on the 12v rail, which limits this to Antec Neo, Tri-Power or PCC&C PSU's, which can *sustain* 30A on the 12v, rather than this being their utmost/stretched peak. Other brands can accomplish this, but not smoothly and overtime will start to weaken under this load.

    Interesting aside, and only if you're interested, I was in the same predicament with my GF's PC, but it had a Nortie P4-2.53/533 and also OC'd to >3.0ghz. Her SmartPower 2.0 putzed out on amps, so replaced it with a Neo. Eventually got tired of the electric bills (>110W for 3.0ghz to boot!). My only reason for not updating was because I'm also a big Northwood fan and HATE the hot, crappy, 478 Prescott cores.

    I found two local dealers that have old Nortie P4-3.0ghz/800s coming out of their ears for $80-$90. They also ship:
    $93 -
    $88 -

    You'll get your 3.0ghz core speed, 200mhz BUS (but you'll have to upgrade your two PC2100's), and back to the standard low amp draw and 61W cpu consumptions (plus coooooler.. mine idles at 30C, peaks at 41C with stock air cooling). And heck, if you're still into overclocking, I can hit 225-230mhz FSB with peaks in the high 40's. hehe.

    I'm still leaning towards your system needing either more power or those other sticks of memory are finally stressing from the load. You'll have to work with the BIOS and memtest86+ to get stability with NO errors here before you can get XP/Direct3D to work properly. Also realize you're likely running your AGP bus way, way over the 66mhz speed given your 133->160mhz update and your 9800XT may be weakening from this load as well.

    Good luck!
  8. Nanahara

    Nanahara TS Rookie Topic Starter

    I ran through all the passes, no errors. Took out all my ram but one 512. I've set everything to Auto in the bios for the cpu, problem still persists.
  9. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    You're jumping ahead of the game, friend hehe.

    First, don't set-up with one stick. You want 2x512, DDR400 for dual-channel.

    Once you've got this determined "stable" @ 133mhz, BIOS settings (using memtest86+), THEN you're going to want to format/xp install.

    You have to understand, @160mhz + possible powerage issues, you really cannot trust all the files that hit your disk during the install.. even moreso if you were getting exceptions after this. Same problem occurred here and still finding random files (zip's and stuff) that are all-out corrupt from the bad memory timings/memory issues at the higher speeds.

    Realize that when overclocking in this way, for every blue-screen or error you may encounter, Windows may have had like 200+ memory errors and corrupted files hitting the disk. This is why you absolutely MUST get a stable/verifiably stable/reliable mem timing setup, THEN squash the drive totally and lay down "known good" images to disk for boot.

    As installs were done with the 160mhz bus on PC2100's in the second bank, for all you know a good portion of the \Windows folder are corrupt from cab -> inflate process.
  10. Nanahara

    Nanahara TS Rookie Topic Starter

    I have the processor that I upgraded from, it's a 2.0... it works great I just came into this one free. Do you think I should swap it out for the clean install as well for testing purposes?
  11. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Absolutely.. what you really want is a "known good" laying of the OS onto the disk, with no possibility for corrupted files.

    It's amazing how many corrupted files can occur without even being noticed by Windows XP when you have a cpu/memory failing or flakey!

    Just about everything my GF downloaded/patched or wrote to for an entire month has some level of corruption... completely unnoticed. Even a few GAME patches I have.. once applied on her new system have texture bugs. Talk about lack of CRC's in Win installer stuff.. ugh. Turns out the patch downloaded has a few bits here and there twisted.. unnoticed yet still works.

    This may have been the whole cause of your initial failure- flakey memory twixing the track/sector values for a read/write operation.. hitting the MBR blocks instead of larger values for the middle of the disk where it intended to write. Not uncommon, but you won the lottery on random luck. :D
  12. Nanahara

    Nanahara TS Rookie Topic Starter

    Well swapping the processor went down the drain. I took it out of my old motherboard and it had a bent pin probably from my brothers kid messing with them. So I tried bending it back and a pin snapped. Lucky me. Lol
  13. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Ah man.. tough luck.. :(

    Well, now you have a good excuse for a brand new P4-3.0ghz/800 Northwood, right? :D
  14. Nanahara

    Nanahara TS Rookie Topic Starter

    Interesting thing happened. I took my PC down to my bigscreen TV and hooked it up though S-Video to watch some movies on the big screen. I couldn't get it to display anything but black and white. Then I tried opening up ATI Catalyst Control Center for kicks and it fired right up this time. So I brought my PC back up, noticed that in my one VGA slot it wont work but if I put on the DVI Convertor and plug my CRT into that CCC fires right up. Still does the same thing on games however. Any thoughts?
  15. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    I'm pretty confused at this point.. hehe. Did you actually get the 2.0 to work or did you not put it in at all?

    I think I'd still say go back to the original plan- which would be to stock-clock the P4-2.53ghz (19x133mhz) with the pair of DDR-400's in the colored slots for dual-channel... run BIOS to where memtest86+ works 6-7 passes with 0 errors, then mash/format one(1) drive (with the other's unplugged) and lay down a FRESH XP install.

    After this, install the latest intel chipset from, then .net 2.0 framework, then the Catalyst 6.4/6.5/6.6/6.7 or 6.8's... finally directx web install from
  16. Nanahara

    Nanahara TS Rookie Topic Starter

    I did all that and nothing happened. :( I really think my video card is dying. That or my processor. I just had some huge huge lag issues with testing my video again. It completely locked up for 5 minutes. I decided to wait it out to see if anything would happen. I couldn't pull up task manager or anything, so tomorrow I'm going to go to my cousin's computer shop and see if I can do some testing over there. Hopefully to return with good news. :)
  17. Nanahara

    Nanahara TS Rookie Topic Starter

    I figured out what it was. Comes to find out it's my Soyo X-Series Playstation Controller to USB convertor... I unplug it and it works fine. How's that for crappy.
  18. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    I'd say that really leads to the initial amperage problem we were discussing earlier. Having a USB device is plugged in is mainly a power issue if it's causing exceptions in windows.

    Could also just be blind luck or random. Keep benchmarking your system to see if you can get it to crash with the unit unplugged. It may have just reduced the load a tad and under a peak flow, might just crash again if it's still a problem with amps/power.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...