Western Digital 1TB external hard drive problem

By rismail
Mar 21, 2012
Post New Reply
  1. Hey guys, I have a Western Digital External Harddrive that's 1TB. Its probably been a year and a half old now but recently whenever I would plug it in it would take really long to load. Now currently, whenever its plugged in, instead of showing up as My Passport (G:) like it always did, its reading as Local Disk (G:) and Windows Explorer freezes everytime I even attempt to click it. Help please, I have over 300 gigs of music on it that I need for parties as I am a DJ. :(
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    Have you tried accessing this drive on another computer?
  3. rismail

    rismail TS Rookie Topic Starter Posts: 17

    Yep, same exact thing happens. It shows up as Local Disk G: and does not load when clicked on. I have also tried uninstalling and reinstalling the drivers.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    Well, I guess there's not much else to do. The drive is most likely bad. I guess you know now, that if some stuff is really important, you must back it up in several places. In your case, another hidden away hard drive would have been nice to have

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...