Why doesn't my dir-300 router's parental control work?

By samnorr · 6 replies
Oct 19, 2008
  1. I clicked on "Turn parental control on and deny computers access to ONLY these sites", entered the website url in the box, ticked it and set the schedule to always. But when I try to access the blocked web page it takes a little longer than usual but then loads on the website normally.

    The two sites entered in the boxes are the ones I've tried to test the feature with, but both are not being blocked.

    Can someone see anything I've done wrong?

    I have tried emptying the cache and rebooting the computer and router, but still the pages just refuse to be blocked.

    What's happening??? Advice would be appreciated.

    Attached Files:

  2. jobeard

    jobeard TS Ambassador Posts: 11,167   +986

    hum; did you try just the domain name without the http:// ?
    also try without the trailing / after the domain name
  3. NetCablesPlus

    NetCablesPlus TS Maniac Posts: 228

    If jobeard's suggestions do not work, I would consider checking to see if there is a firmware update that can be installed for the router. Other than that, it would seem to be time to call their tech support people.
  4. samnorr

    samnorr TS Rookie Topic Starter

    I have tried writing the domain name in both forms suggested above, with no luck.
  5. samnorr

    samnorr TS Rookie Topic Starter

    I thought that surely there would be someone else with the same model router, who could try out the feature. Advanced parental control is listed as one of the major features of the DIR-300, so surely it would work effectively.
  6. samnorr

    samnorr TS Rookie Topic Starter

  7. samnorr

    samnorr TS Rookie Topic Starter

    UPDATE: I just went to the D-Link website and downloaded and installed firmware version v1.04-tomi-1.1.2 ( I don't know why, but it wasn't showing on Check for Updates). I wasn't expecting it to do anything, but amazingly, it has completely fixed the parental control problem!

    The router now effectively blocks any site I set it to, and can do so just by having a keyword entered into it (like "google" instead of "www.google.com").

    Thank you very much to everyone who has been helping me. :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...