1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Wifi not working, ethernet does

By brayford ยท 6 replies
Aug 14, 2013
Post New Reply
  1. Hi guys, first post here. I don't know much about tech so joined here for help. I moved into a new house (rented) and we have virgin media internet with their infamously reliable super hub ;)

    I can connect to the internet fine with an ethernet cable but only get "local" access when attempting with wifi. My friend can get on wifi fine on his laptop and my wifi works fine on other networks which leads me to believe its just some settings that need changing. I will try to attach a picture of my ipconfig with wifi switched on and no ethernet cable in.

    Any help on this would be much appreciated, I've googled for hours and hours but nothing anyone suggests on there has worked for me.

    Cheers for any replies

    Attached Files:

    • ip.jpg
      File size:
      255.7 KB
  2. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    Is that Cell phone internet your using there. Disabled Wired connections when using WiFi connections don't have both enabled. Also are you sharing internet or WiFi in this building?
  3. brayford

    brayford TS Rookie Topic Starter

    I'm using the ethernet cable to be online if thats what you mean? And yes there is four people in my house but only two of us here at the minute. My housemates laptop works fine on wireless and cable but mine only works on cable. I have been unplugging the internet cable when trying to connect via wifi but still no luck.
  4. tipstir

    tipstir TS Ambassador Posts: 2,839   +193

    Your laptop is it on Windows 8, Windows 7 or iOS?
    Did this ever work for you the connection on WiFi?
    If it did what has changed since then?
    Are or did any of you enable Homegroup on Windows if your on that OS?
    If so disable it.
    Use Workgroup and make sure you gave your network a Name.
    So you have to WiFi on your PC or just Ethernet.
    Do not enable WiFi and Ethernet connections you only should one only enabled. Disable the other.
    You say your friends are okay. Did you check their settings to match yours?
    Make sure you are on IPV4 and not have both IPV4 and IPV6. Look at their settings to see what they have enabled.
  5. TheHawk

    TheHawk TS Enthusiast Posts: 32   +9

    Hey Brayford. f you haven't already done so, I would go into Device Manager and find your Atheros wireless adapter, right click on it and uninstall it. Keep the driver if asked, then reboot. Allow the "new" hardware to be found, and when all is ready, try and detect and connect to your wireless network and post back.
  6. brayford

    brayford TS Rookie Topic Starter

    Sorry I took so long to reply guys, it's been a hectic few days.

    My laptop is Windows Vista.
    My WiFi works but hasn't ever worked on this connection in my new house.
    Not sure what Homegroup is?
    Only use the ethernet with WiFi switched off or WiFi switched on with no cable in.
    I have IPV4 and IPV6 enabled but did on other networks and it connected fine. Also I tried disabling IPV6 but I still couldn't connect to WiFi.
    I'll double check to make sure my settings match my house mates but I'm certain it did.

    I'll give that a try, so it should automatically find the adapter when I switch WiFi on after the restart and install in automatically?

    Cheers for your help guys, I am very grateful for it!
  7. TheHawk

    TheHawk TS Enthusiast Posts: 32   +9

    Vista should find the wi-fi adapter and reinstall it. I always try the simple stuff first. What Service Pack level is your Vista on, 1 or 2?.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...