Win 8.1 system lag spikes/slowdowns when copying/downloading files

By awac1991 · 15 replies
Aug 10, 2014
Post New Reply
  1. Hi everyone, I'm new to the forums but I have been reading a lot here these days so I thought I will give it a try [​IMG] I’m Sorry if this is not the right section of the forums, but it’s kind of a general problem [​IMG] Full System Specs at the bottom:

    I just upgraded my computer putting an eight core AMD FX-8350 into a new motherboard (RAM, SATA HD and Graphic Card are the same old ones) and I’m experiencing serious lag whenever I’m copying files from external HD to local HD or even from one drive partition to another. I started noticing it when taking back some GBs of music and files from the previous computer: the mouse lags heavily every now and then and programs become laggy and unresponsive. Knowing that this might be completely different issue, exactly the same happens when downloading a game from Steam. My connection is really bad (600kbs at its best) but I have to clarify that I had NEVER experienced this kind of system slowdown in my i3 / win7 previous to the upgrade, and I did really heavy file copying and downloading…

    During this lags and slowdowns when copying files, CPU activity stays low, but Disk activity is 100% through all the process

    I have been trying several options that I found around the web but the problem persists. I’m starting to think something is wrong with my Hard Drive or RAM. Thanks in advance for any ideas that might help, here are some notes in case you feel like looking into it:

    - I have already cleaned registry and defragmented the Hard drive
    - I have 2 partitions of a singular 1TB hard drive. I experience lag when copying from/to both of them
    - I haven’t discarded that the lag when downloading is due to the “Qualcomm Atheros Killer E2200” system included on the motherboard (it’s supposed to prioritize incoming traffic for games and such)
    - I have read and tryed many of the things mentioned in this post without any result:

    Sorry for the long post and sorry if im not being precise enough...I've tryed many things these days so I cannot recall them all. Ask for any details you need and thanks in advance for the help guys.

    Full System Specs:
  2. awac1991

    awac1991 TS Rookie Topic Starter

    *tried. Sorry for that :_)
  3. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    In one specific case you mention you are copying from 'an external HDD' which would mean a USB connection. This might be USB3 or USB2. Your motherboard might actually have both or maybe just USB2, and if you are using more than one USB device at a time (I.e. two external devices, mouse, internet adapter, anything else), then the USB speed becomes divided between them. You would certainly find 'lagging' symptoms if you have a USB2 connection, and if your mouse is USB too, that would account for the mouse lag.

    However, on balance, you should probably suspect your old HDD. It could be the HDD is operating through a USB2 adapter, despite your m/b having USB3, or maybe it is slowly dying. You could test it and chkdsk /R on it. Test it in another PC and if it seems to buzz along at the speed you accustomed too, you probably have a m/b hardware problem or a driver problem. Not easy to pinpoint either.
  4. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    Hmm; First run CLEANMGR from your personal account and then again from the Admin account. This will free up more free space.

    Investigate the target device for free space available - - if it's less than 10%, you will have issues for large volumes of hd writes.

    If so,
    1. first delete old stuff you don't need. See this thread for clearing obsolete MS Updates
    2. Once you have pruned the scruff off the system.
      1. {a} run Checkdsk C: /F
      2. {b} THEN defrag the disk
    HD performance should improve.
  5. awac1991

    awac1991 TS Rookie Topic Starter

    Thanks both for your quick replies.

    Regarding the USBs, the new motherboard has 6x USB 2.0 and 2x of USB 3.0. I was having slowdowns when copying from/to any of those (I've tried all the combinations, including plugging the HD to the frontal panel USB) and im also experiencing the slowdowns when copy from one partition of the disk to the other. My mouse is plugged to one of the USB 2.0, so I will check that.

    To JoBeard: I did already run CLEANMGR and im doing right now the win update, but I doubt I will be able to free any space from previous updates since I've jsut installed win8.1 from zero and I didnt install any updates yet. I will also do the Checkdsk and posterior defraging and tell you if its solved.

    Thank you very much!
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    If it is really the exact same thing as in my thread that you linked in your first post, the only fix seems to be disabling Superfetch. I never tried it on my machine because by the time that was suggested I didn't even run Win8 anymore.

    You said you tried many things in that thread, but didn't mention if you tried disabling Superfetch or not.
  7. awac1991

    awac1991 TS Rookie Topic Starter

    Well, after last defrag I didn't have the Lag issue again, but my CPU still gets too busy when simply exploring the web with 5 or 6 of tabs in chrome or when downloading files via direct download, dropbox or steam...

    I disabled SuperFetch but the lag was not happening anymore so I can't tell if that helped or not but I didn't notice any difference in performance either. I will keep monitoring the CPU with SuperFetch enabled and disabled.

    I'm still experiencing some weird 100% disk usage peaks that are not accompanied necessarily by a CPU peak…I will provide some screenshots. Notice that at the moment of the screenshots just Chrome was opened with a couple of tabs and not much more. The cpu looks normal at this stage but I cannot explain the heavy disk usage peak.

    Thanks for all the answers so far, I’m really lost and trying to solve a very general problem and I don’t know really where to focus.
    performance. procesos.
  8. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    Consider disabling the Windows Search and Index service for the time being
    Whltng and gbhall like this.
  9. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    When downloading or copying large numbers of files, what if every single file has to be processed? That may be happening as described below.

    It can be caused by scheduled anti-malware running (checking each file). You can actually be unaware it is running until you look for logs. Some versions of anti-malware get a reputation for being an interfering @:&*^% but an update can cure it (or start it off). You cannot trust anybodies' versions to be consistently good.

    Windows index service is one of the most pointless products ever (indexing each file contents). I'm with @jobeard - I never let it run - but then I don't have 100,000 documents that need to be routinely searched (nor does anyone else I would think). Brute force search is always good enough.
    Last edited: Aug 14, 2014
  10. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    I don't think thats it though. Any system since about 2004 has been able to handle all kinds of downloads at once at much higher speeds than OP says he can dl at. He linked back to a thread I created with Win 8 when it was brand new, over time many more people came into that thread with the same issue. Typically we'd like to see OP have posted a reply to that thread since it is the same issue, but I'm forgiving that this time since that thread is pretty old and big at this point and few people would read it from the start.

    My point is, this is apparently an issue many people are having and there is not a cure-all for it. Superfetch being disabled is the only thing that anyone has posted that has worked for the fewer that have tried it.

    OP's issue might have been fixed by the superfetch disabling and it is some other issue that is causing momentary peaks. The original issue wasn't a short peak though, it would be sustained throughout the file transfer. Which can be hours if you are dealing with tens to hundreds of gigabytes at the reduced speeds everyone that has this problem was/is seeing.
  11. awac1991

    awac1991 TS Rookie Topic Starter

    Thank you again for all the answers.

    Firstly, SNGX1275 is totally right: I just opened a new post because I thought my configuration was different (which could or could not be relevant) and also a long time has passed since that post.

    I tried for example opening a Cubase music project, which involves pretty hard processing and disk searching for all the audio files. This immediately caused the “Windows Indexing” process to rise to the top of the CPU usage, and put my disk on 100% usage.

    For the time being I disabled both Superfetch and Wsearch services, and when performing the same task (opening the same musical project on Cubase) the disk usage was much lower. Memory usage goes up as expected and I jsut get the CPU peak during the 5-6 seconds of loading the program. (Screenshot)

    Still there’s some CPU peaks but I think is reasonably within the AMD processor usual values. I’m also considering getting a new and better CPU cooler since the one that comes with the processor it’s pretty noisy and doesn’t seems to cool much :/ I’m getting 50 to 60 Cº temperatures at relatively low CPU usage.

    I will continue using my computer with both services disabled for a while and tell you guys how it’s going and if that solved the problem once and for all! Thank you very much again!
  12. awac1991

    awac1991 TS Rookie Topic Starter

    Well, after several days of normal working the issue didn't showed up again! Seems that disabling both Superfetch and Wsearch services did the job for now and im not noticing any disadvantages from disabling them so... Thanks everyone for the help! :)
  13. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    There is a issue because what's running underneath the OS. I am there now. You can disable some services to help improve the OS. LiveComm and GLS Windows Reader (still doesn't seem to be running always) App like Jetboost can fix some issues but it's a only a temporary solution.

    I made Jasper for TCP/IP that helps with my network shares so they are quicker. But like in all Windows OS Microsoft defaults the buffering to the very low defaults.

    Metro Apps that has all sorts of extra system resources hogs running.

    I manage the system with.
    JetClean Pro (deep cleaner and RAM scrubber)
    WiseCare 365 Pro (working with them directly to help improve their software)
    Uncleaner V1.7 Freeware (focus more on Windows System Folders)
    Free Windows Tuner V2.0.1.3 (this one seems to do a lot more than just cleaning RAM)

    Once all that is done for secondary level for firewall Firewall Control 64-bit blocks anything that is calling back to the maker that doesn't need to be using any TCP/IP.
  14. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    Tipstir - I don't think you understand what the OP's problem was, he even linked to a much larger thread with a lot of details on the problem and said it was the same. Disabling superfetch fixes it.
  15. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    I am sure there are problems like he as described, I am just saying what I do to correct the issue. I haven't disable those services he had mentioned, but there are others that can be set to manual instead of auto/start which are not needed. I just got the end of the stick as we say with this thread.
  16. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    But the TCP/IP stuff has nothing to do with drive to drive file transfers. This isn't only happening on a network transfer.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...