Windows 7 computer says connect via ethernet and ping confirms but cannot get to any page

I have a Windows 7 HP desktop system that is connected to the internet via an ethernet cable. The system says it is connected, and a ping confirms it is accessing the internet. BUT, all the browsers say the computer is not connected to the internet (tried Chrome, Firefox and IE). All of the Microsoft network adapters (6to4, ISATAP adapter, ISATAP adapter #2, Teredo Tunneling Adapter) shown under device manager cannot start (Code 10). the Realtek PCIe FE Family Controller is the only network adapter shown as working properly. What do I need to do to fix this? Let me know if there is any other information needed to help me.


Posts: 2,854   +200
Does your router see this computer on the network?
Are you on Private Network or Home Network?
Is the IP address showing 192.168.x.x or is it showing 169.xx.xx.xx?

NIC network card you can do a few things. You can can disable it and re-able it.
Open dos prompt
type: ipconfig /flushdns
type: ipconfig /release
type: ipconfig /renew

Give this a sec or two.

Now under services.msc (use the control panel and type services)
Select view local services
Scroll down for
DHCP Client (right click and stop it) wait then right click and start it
DNS Client (right click and stop it) wait then right click and start it

If none of the above work go into the device manager. under control panel type: device manager. click on device manager

-Network adapters
-Realtek PCI-e this one uninstall the drivers (BUT DO NOT DELETE THEM)

Two options here.
One: Scan computer for new hardware changes
Two: Reboot the PC

Choose Two, because Windows will re-install the drivers and setup network card settings. for you. The Choosing One would do that same but you really want to flush out any prior issues that got you to this point.
I am on a home network. The router sees the computer IP address as 192.168..

Already tried the dns flush. The other two ipconfig commands will not execute. IT says No operation can be performed on Local Area Connection while it has its media disconnected.

I uninstalled the Realtek driver, rebooted and it reinstalled it. BUT, it now does not even show the computer is connected to the internet.

What next?


Posts: 2,854   +200
Are you running both IPV4 and IPV6 on that PC?
Tell me what has changed prior to getting this issue?
Has the internet worked on this PC where the browsers would connect?

Ping www.techspot from the PC under dos prompt.
Can this computer access files from other PC on your network.
Your router when last did you run a firmware update? Have you ever power cycle this router. Turning it on and off. The same with your modem.
Not sure how to check the IPV4 and PIV6.

All other computers on the network are working perfectly. I have one other desktop that is connect via ethernet and several laptops connected via wifi. None has an issue.

I am connected to the internet via a U-Verse Gateway. I have cycled it a couple of times when I first started having problems with the desktop.

I think this started after I discovered YAC on the system (Yet Another Cleaner). It was also on one of my laptops. I managed to uninstall it from both systems, but the desktop has had this problem since then - I think. I tried running a restore to a couple of different points, but it did not change anything,
Sorry. I think I said in the first post that the ping indicates it is accessing the network, but I forgot to address again in your second post.


Posts: 2,854   +200
YAC was on the system then you remove it and now you have the issue with connection.

run as admin
open dos prompt make sure your at C:\>Windows\system32 and type each line then press enter

nbtstat -R

netsh int reset all

netsh int ip reset

netsh winsock reset

reboot the PC

YAC issue could have mess-up something in the registry. 3 cleaner apps you can try. Uncleaner V1.7, WiseCleaner V8.35 Toggle Network to be clean and JetClean V1.50. Run those in this order manually. Under JetClean toggle DNS, IIS to be cleaned.

One note: Try to do a system restore prior to when YAC was on the system when you were able to connect to the internet. If you still can't it to function. Of course you can do something to the NIC but it might boil down to a corrupt registry after YaC was removed.
Last edited:
I don't know what all that did, but I am back in business! A very large THANK YOU! I will run the cleaners now. So glad I found this site.