Windows explorer very slow and locks files up

By starbearer ยท 21 replies
Jul 6, 2010
  1. Hello,

    I'm having the exact same problem posted by Karmashock here: (please add www as I'm not allowed to add links) However, the fixes mentioned in that thread aren't working for me.

    -Explorer takes ages to open a folder and display its contents. Most of the time displaying the flashlight which you see while browsing a network drive
    -While trying to delete a file, most of the time, I receive the message that the file cannot be deleted
    -On using "Unlocker", majority of the times it as being locked by Explorer which is preventing it being deleted
    -Problem solves temporarily for 5-10 minutes or so when right clicking on the start menu and then opening 5 to 10 "explore all users" but it comes back every-time
    -Problem not seen in other file managers like command prompt, Nero file browser or even XYplorer

    There are no network drives which I use. In fact, this is just a standalone PC without any home network.

    As mentioned in the above thread, I have deleted the "Windows" folder from "c:\documents and settings\<profilename>\local settings\application data\microsoft\" by logging in through a different admin account but that hasn't made a difference at all.

    I would really appreciate if someone can suggest a solution as the only once I'm seeing now is a fresh install.

    P.S. I'm using Windows XP SP3 with most latest updates installed
  2. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Easy step to make sure it isn't just Explorer doing it: Go to Run (Windows Key+R, or startmenu>run) then type C:\windows\system32\dllcache
    In here you will start to type Explorer it should locate an explorer file. Take this and place it into the "c:\windows" folder.
    ***************If you do not want to replace the file, you could just try running it inplace of your explorer. Open Task Manager, go to the Processes tab, click Explorer.exe then End Task. Go back to the Application tab, and do New Task. In that box, type "c:\windows\system32\dllcache\explorer.exe" ***************** This will instead just run this explorer and see if it is the explorer that's having troubles

    You could either: Try going back from SP3 to SP2 then reinstalling SP3, might reinstall or fix any problems with Explorer..

    Could try and do a system Restore back to when it WAS working(Make sure if you are doing a system restore, if you restore to a previous date, UNDO The restore before trying another restore point as this can make windows even worse.

    Although it never seems to work(for explorer issues), I'll leave it here as a suggestion:
    Try doing a check disk (go to a command prompt, type chkdsk /f /r)
    click yes, restart your computer, let it go through.

    Could also try system file checker: in command pompt type sfc /scannow (yes there are 2 n's)
    If any files are corrupt it will probably ask for the system disc, in which case you will need your installation CD, it will ask for the CD for EVERY file it finds/wants to replace... so, don't assume it's not the proper CD. But You will probably need a SP3 disc to be able to do it, so it replaces with the correct version..

    You could also try creating a new user profile, seeing if that user has it, if it doesn't then it is to do with that profile, you can simply copy over all your documents over to the new profile and work from there, unless you would rather fix this issue.. Post back with results and anything else you have tried.

    A few minor things to ask: Have you recently changed any settings? Even your desktop background, taskbar/folder layouts, any modifications.
  3. starbearer

    starbearer TS Rookie Topic Starter

    Thanks for your reply ComputerGuy55,

    There was no explorer.exe in the dllcache folder. I don't have system restore enabled as I've experienced that it creates more problems than it fixes. I'm re-installing SP3 now. Will let you know how it goes. Thanks again.
  4. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    was there an explorer file even? Or nothing at all? Doesn't have to have the extention on it.
  5. starbearer

    starbearer TS Rookie Topic Starter

    No there wasn't. There were other files but explorer was not present.

    I've re-installed SP3 now, but the problem is still there.

    I do see that the explorer.exe file has been copied to the dllcache folder now. On checking the explorer.exe in c:\windows and in the dllcache folders, both their sizes are exactly the same (1,033,728 bytes). I know that its possible that both the copies are the same from the new SP3 installation, but since the problem is still present, it would point to something other than the explorer.exe file.

    I wasn't able to do a sfc /scannow as the XP CD is have is SP2 slipstreamed so if it compares the files, it would be doing an SP3 with SP2 comparison. I can always make a slipstreamed SP3 CD, so let me know if i should.
  6. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    It would work, you could try that but i doubt that it will fix your issue. It is more then likely something to do with the profile itself. Have you already tried creating anohter profile on the computer, seeing if it has the same issue ? Also have you tried safe mode? See if it's maybe a service/program that runs?

    To get to safe mode, while the computer is restarting tap F8 until you see a boot-up selection screen and just choose Safe mode with Networking, does the problem presist in safe mode as well?
  7. starbearer

    starbearer TS Rookie Topic Starter

    I've created another user and I'm using that now. The problem is that once the PC is rebooted or if I log-off and then log-on, it runs fine for 30-60 mins. It only starts lagging after some time. So I never really know if the problem is completely solved.

    I will try safe mode with the old account once I'm sure the new account doesn't have the problem in it as well
  8. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    What is your anti-virus and firewall? This may not be due to windows files problems but simply virus or trojans.
  9. starbearer

    starbearer TS Rookie Topic Starter

    eset nod32 and windows firewall.

    And the new account is working well so far. Has a nice freshly formatted PC feel :-D
  10. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    Hmm that confirm that it can be a virus problem then. I would recommend you to change to Avira anti vir free version and make a scan and recommend you to use Comodo Firewall free also for your PC. They are the best in their category.
  11. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    If your going to use any firewall at all I would suggest purchasing one.. Free ones don't get the full job done..

    But glad to hear the new account seems to be working well, test it for a day or two and see how it runs, Do you know how to transfer all of your data over from one account to another?

    if you use any E-mail client programs it will be a bit trickier but for the most part it's simple stuff.
  12. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    Same that's good to heard that it work but this may not continue for long. If you got the same problem once more then a clean install of windows will be needed.

    ComputerGuy55 I agree with you about free firewall and antivirus but for Comodo Firewall i'm using it for about two years and never get any problem it does its work well that his alert me for anything suspicious even when my friend connect to my network for the first time. Everything is check by it. Avira Antivir it does well its work as I use other paid program before and was unable to find those virus and Avira did it well.
  13. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Yeah, I use Corporate McAfee and it does the trick for me, havent had a virus on this laptop or my dads, sisters, moms, 2 desktops.. all running it and never get infected, its great. then again I know what to avoid.
  14. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    Yes it can say that there is no virus but this does not mean that there is no virus. I prefer my antivirus to tell me that it has detected a virus than nothing as when detected I know it is working.
  15. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Oh, it does find things when they happen, I've downloaded files and it stops it before it finishes, went to websites it blocked, put in a flash drive that it wouldn't let load specific software. I also scan with Malwarebytes and Superantispyware at the beginning of the month to see if I have any infections, and never have any.
  16. starbearer

    starbearer TS Rookie Topic Starter

    I've done a full C drive scan and there aren't any infected files. I even did an online scan. Didn't find anything. Its most likely a profile issue or a broken registry issue. I've also used RegVac, but even that didn't do the issue much good

    For migration, I'm basically copying over the files which I need from my old profile into the corresponding folder into my new profile. If there's any set process to migrate, please do let me know
  17. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Nope, you have the right idea. Desktop, Favourites and Documents can be transfered over with ease and they cooperate with the new profile.

    However if you were using an email client (Outlook, Outlook Express, Thunderbird etc) You would have to transfer the Address book, e-mails and Profile, though it isn't too difficult.
  18. starbearer

    starbearer TS Rookie Topic Starter

    Ok, its back. It happened a couple of times in the new profile. Now I'm desperate. I'm ready to do a clean install but I would still like to know whats causing this and how to avoid it in the future. If anyone has any suggestions please let me know.
  19. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Do some hardware tests on the RAM and HD. If you can I suggest getting another harddrive if you can, reload windows on that and see if the problem happends.. Dont want to reload and find out it still happens

    Also you said the problem is back, after you copied over the data from your previous profile? Something must be corrupt in the old profile, I would suggest creating another profile. Run it for a bit without transfering any data over.. If you need something off the profrile just go and copy that file or use it from where it is located. After a day or two of testing, if you don't see the problem. Copy the desktop folder over, run it for a few hours or a day, see what happends. If no change, do the documents, see what happens..
  20. Ultiweap

    Ultiweap TS Enthusiast Posts: 606

    If the problems continue to persist I would recommend you to change Antivirus and make a test.
    Here is the link: Avira Antivir Personal

    I think it may be a virus spreading in the PC and when you create another profile it spread on it after some time and do the same.
  21. starbearer

    starbearer TS Rookie Topic Starter

    OK it wasn't a virus problem. I scanned using the latest definitions using different virus scanners and nothing malicious came up.

    I did some more searching online and tried a few things:

    -Deleted the "Windows" folder from "c:\documents and settings\<profilename>\local settings\application data\microsoft\" from all the existing profiles including Administrator, All Users and Default User
    -Installed and ran TuneUp utilities. Tuned up whatever I could. Don't remember now what exactly was changed.
    -Defragged C: drive

    I dont know which step cleaned it but the explorer locking and the flashlight problem is mostly gone. I do experience a few occurrences of explorer crashing and then a new instance opens up but atleast its usable now. There is some progress.

    I think it was the 1st step as it could be that the folder was being copied from one of the other profiles. Just my thoughts. Thanks again for all of your help and time.
  22. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    No problem, glad to hear you got it to a usable state.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...