Windows Firewall not turning on

By NineMilesHigh
Dec 4, 2009
  1. Hi.
    I am requesting help for an apparent issue with Windows Firewall.
    In a separate thread, Bobbye recommended I install a better Firewall such as ZoneAlarm or Comodo - and I intend to take that advice.
    However for the moment I think the issue I am seeing is a wider issue than just the Firewall.
    PC is a Dell Dimension 4600, Windows XP (SP2), 2.5GB mem.
    On starting Windows, I get the warning 'No Firewall is turned on'.
    In Security Center, there is an option to 'Enable Now' the Firewall. This results in 'Security Center could not turn on Windows Firewall'.
    When I click on Windows Firewall in Control Panel, it gives 'Due to an unidentified problem, Windows cannot display Firewall settings'. If I try to run IE, the egg-timer comes on for a few secs and then nothing happens.
    When this happened yesterday, I tried the fix from another thread - running 'netsh winsock reset' from cmd prompt. After a reboot, problem was still there.
    Anyway, what happens is that about 20 mins after the PC has been started the Firewall suddenly turns on, Interent Explorer (which I tried to launch about 10 mins ago) suddenly springs to life and all the errors mentioned above go away.
    I would like to clear this issue and when things are stable, look at installing a better Firewall.

    Thanks for any help.

    Added later:-
    I should also say that Event Viewer shows:-
    An Application Hang - AcroRd32.exe, hung module hungapp
    Service Control Manager Event - The Server service hung on startup.
    Service Control Manager Event - The Computer Browser service depends on the Server service which failed to start because of the following error:- 'After starting the service hung in a start-pending state'.
    Also, for information --- the Windows Firewall/ICS Service does start ok and is set to Automatic.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    This what I'd do ;)
    Remove the 0.5Gig of memory (ie your 512Meg Ram card)
    Uninstall any 3rd party Firewall (I'm unsure if you added one or not)
    Uninstall any other live protecting software (like SUPERAntispyware; Spybot S&D; Ad-Aware etc)
    Keep your Antivirus software ;)
    Close any programs (not antivirus) near your system clock

    Then update to SP3:

    I'd say fault solved, or you have a hardware issue
    Have a nice day :)
  3. NineMilesHigh

    NineMilesHigh TS Rookie Topic Starter Posts: 56

    Next steps

    Thanks for response.
    Q:- Why do you recommend to remove the 1/2 GB memory?
    I am taking the other steps at the moment to install SP3.
  4. NineMilesHigh

    NineMilesHigh TS Rookie Topic Starter Posts: 56

    SP3 failed to install

    There is no 3rd party firewall. Only Windows Firewall is running - but as I mentioned earlier it does not start on start-up and Windows Security Center complains about it-- but about 15 mins later it mysteriously kicks in.
    I uninstalled Malwarebytes AntiMalware which was the only protection s/w running other than Avira Antivirus and tried to install Windows XP SP3.
    It failed after about 10 mins with 'Access Is Denied'.
    I tried uninstalling the virus s/w (Avira) and ran it again.
    This time it failed to install with 'An internal error occured'.
    I will go and look for these probs in various forums, but if you have suggestions, I would like to hear them.

    An update:
    This is an extract from the svcpack.log file when the install failed:-
    110.360: AnalyzeDevices used 1953 ticks
    110.516: AnalyzePhaseTwo used 156 ticks
    110.516: AnalyzePhaseThree used 0 ticks
    110.516: AnalyzePhaseFive used 0 ticks
    110.657: AnalyzePhaseSix used 141 ticks
    111.235: Trying CheckVLKForBlock again
    111.735: Error: CheckVLKForBlock failed
    111.813: Inventory complete: ReturnStatus=536741199, 54250 ticks
    111.813: Num Ticks for invent : 54250
    116.375: UnRegisterSpuninstForRecovery, failed to delete SpRecoverCmdLine value, error 0x2
    116.375: DoInstallation: Failed to unregistering spuninst.exe for recovery.
    116.375: An internal error occurred.
    119.594: Message displayed to the user: An internal error occurred.
    119.594: User Input: OK
    119.594: Service Pack 3 installation did not complete.
    120.469: Message displayed to the user: Service Pack 3 installation did not complete.
    120.469: User Input: OK
    120.469: Update.exe extended error code = 0x1ffe054f
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...