Spread the love! TechSpot Tech Gift Shortlist 2017

Windows installer problem

By Oziris · 6 replies
May 14, 2010
  1. Hey ya all,as you can see im new around here,this is my first post >.<
    Ive read around a bit,tried some solutions for my problem but seems i just cant make it.
    Then i ran into one thread and noticed that the last guy who posted havent resolved his problem either.If you scroll up you can see that one of the posters did resolve,since hes not answering on PM i decided to open new thread and ask you guys for help.Thank you in advance
    Best regards,

    Windows ® Installer. V 4.5.6001.22159

    msiexec /Option <Required Parameter> [Optional Parameter]

    Install Options
    </package | /i> <Product.msi>
    Installs or configures a product
    /a <Product.msi>
    Administrative install - Installs a product on the network
    /j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
    Advertises a product - m to all users, u to current user
    </uninstall | /x> <Product.msi | ProductCode>
    Uninstalls the product
    Display Options
    Quiet mode, no user interaction
    Unattended mode - progress bar only
    Sets user interface level
    n - No UI
    b - Basic UI
    r - Reduced UI
    f - Full UI (default)
    Help information
    Restart Options
    Do not restart after the installation is complete
    Prompts the user for restart if necessary
    Always restart the computer after installation
    Logging Options
    /l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>
    i - Status messages
    w - Nonfatal warnings
    e - All error messages
    a - Start up of actions
    r - Action-specific records
    u - User requests
    c - Initial UI parameters
    m - Out-of-memory or fatal exit information
    o - Out-of-disk-space messages
    p - Terminal properties
    v - Verbose output
    x - Extra debugging information
    + - Append to existing log file
    ! - Flush each line to the log
    * - Log all information, except for v and x options
    /log <LogFile>
    Equivalent of /l* <LogFile>
    Update Options
    /update <Update1.msp>[;Update2.msp]
    Applies update(s)
    /uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
    Remove update(s) for a product
    Repair Options
    /f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
    Repairs a product
    p - only if file is missing
    o - if file is missing or an older version is installed (default)
    e - if file is missing or an equal or older version is installed
    d - if file is missing or a different version is installed
    c - if file is missing or checksum does not match the calculated value
    a - forces all files to be reinstalled
    u - all required user-specific registry entries (default)
    m - all required computer-specific registry entries (default)
    s - all existing shortcuts (default)
    v - runs from source and recaches local package
    Setting Public Properties

    Consult the Windows ® Installer SDK for additional documentation on the
    command line syntax.

    Copyright © Microsoft Corporation. All rights reserved.
    Portions of this software are based in part on the work of the Independent JPEG Group.
  2. wii-ste

    wii-ste TS Rookie Posts: 163

    You didnt actually say what the problem is.
  3. Oziris

    Oziris TS Rookie Topic Starter

    well actually when i try to install some software like ventrillo / daemon tools, window pop up with that error...
    so i updated windows installer,installed 4.5 one but still having same issue,i tried making new temp folder and putting install client in it and run it directly from there but that failed too,so im kinda without any idea how to resolve this thing
    i dont have this problem on win 7,but i went back on windows xp sp3 and since im back on xp this issue has been bothering me
  4. ultragrey

    ultragrey TS Rookie Posts: 61

    Yes I had the same kind of problem too. I went for upgrading my pc and all settled.
  5. wii-ste

    wii-ste TS Rookie Posts: 163

    I think that upgrading is going a bit far to fix this problem.

    Can you try this?

    I know the problem mentioned is slightly different but I think the cause may be the same.

    EDIT: I noticed that the page is slightly wrong in places .... here is correction:

  6. vhunter16

    vhunter16 TS Rookie


    can any one tell me.....how to disable to usb of the pc from manage?
  7. Oziris

    Oziris TS Rookie Topic Starter

    yeah i tried that as well,still having same problem even after i do that...
    thank you for your help
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...