Windows Installer won't remove Nero

Status
Not open for further replies.

AKHandyman

Posts: 8   +0
Windows Installer...won't remove Nero !

Allright everyone, time to put on the ole thinking caps...I have tried to work through this problem and have researched the KB over at MS. I am trying to remove my original version of Nero 5.5 to supplant that with my bundled software that came with my new Lite-on CD/RW burner. It also has Nero 5.5 Burning CD-ROM.
I am running Win2kpro w/SP3. I am using the Add/Remove program. I click on remove Nero Burning and the windows installer window pops up with "The feature you are trying to use is on a CD-ROM or other removable disk that is not available". Then it prompts me to insert my Nero CD and click okay. I have done that and I then get the next Windows Installer window saying "The path 'Please insert the disk with Nero Burning Rom cannot be found. Please verify that you have access to this location and try again, or try to find the installation package 'Nero-Burning Rom.msi' in a folder which you can install the product Nero Burning Rom". Well, I have opened the CD ROM and found the file Nero-Burning Rom.msi and I clicked on that and then I get the window from the Add/Remove programs and it says " The installation source for this product is not available. Verify that the source exists and that you can access it". I am at a loss as to what exactly the problem is, but I am leaning towards the Windows Installer files being corrupted. I have done what was called for in the MS KB Article 315346, re-registering the windows installer and also trying to reinstall it after trying to remove it. I need some extra guidance or a divine intervention. Anyone out there have this problem? Stuck in Tok, Alaska...AKHandyman :confused:
 

SNGX1275

Posts: 10,592   +453
Have you tried the setup.exe or the .exe installer rather than the msi? The disk shoudl have both.
Whats the problem with just installing your new one over the existing installation?
If you get real desperate you can just delete the nero folder where its installed to then dig through your registry deleting instances of Nero but I don't recommend that unless you have a backup of your registry and have an idea about what you are doing.
 

RealBlackStuff

Posts: 6,452   +3
Beginning with V5.5 if you need to uninstall Nero, delete the folder it leaves behind in C:\Program files, reboot, run RegCleaner http://www.majorgeeks.com/download460.html and then the Nero upgrade/re-install will install without problems.

At the point that the Nero installer/uninstaller asks if you want to continue it has already deleted some of the old files.
The moral of the story is don't interrupt the Nero installer when it's at work.
 

AKHandyman

Posts: 8   +0
  • Thread Starter Thread Starter
  • #4
I am learning about the registery now, though I don't have the confidence just yet to really get in there and do some good prunning. I have tried installing the new one over the old one and I get the message from Windows Installer window "ERROR applying transforms. Verify that the specified transforms are valid". I also tried the exe installer and I still get the above mentioned pop-ups. Would SP4 alleviate this problem?
 

AKHandyman

Posts: 8   +0
  • Thread Starter Thread Starter
  • #8
Once again, thanks for all the help. I was successful in deleting the old Nero and was able to install the Nero software for my new burner. Should have gone to Nero's Website in the beginning. Oh, well, that's why they call it a learning curve.
AKHandyman
 

RealBlackStuff

Posts: 6,452   +3
Just in case anybody is still interested, the link above was an old one, leading to the (then) free version (humble apologies).
They have gone shareware now, and can be found at http://www.jv16.org/ look for the JV16 Powertools or RegSupreme
 
AKHANDYMAN ... :hotouch: whaT DID YA USE TO FIX IT ???

im having the same error and it wont let do anything ????????????????//


:grinthumb
 
Error applying transforms.

Although this may not be directly related to AKHanyman's original post, it does apply to the "Error applying transforms" when trying remove, re-install or modify Nero 7 Ultra. I had the same problem, tried all Nero's removal/repair tools...to no avail. Eventually, I figured it out. The problem, for me at least, was that I was using a different source path to re-install from. I had made a copy of Nero software in the form of a CD image (bin/cue), and that is where I had originally installed the software from. When I wanted to modify installed components, I used my original CD as I had long since deleted the image to make room on HDD. Therein lies the problem....different source path. I made the image again...same name and location, mounted it and voila! Hope this helps some of you experiencing the same problem.
 
I found a better way to help you for this. I got the same problem, all the uninstaller, the cleaner from nero didn't work. What you have to do is to put the CD or mount the image file with the SAME cd rom used when you installed it. It must be the original cd rom letter.
 

SNGX1275

Posts: 10,592   +453
LastWizard said:
I found a better way to help you for this. I got the same problem, all the uninstaller, the cleaner from nero didn't work. What you have to do is to put the CD or mount the image file with the SAME cd rom used when you installed it. It must be the original cd rom letter.
Um. That is pretty much exactly what Boa_2k5 said right above you.
 
Status
Not open for further replies.