Windows Media Player - Not starting and cannot create Directshow player

By Fiddler_the_Xth ยท 5 replies
Jun 25, 2006
  1. I'm running Windows XP, on an AMD Athalon 64 FX-53 chip, nVidia 6800, Firefox, with the latest directx driver.

    Whenever I would attempt to view an embeded video file with the windows media player, I would recieve this error message,
    "Can not create DirectShow Player" :eek:
    This also occurs when I use IE or Opera. But when I choose another format (MPG, Flash, AVI, QuickTime) I can see the clip fine.
    In an attempt to fix this, I removed and reinstalled Windows Media Player 11 Beta. I also tried reinstalling WMP 10 but tht didn't fix it either. (XP users can no longer roll back to version 9. It's been deleted completely)
    Now not only do I get the "Cannot create DirectShow player" message. I can't even start up Windows Media Player. When I click on the little WMP icon, my cursors flashes an hourglass, than goes back to a cursor. WMP wont engage at all. Help?
  2. Phred

    Phred TS Rookie

  3. smore9648

    smore9648 TS Rookie Posts: 697

    I had the same problem with WMP 11. I uninstalled it and re-installed wmp 10.
    No more problems
  4. Inno

    Inno TS Rookie

    Hi, sorry to jump in with my first post here - but I'm having exactly the same problem, although it seems to have extended itself to WinAmp not playing video files and Internet Explorer acting sluggish also.

    I've tried everything I can think of, even everything on that MS article - I get errors trying re-register the first of the dll files and I'm fast approaching the end of my tether.

    Can anybody help me at all? I'm desperate!
  5. rycher

    rycher TS Rookie

    Phred, I love you!

    I had a VPN install gone awry that caused a domino effect on my laptop. I solved a few problems, but started getting some errors during boot and one of the resolutions had me change a few settings,....end result was that I couldn't see the Windows Update site (among a few others). I spent HOURS looking for an answer on the Microsoft site. NOTHING. I reloaded SP2 and upgraded my browser to 7.0 and NO CHANGE. Finally, I was trying to launch a few sites that played audio and was getting an error - which lead me to here - which lead me to the MS solution - that appears to have fixed my problem. Of course, it was 2 lines. I wish I would have found this 24 hours and many follicles ago!
  6. notime

    notime TS Rookie

    Codec adware

    Apparently, DirectShow requires codecs Vcodec and Vcodec.emedia
    which are identified as adware by some anti-spyware programs such as Spybot. Restore these and DirectShow works fine.
    Always a price to pay.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...