Windows was unable to find a certificate to log you on to the network

By imekul ยท 5 replies
Apr 10, 2008
  1. I recently bought two Belkin F5D7320 (v8000, latest firmware) Wireless G routers, and I'm having a very strange problem. I set one up to use WPA-PSK. Using my laptop (running XP Pro SP2), I find the SSID (using the Windows wireless utility), then I double-click on the network. I enter in my WPA key, just like I always would, and it goes through the process of acquiring a network address and all of that, but as it's doing that, I get a bubble alert in the system tray which says "Windows was unable to find a certificate to log you on to the network (SSID)."

    The connection seems to still work, though; just I get this message. I have tried a few different laptops, and they get the same message. I have other wireless routers secured with WPA, and I have never gotten that message before using the new Belkin. Out of curiosity, I opened up the second identical Belkin router, applied the same WPA settings, and it seemed to do the exact same thing.

    I seriously doubt it's a laptop issue, as I have used the same procedure that I have used countless times to connect to WPA-secured networks, and I have also tried this on a few different laptops, with the same result.

    I searched for this message, and people almost immediately suggest that it means either the router or computer are configured to use a Radius server. Well, neither are, as far as I can tell. In fact, here are the settings for my router:

    Security Mode: WPA/WPA2-Personal(PSK)
    Authentication: WPA-PSK
    Encryption Technique: TKIP
    Password(PSK): (my WPA key)

    That doesn't seem to suggest anything different from a typical WPA setup, from what I can tell, yet I still get this weird message.

    Any thoughts on this? It seems to be router-related, but I'm confused as to why both routers do it. Unless it's something new on the router that I'm missing. And, of course, the network seems to work other than this bubble, but I'm just wondering why it's coming up and how to get rid of it...

  2. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    Each WiFi adaptor has it's own setup utility, eg my Toshiba can with an
    Atheros AR5005gs onboad chip and the OEM installed its own connection wizard.

    Lots of people have used the MS wireless wizard, but perhaps you need to try the
    OEM version.
  3. imekul

    imekul TS Rookie Topic Starter

    Thanks for the help. I have tried that method, and it seems to work pretty well. However, I'd much rather use the built-in wireless networking tools.

    I guess this must be a problem/issue with this router, huh? I'd be interested if anybody else has a solution to actually fix the problem, but I'm glad that there seems to be a workaround.
  4. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    hum; if you got it working, what's the problem left to be solved?
  5. imekul

    imekul TS Rookie Topic Starter

    Well, basically, so that it will work without any manufacturer-specific wireless software running. Lots of people don't even have that type of software installed, so they would be out of luck if they tried to connect to the network.

    I can't imagine that this is supposed to happen with these Belkin routers, but it's strange that the problem occurs on two identical models. Yet, there seems to be no documentation or explanation of it! It's odd.
  6. jobeard

    jobeard TS Ambassador Posts: 11,177   +989

    In a perfect world there would be no such thing as a device driver --
    but we all know how perfect things really are, don't we!

    The connection wizard on Windows is generic; the OEM package is of course vendor specific.
    This is not the same thing as the device driver.
    Sorry but you just must install the WiFi driver for the device and follow just
    these two rules:
    1. read, understand and follow the rules,
    2. any questions, read rule-1

    Yes, Belkin seems to be difficult at times -- first reaction is to update the router firmware and then the WiFi driver.

    Best wishes.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...