1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

XP can't copy/move some files

By Karmashock ยท 4 replies
Jul 24, 2007
  1. I've had this happen a few times... typically it's some strange program I download or file... I've never seen this with system files or anything that isn't exotic.

    Currently it's a dll file I need to move. It came in a zip, I can upzip it... I can rename it... no program/thread/process is using it. It cannot be copied or moved... anywhere.

    It is not write protected, it is not set on archive, it is not hidden, and the privileges are identical to everything else in the folder.

    I've seen this with programs before as well.

    In any event, I've tried turning off all my security and moving it... no luck... I've even tried unlocker's "move on next reboot"... None of it works.

    The only way I can seem to move the file is to compress it with winrar and then extract it where ever I want it to go. Annoying, but it works.

    Any idea what does this?
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    That is the way it is supposed to happen. It is often a built-in protection against failures. Disable, rather than remove. You should have no trouble if you remove after booting in SAFE MODE, after deleting the program with Add or Remov, then with a simple registry editor such as RegClean or Registry Cleaner.
  3. Karmashock

    Karmashock TS Rookie Topic Starter Posts: 223

    sorry, I figured it out... I installed and uninstalled Sophos ages ago... it's a pretty good Anti virus program but I just don't need anything that sophisticated.

    Anyway, apparently it left behind a system service and it was flagging those files as "viruses"... they're not... but it thinks they are... so disabled it and everything works now.
  4. jobeard

    jobeard TS Ambassador Posts: 10,328   +788

    Unders Win/*, any file that is open can not be copied or replaced. This is very
    important for DLLs, as you can't tell if/when they get loaded. This is why you
    frequently see System Must Be Rebooted; the files are active and can only be
    replaced during the reboot before Win/* gets to far in the process.
  5. Karmashock

    Karmashock TS Rookie Topic Starter Posts: 223

    yeah, this file could however be renamed... was not in use... could be compacted into a zip file and then extracted elsewhere.

    The file system simply refused to allow copy or move orders... but other systems could be used to do it. Alternate file browsers for example work fine in these situations.

    I found out what the problem was, I had some Sophos antivirus services running. I installed and uninstalled sophos AGES ago... well over 8 months ago. Anyway, after disabling those services this problem went away. These sophos services were apparently preventing some files and programs from being moved, copied, run, or in almost any way accessed. I assume it thought they were infected.

    In any event, they're dead now and all is well.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...