XPS M1530 dead - no power at all

By Countryrzrbk
Mar 9, 2010
  1. Just 20 days out of warranty, my M1530 died suddenly. It was working, then it shut off completely. I turned it back on, and it worked for about 5 mins, then shut off again. Now it does nothing at all. No lights, nothing. Power supply has been checked and is working, green light stays on. I've read numerous posts elsewhere that all say "Motherboard" but I just can't believe that to always be the case. One post I've read said "Powerboard" which I'm hoping is the case. I need to know can anyone tell me a way to be sure before I go buying parts I may not need? I have reseated the memory cards, pressed the fn and start buttons together, tried just about everything I could find in numerous forums and still nothing works. For about 2 weeks prior to this happening I noticed the battery light on the front edge would flash red 2 times, then go blue. Flash red 2 times, then go blue over and over again. But the battery showed full charge, so I ignored it. Any help would be much appreciated. Thanks y'all!
  2. JamesP

    JamesP TS Rookie Posts: 29

    Similar problem with my Dell, it turned out to be a lose CPU. The locking screw on the CPU only has half a turn and that somehow came lose, one half turn clockwise was all it took to fix problem. I hope this helps
  3. Countryrzrbk

    Countryrzrbk TS Rookie Topic Starter

    Thanks James, I'll give that a try. I'll let you know the results.
  4. ispppc

    ispppc TS Rookie

    Same problem

    I m going thro the same problem
    The XPS model is crap.
    Friend what have u done to make it up and running again

    Plzzzzzzzzzzzz help me ...............

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...