TechSpot

Autorun not working

By someguy
Feb 5, 2004
  1. I was already referred to this Microsoft support page in a previous thread:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;330135&FR=1&PA=1&SD=HSCH

    But I seem to have hit a snag. When opening regedit and checking my

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDriveTypeAutoRun

    file, as step 7 suggests, the file is available only in binary, not hexadecimal. (It's labeled as REG_BINARY.) So, I can't edit in a hexadecimal value of 91, as the Microsoft page suggests. The display, when I right-click to modify it, is

    0000 FF 00 00 00 y...

    I'm not sure where to go from here. Can I somehow this existing NoDriveTypeAutoRun file, or copy a "good" one with a hex value of 91 from my Windows install CD? Any help would be greatly appreciated. I'm pretty sure this screwed-up reg file is the problem.
     
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  3. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    That is not what he asked RBS. Autoplay ( the feature that makes Audio CDs play automatically once inserted for example ) is disbaled & he's tryig to re-enable it. No booting involved.

    Isn't it possible to re-activate Autoplay by clicking on your CD-Rom's properties ( from the device manager ) ?
     
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Open Group Policy (gpedit.msc on the Start/Run) and navigate to Computer Configuration\administrative templates\system.
    Open the Disable Autoplay Policy, select Enabled and select CD-Rom drives.

    The NoDriveAutoRun value is a bitmap in which each bit represents a drive letter, starting with A as the least significant bit (outermost right). Setting a bit to 1 disables Autoplay for the associated drive letter. E.G. if you want to disable autoplay on drives H and I, you set the value to hex 180, which is calculated as follows:
    LKJI-HGFE-DCBA (these are the drive-letters (backwards))
    0001-1000-0000 = 180 hex.

    Complicated but true.

    To activate autoplay for all, make all the bits 0 (00 00 00 etc.)
     
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    To enter the value 91 as per Microsoft, in Regedit that value now shows (in your PC at least):
    0000 FF 00 00 etc.

    When you doubleclick on NoDriveAutoRun the cursor will blink between 0000 and FF. Carefully press just ONCE on the Delete-key on your keyboard. The FF will disappear. Now just type in 91 where the cursor is.
    Your line will now look like:
    0000 91 00 00 etc.
    Click on OK and that is it.
     
  6. someguy

    someguy TS Rookie Topic Starter

    This worked like a charm. A frosty pint to you and yours, good sir, I am in your debt. Also, thanks.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...