Installed new graphics card and PSU now getting IRQL_NOT_LESS_EQUAL

By brizzle909
Mar 15, 2010
Topic Status:
Not open for further replies.
  1. I recently bought a new video card(galaxy nvidia 9500) and a Dynex 400w psu, I downloaded the drivers to my graphics card and it went to restart but it went to Bluescreen and said IRQL_NOT_LESS_EQUAL
    How do I fix this? Geek squad is no help unless I wana fork over a **** ton of cash...

    Specs:
    Amd Athlon 64X2 Dual Core Processor 4400+ 2.30 GHz
    New Galaxy Tech GeForce 95000 GT (!gm 128 bit ddr2)
  2. EXCellR8

    EXCellR8 The Conservative Posts: 2,278

    Did you remember to uninstall the previous drivers? You may get errors if the last set of drivers is still sitting on the hard drive. If you are able to boot into Windows, or at least Safe Mode, go to Add/Remove programs and select your display driver. Afterwards, run Driver Sweeper and then restart the computer. Once the system comes back online (with no video drivers installed) run the installer for the new 9500 drivers from www.nvidia.com and then restart when prompted.

    If you still get the error, consider updating your motherboard chipset drivers or exchange the PSU for another.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.