Adaptec's 1205SA users, here's what I sent to Adaptec

By DragonMaster ยท 62 replies
Jun 22, 2005
  1. Digidat

    Digidat TS Rookie

    Hi good ppl's of this forum.

    I am new here but am glad that I found this thread (even if it is very old :) )
    I have read this whole post, but am not 100% sure if I have enough info to resolve my problem.
    I have the Adaptec 1210SA controller on 4 pc's.
    They all have 2 WD HDD's 250GB running in Raid 1 mode (Mirroring)
    I want to upgrade to Windows Vista Ultimate 32bit and it seems to install resonably, but I use the WinXP Drivers.
    If I have installed it without error's and upgrade the Vista completly than I try to copy a large file from my Win2k8 server within my network.
    After a couple of seconds Vista freezes and when I reboot diskcheck starts, changes corrupted files and WinVista never boots again.
    I also have diverent error's with Microsoft Update and random reboot's etc.
    I have read and tried al the vista error posts, but now that I think this is no Vista error but it could be the fact that Vista doesn't recognize my Adaptec 1210SA card and it is working with WinXP drivers.

    What I want to try is to flash my Adaptec to a Silicon version in order to use the WinVista drivers of Silicon

    My questions are:
    Is it possible to reflash my Adaptec 1210SA to a Sillicon Raid controller ?
    Should I use the same Sil3112 Firmware to do it ?
    Is there someone who can help me with the instructions for flashing and if necesery the (adapted) files including the WinVista 32bit drivers ?
    Is the Silicon Flas reversable; can I change the firmware back to the orriginal Adaptec firmware, if it doesn't work ?
    What are the experiences with the performance (Sil3112) Silicon controller in comparison with the Adaptec 1210SA (my experience with Silicon is not so great) ?

    Thanks in advange for any help

  2. malpayne

    malpayne TS Rookie

    Adaptec 1205SA and Vista/Win7 - Finally some success!

    For those of you who are trying to get the Adaptec 1205SA to work with Vista or Win7, I was able to get it to work with an old driver I downloaded from Adaptec at I tried all the drivers at Silicon Image with no success. Hope this helps!
  3. Digidat

    Digidat TS Rookie


    Thanks for responding to a rather old post.

    Great to hear that at least that Adaptec raidboard is working under Vista, but is it really working ?
    I got my 1210 board also perfectly installed and working under vista (while installing Vista I use the Floppy with the WinXP drivers on it, and that seemed to work).
    But when I started downloading files, or coppying files to my pc from my server, Vista crashes and than started a HDD-check, changed some files and Vista never booted again.
    In other words, after a lot of testing, I noticed that when I started stressing the Raid by writing a lot of big files to the HDD, it couldn't cope with it and crashed.
    If this doesn't happen with you, that congratulations with your stable Vista pc. :)

    Anybody has any suggestions for the Adaptec 1210 Raid Board under Vista ?
  4. naranek

    naranek TS Rookie

    1TB support added

    I would like to add that the Adaptec 1205SA does not support disks 1TB or larger. Flashing it with a Silicon Image BIOS adds this support :D

    To avoid error code 10 you must update the INF file (including the &SUBSYS_02509005 info) and for setup the OEM file, following DragonMasters instructions.

    The SiI BIOS update readme states you must have a drive connected to be able to flash from the control panel, so make sure you do that.

    If you need to flash from DOS you can use FREEDOS from fdos dot org.

    The F3 prompt is there in 4.2.79 but not in 4.2.83 and 4.2.84. I tried F4 and CTRL-S but they don't work either, any ideas?
  5. grantgorgen

    grantgorgen TS Rookie

    I love you guys

    I'm so thankful for the original poster and everyone else's useful tips. I needed to get my 1205SA to work with my new 1TB hard drive. I used SI's windows bios flashing utility to update to the latest 4.4.02 and modified the driver to work minus the "&SUBSYS_02509005" part (don't ask why i thought it was a good idea... the lines matched up better that way, and it worked). I now have 1TB support in XP Pro.

    P.S. The windows flashing utility worked without a hitch

    C:\>SiFlashTool.exe /v
    Silicon Image Flash BIOS programming tool version 1.0

    Controller Type PCI Location Flash Part BIOS Ver. BIOS Date
    Sil 3112 Bus:00 Dev:0b AMD Am29LV010B UNKNOWN UNKNOWN

    C:\>SiFlashTool.exe /File:b4402.bin
    Silicon Image Flash BIOS programming tool version 1.0
    Selected Sil 3112 on PCI bus: 0x00 device: 0x0b
    Flash part: AMD Am29LV010B size: 128K
    Erasing flash ........
    Programming flash ..........
    Verifying flash ..........
    New BIOS Version: 4.4.02 Date: 10-30-2008
    BIOS successfully updated.

    C:\>SiFlashTool.exe /v
    Silicon Image Flash BIOS programming tool version 1.0

    Controller Type PCI Location Flash Part BIOS Ver. BIOS Date
    Sil 3112 Bus:00 Dev:0b AMD Am29LV010B 4.4.02 10-30-2008

    After the easy flashing (no reboot required) and driver update (reboot required) all i had to do was drop in Western Digital's Data Lifeguard CD and format the drive

    Thank-you everyone who's contributed to my success.
  6. valDar

    valDar TS Rookie

    Back at it again...driver madness and Windows 7
    Well I tryed to install the new driver to control the Adaptec 1205sa with updated BIOS 4.4.02 and it cannot find the new driver, error 10. The system is an x86 tri boot also running xp pro and vista business, of course they are working fine with the 1205sa. Now I add windows 7 pro x86 to the mix and the driver will not load. Anyone else had a problem loading the windows 7 driver from silicon image...maybe the driver was designed for the windows 7 beta and not the RTM. May have to wait for a revised version. Its good to see this thread is still alive and the Adaptec 1205/1210sa still remains viable despite Adaptecs lack of interest.
  7. Reuben13

    Reuben13 TS Rookie

    Hey DM

    Didn't you use to play a online PC Game called DragonScape?

    If so just reply to this topic lol.
  8. omegaeel

    omegaeel TS Rookie

    Windows 7 Driver Mod Install for Sil3112 OR 1205SA

    I ran into a similar problem which kept me from moving to Windows 7. Finally have it figured out this past morning. (Non-RAID Solution)

    1.Update Adaptec 1205SA card BIOS to Silicon Image Base BIOS v4.4.0.2
    under the chip SiI3112

    2.Download latest SiI3112 Windows 7 Drivers v1.

    3.Open in notepad these two files from the archive (SI3112.inf AND TxtSetup.oem)

    4.In Windows 7 Device Manager:
    -> Select the uninstalled Mass Storage Controller
    -> Goto the Details tabs
    -> Under Property select Hardware Ids
    -> Note of the numeric sequence that trails
    PCI\VEN_1095&DEV_3112&SUBSYS_ (ignore the "&REV_02" portion)

    5.Go back to the two files open in notepad and find all instances of this string:
    PCI\VEN_1095&DEV_3112&SUBSYS_xxxxxxxx (the last 8 digits you will
    replace with the numeric sequence you noted from the Hardware Ids Property)

    6.BE CONSISTANT! You have to change the same numeric string in all places, in both files open in notepad.

    7.Save the changes, go back to the Device Manager and Right-Click on the Mass Storage Controller with the yellow exclamation point.

    8.Choose to update the driver

    9.Choose "Let me pick from a list of device drivers on my computer"

    10.Uncheck "Show compatible hardware" AND choose "Have Disk"

    11.Point to the location of the modified driver files.

    12.Select the "Silicon Image SiI 3112 SATALink Controller" and select yes throughout the installation.

    13. Restart and enjoy.
  9. valDar

    valDar TS Rookie

    still working on it...

    Nice tutorial and thanks for the info omegaeel but I already had the proper hardware IDs planted and the driver is showing up in the device manager. However as a storage controller the device is still flagged with the error 10. It does not show up in the control panel as it does in XP and Vista and errors are also noted in Administrative events. My guess is that the Intel 875PBZ motherboard needs a new driver to work properly with windows 7 and a check on the Intel site shows no new driver available yet. Hopefully this 8 year old motherboard can still be upgraded. The only other interface card in the computer is a Firewire 1394 host controller that I use for digital audio and it shows up fine.
  10. omegaeel

    omegaeel TS Rookie

    The solution I wrote was for the same motherboard - Intel D875PBZ.

    Have you updated to the most recent BIOS "P34" ?
  11. valDar

    valDar TS Rookie

    Yes I'm on BIOS P34, must be something else then. Thanks for telling me you have the same MB as it gives me extra incentive to solve this problem.
  12. gcronau

    gcronau TS Rookie

    I'm running WinXP SP2, I've been using an Adaptec 1205SA for many months with no problems. Today I tried to attach my brand new Western Digital WD1001FALS to the 1205SA. During POST, the machine hung when the 1205SA tried to dsplay the drive capacity. At this point, I figured I'd hit yet another drive size limitation and the 1205SA couldn't handle drives of this size. After searching the net I found this article(THANKS GUYS!!!) and I downloaded the Silicon Image windows drivers and the 4.5.02
    bios. I instaled the windows drivers without a problem, and used the SiFlashTool to flash the bios. That all went without incident. I rebooted the machine, the 1tb drive was recognized and I'm now growing old waiting for windows to format a 1tb drive..... zzzzzzzzzzzzzzzz :)

    However, I have a couple of concerns:
    1.) All through this article mention is made of the need to edit parts of the various .inf files. I didn't do any editing. I figured I'd try a cold install and, if that didn't work, I'd dig deeper into what needed to be tweaked. But everything seems to have installed fine with no problems. Is there another shoe about to fall? Did I miss something that might come back to haunt me later by not tweaking the .inf files?

    2.) I no longer get the "HIT F3" prompt to go into the card's setup software. Anyway to get that back? I don't use it, but I might need it some day.

    3.) I'm using drivers and 4.5.02 bios. Any known problems with this combo? Is there a preferred set of older drivers/bios that I'd be better off using?

    Thanks for any help.
  13. tuinboontje

    tuinboontje TS Rookie

    Hi I just read this post on the adaptec1205 sa problem i tried every solution in this thread but cant get the card to work. Giving a error 10 when i look at the properties in device manager. any ideas? I'm al ou t of ideas. pls help. igot windows 7 pro x64 and tried every driver bios combo i think
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...