1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

AHCI BIOS Not Installed

By xynthal · 4 replies
Nov 26, 2007
  1. heyas...

    mobo: abit ab9 pro (BIOS release V20 (latest release)) // Intel Core 2 Duo E6700 (2.6GHz) // 2x 150GB Western Digital 10k rpm Raptors // 4x 1GB mushkin xp2-6400 (DDR2-800) ram // 2x HP dvd840 optical drives (LightScribe)

    edit: the 2 hard drives are running raid0 stripe

    awardBIOS V6.00PG // serial ata ACHI BIOS Version iSrc 1.07 08042006 // intel matrix storage ICH8R w RAID5

    out of nowhere I noticed that my hdd led and floppy led were solid on... I rebooted and the puter didn't recognize either of the optical drives and the floppy drive didn't function... a direct quote from the mobo during bootup… “detect drives done, no any drives found”

    I went to the BIOS to see if anything had changed... all looked well...

    then I replaced all the cables (sata, ide, floppy)... no change... then I unplugged both optical drives and the floppy... the hdd indicator led went back to normal... I then tried connecting just the floppy... both the hdd led and the floppy led were constant on... then I tried just one optical drive... same result… I tried all combinations but the result was that if either optical or the floppy were connected…both indicator led’s would remain constant on…

    so I thought that the mobo was fried... so I swapped in a new mobo and the problem was still there...

    then during bootup, I noticed "AHCI BIOS Not Installed"... this is a function of the cpu correct??? Is this why the drives are not recognized??? What does this have to do with the floppy???

    Also… BIOS only recognizes 3 of 4GB of ram… from windows I can run cpu-z and it gives me information on all 4 sticks of ram…

    intel retail cpu’s are warranted by the manufacturer for 3 years right??? the company I bought it from seems to have gone under (monarch computers)… another dilemma is that I bought the mobo and cpu as a combo… they installed the cpu to the mobo… I received the original cpu box… but the invoice says “Core 2 Combo”… anyone know offhand if this is a problem before I go to intel???

    hope this makes sense… lol…


  2. miso_ohio

    miso_ohio TS Rookie

    Look at this helpful Thread that relates a little to your issue.


    Seem that error is the raid bios, according to that thread you need to go into Bios and find the SATA operation and turn it from "Raid Autodetect AHCI" to combination. At least that is what that thread says, I have no personal experience with this but if you are not using raid why leave it on to cause issues.

    Hopefully that helps.
  3. xynthal

    xynthal TS Rookie Topic Starter

    my problem is that the bios does not recognize the optical or floppy drives... the computer will boot... i can run windows... i can use my screaming dial-up... i can play everquest2... i just can't install the new expansion... lol...


  4. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    a floppy led that is solid indicates improper installation. Your cable is oriented wrong.
  5. miso_ohio

    miso_ohio TS Rookie

    Sorry, my bad I read that the HDD was solid red too so I assumed you where not booting into an OS, and that error can sometimes cause none of the devices to be detected.

    What Tedster said is normally correct for a solid light on things like Floppy drive and CD drives.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...