Amilo L7310GW will not boot

By nipperthedog
May 27, 2008
  1. Hi all

    I Have an Amilo L7310GW which will not boot. When I press the power button the battery indicator light comes on, green, the hdd light flicks for a split second, goes off, then a stable wireless indicator light comes on for a few seconds, the hdd clicks, hdd indicator flashes, then the cycle starts again. This will happen 10 times before the Amilo remains stable with just the wireless indicator and the green battery indicator (cable not plugged in). During this time the lcd remains blank.

    Things tried:
    1 Tried an external monitor.
    2 Removed battery, did a hard reset, plugged power cable in.
    3 Reseated Ram, swapped modules around.
    4 Tried to enter bios.
    5 Tried to boot up from DVD (with a linux type boot disc).
    6 Checked for dust and fluff in cpu fan (working).
    7 Turned on without the hdd.


    What I neglected to say is that a friend gave me the laptop unworking but can shed no light on how it got in this position. Strange. When I look inside the wireless card compartment, the card appears to be missing with a loose antenna cable dangling inside.

    Any help with this would be extremely appreciated.

    Thanks for reading

    Stripped laptop down to mobo, still does the same thing. Checked power supply with a multi-meter, output ok. Board must be flakey.

    Going to remove cmos battery, see if that helps.
  2. nipperthedog

    nipperthedog TS Rookie Topic Starter

    Guess no one can help.
  3. nipperthedog

    nipperthedog TS Rookie Topic Starter

    Guessed right
  4. P-H_I-L

    P-H_I-L TS Rookie

    got the same problem!

    hey nipperthedog,
    i have got exactly the same problem!!!
    i tried all the things you did, too.

    did you find any solution?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...