Any USB Mass Storage Device won't appear in my Windows Explorer

Not open for further replies.

I have a problem.

Symptoms :
- Any USB Mass Storage Device won't appear in my Windows Explorer.
- It will appear on the bottom right screen as safely remove hardware, and you can safely remove it.
- Device Manager can detect it in two locations : Disk Drives, and Universal Serial Bus Controllers (as USB Mass Storage Device). In their properties it says "This device is working properly."
- Disk Management cannot detect it. It will only showed my CD Drives. And I've already assigned the CD Drive letter to something elze (Z:).
- My mouse and My soundcard work perfectly in all USB port.
- All the devices that I've plugged to my USB work perfectly in another computer.

I've tried these solutions (It didn't work) :
- Tried another USB Flash Drive, Mp3 Player, and my External Harddrive
- Tried to plug it to all the USB Port.
- Tried to delete UpperFilter
- Cannot assign the USB Mass Storage drive letter because it won't be detected in Disk Management.
- Tried to uninstall and reinstall all the USB controllers in Device Manager
- The Virus & Malware scan result were nothing. (Using latest Avaast and Ad-Aware)
- Tried to delete dosdrives in registy.
- Unchecked all "Allow computer to turn off this device to save power"

Ok... I've done all of those and still can't read all my USB Flash Drive, Mp3 Players, and my External Harddrive. All help and suggestions will be greatly appreciated.


Mine 2

Hi Cliverine, i have the very exact problem. i have tried advises from net but they all mesh....nothing works.....

is there someone out there who could really give an exact technique to turn my usb alive again/useful again? pls. help (share ur knowledge, please?).

thanks in advance.....


Posts: 5,746   +14
assuming the drive is not dead or formatted, go to disk drive management in the control panel and assign the drive a letter.


Posts: 838   +1
I agree with Tedster, I once had a similar problem with my jumpdrive.
When my laptop was wired to the server at work, the drive letter from the server 'overlapped' the drive letter on the jumpdrive.
I then disconnected the server HDD, and reconnected with a different drive letter, it worked great thereafter.
Whether your computer is hooked up to a server or not won't matter, but you may have a similar scenario.
Not open for further replies.