ASPI error

By bretty ยท 11 replies
Sep 6, 2002
  1. I have just installed some ASPI drivers.

    I was able to pass through a AC-3 stream to my decoder fone before I installed these..

    Can anyone let me know how to UNinstall these things. they are not listed in add/remove programs.

  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Oh, I don't think you will be uninstalling those in a hurry. At least not properly anywayz. :(

    Where did you get the drivers?

    The best you can do is try to get alternative ASPI layer from somewhere else and try that.

    The kind you are thinking about is system wide and not easily got rid of.

    It is possible to manually remove the ASPI layer, but be warned for a product like easy CD creator, the process will be something like this:

    And I have not checked whether this is BS or not. More info comming if I find more. But I would like to know where you got the ASPI drivers from.
  3. bretty

    bretty TS Rookie Topic Starter Posts: 92

    So you think I should just leave them?

    I have got the external decoder going OK. Are they good for the system though???
  4. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    ASPI is an interface specification developed by Adaptec that provides a common language between drivers and SCSI host adapters. It also provides a way of sending SCSI like commands to IDE devices. Its very important and certain is worth keeping.
  5. sicarius

    sicarius TS Rookie Posts: 27

    Somewhere like this? I would like to know why you loaded them? As Phantasm said this is a layer loaded so the computer can comminicate with both SCSI and ATAPI devices. Were you just trying to get the most current drivers?

  6. KrazyKevin

    KrazyKevin TS Rookie

    Hey Bretty there is a much easier way to remove your aspi drivers. Theres a program called Force ASPI. I used it to totally remove my ASPI layer, and then I reinstalled them to correct some problems before. Let me know if you want it. I can email it to you or hunt the link where I downloaded it from. It's several diff lilttle programs in one little zip file.
  7. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

  8. bretty

    bretty TS Rookie Topic Starter Posts: 92

    Thanks fella's.

    That program worked a charm!! its all good.

    Thanks again to all that replied.
  9. KrazyKevin

    KrazyKevin TS Rookie

    Glad we could be of some help Bretty.
  10. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

  11. KrazyKevin

    KrazyKevin TS Rookie

    Your welcome. I ran into a few weeks ago as I was trying to CloneCD to work on my machine. It kept telling me my aspi layer wasn't installed. When I tried to install it with the aspi layer from adaptec's site, it would only install two of the 4 components. I used the force kill file from the Force ASPI zip to take out all the files, and when I installed again, magically everything worked. I don't know what was wrong, but it fixed it. It seemed to help Bretty out also. Night night, just got off graveyards here in Texas, its time to hit the hay.

  12. mars9

    mars9 TS Rookie

    aspi errors

    After I use killasp. from the Force Aspi zip, can I delete the entire adaptec folder w/out causing any system damage. I am not sure if the .dll and other system are still connected.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...