Tech Stocking Stuffers: 18 awesome gifts under $50

ASUS P5LD2 won't boot + No BIOS beep or video signal

By SlimJim_Newbian ยท 32 replies
Oct 20, 2005
  1. fernz

    fernz TS Rookie

    yeah, im not sure that you are having the same problem as other people here have had. I guess since you updated to the latest bios, then that musnt be the problem... sorry im not much help :eek:
  2. lccm

    lccm TS Rookie

  3. skelly831

    skelly831 TS Rookie

    There lies my problem, my PC won't post and I cant enter bios to change anything. When I turn it on the fans run but there are no beeps nor HDD activity and the monitor stays in standby.
  4. fajoopsa

    fajoopsa TS Rookie

    If you have no beep, it sounds like you havent connected both power leads to the Motherboard or you have a faulty Power Supply
  5. skelly831

    skelly831 TS Rookie

    Thanks for the help everyone, but my motherboard did get damaged due to a faulty power supply. I sent it back to ASUS even after the warranty expired, they were nice enough to not charge for repair services (I only paid shipping). I got it back with a replaced power supply and my repaired motherboard, it's been working fine ever since.
  6. w0lf

    w0lf TS Rookie

    I'm sure that several things ie. power, ram etc. can cause a similar problem, but in my experience, this has only ever happened to me when the motherboard didn't support the specific cpu installed. This issue was always resolved by flashing the bios with the latest version.
    Hope that helps some of you. Good luck.
  7. Daisuki

    Daisuki TS Rookie

    Same as Everybody Encounter this Problem...

    I have the same problem arises when I assemble a newly purchased Motherboard "ASUS!!!!" This is my third times to assemble a computer but this one is the very tough one, cause it almost half a month when I started configuring the problems that I encountered. Maybe this "P5LD2" is the most worse nightmare of ASUSTEK company. I've tried all the possible solution to make this things worked but still !!!!! A failure on my part...
  8. glen888

    glen888 TS Rookie

    Dear friends!
    Thank you so much for your posts !!!
    I spent 5 hours to try to start my ASUS Pq5 PRO - no results... - no picture, no beep, only fan working. But I felt motherboard good (I have this mistery... ).
    I was so pity (and angry - a mess with UPS boxes in my kitchen, wife looke at me like I am looser).
    And I went to Internet and dial "asus p5q doesn't boot vga" in Google... - and find this forum !
    I red everything and dissolved my problem!

    One main problem - not right power connection ! (if Power Supply good)...
    I connected 24 pin power connector (below DDR2). My power supply has configuration 20 connectors and 4 connectors on the same wire. I gathered them together and put it in 24 slot. System did not work.
    I have in my pover Supply else 6 connectos and 2 connecors on the same wire. I took out cover from ATX power connection {don't do it !!!} (4 was blocked in Factoty) and put all 8 connectors together. Even fans stop working. I was afraid that burned motherboard...
    And I found on my Pover Supply 4 connectors on wire - I put back manufacture cover (block 4 connectors) and connect to the boottom 4 pins.
    Moterboard start beeping! (BECAUSE NO EVEN MEMORY WAS IN MY CONFIGURATION - only keyboard and videocard).
    I put 1 GiG memory stick and my black screen after 30 seconds start to see BIOS !!!

    Thank you all my dears!
    Good luck!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...