Audio won't work after resetting BIOS to default

Alright, so, a few days ago I reset my BIOS default (idk why). After that, when I was gonna listen to some music, it wouldn't work. I checked my audio, where it said ''No audio device is installed''. After that, I've tried everything to fix it. Plugging my device in and out, trying different ports, checking the net for solutions, updating my drivers but nothing works. When I plug in my headset, it says that it's connected, but it still won't make any sound. Can anybody help me?
 

Kshipper

Posts: 618   +140
TechSpot Elite
OK on to the next item: Using >> Device Manager .....Sound video and game controllers...expand that to see what devices are there. Any of them have a ! on it or a yellow icon
 
Nothing. I have my devices there, but there is no warning sign or anything. I've tried to update the driver on all of them, but hey say that the newest are already installed. I opened Run and typed in dxdiag.exe to check the soundcard, where it says that there is no soundcard. Its weird, as I have an integrated soundcard
 

Kshipper

Posts: 618   +140
TechSpot Elite
Well, I guess it is possible that the chip on the motherboard has died. A add in sound card is possible. They also make USB versions that are really low end that you plug in and configure as your sound card and they have the little stereo mini jack on them to hoop to your speakers. You could also just a USB headset. Those is a digital USB headsets have a built in sound card that installs as part of the headset. The last idea I have is trying to get sound out of the HDMI. That also tends to be a sound card and HDMI is designed to carry sound to the monitor. That would mean the monitor would have to be hooked up by HDMI and that you are using a HDMI cable that carries sound and that your monitor has speakers.
 

Kshipper

Posts: 618   +140
TechSpot Elite
Oh..one other thought>> Onboard audio controller sounds so generic. It really suggests that you don't have a driver for that, doesn't it? You did go to the manufacturer of the motherboard and you did get the audio driver from there?
 
Oh..one other thought>> Onboard audio controller sounds so generic. It really suggests that you don't have a driver for that, doesn't it? You did go to the manufacturer of the motherboard and you did get the audio driver from there?
idk, my father bought the pc. also, the driver has always been working just fine until now after the BIOS reset. been running for two years I think
 

Kshipper

Posts: 618   +140
TechSpot Elite
Well there is a cool program called Belarc that will scan your hardware and tell you what kind of a mainboard you have. That will save you the time of taking the side cover off and looking. Sometimes you have to remove the graphics card to see so Belarc can be handy for that reason.

Once you know the mainboard manufacture and part# you can find the sound card driver.
 
Well there is a cool program called Belarc that will scan your hardware and tell you what kind of a mainboard you have. That will save you the time of taking the side cover off and looking. Sometimes you have to remove the graphics card to see so Belarc can be handy for that reason.

Once you know the mainboard manufacture and part# you can find the sound card driver.
So I gotta buy a new one?
 

mailpup

Posts: 7,687   +768
TS Special Forces
So I gotta buy a new one?
No, it's to make sure you download and install the correct motherboard drivers. You might have done so already but just on the chance you didn't, Kshipper is trying to direct you to the best/correct source of motherboard/sound drivers.