Black screen, log tells me: 0x100000d1 + minidump

By Anlavabeed ยท 17 replies
Jan 13, 2009
  1. Hello,

    Today all of a sudden my screen turned black and my monitor went on standby after a startup. I just had put in an USBstick and I opened Firefox when this happened. I manually rebooted the system. A minidump was saved.

    In the logfiles I found this error:
    0x100000d1 (0xf7e4d000 0x00000005 0x00000000 0xf7787cb1) On this error is not mentioned.

    My machine:
    Windows XP Home SP3 (recently installed)
    Abit IP-95
    Pentium 4 3,4Ghz
    1 GB Ram DDR
    SATA HD Seagate Barracuda 80GB (a week ago checked with checkdisk: no problems found)
    ATI Radeon X1800XL

    Not a clue what this might be. Can somebody help? it is much appreciated. Thanks.
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Likely the USB drive has damaged software on it... or is itself damaged.
  3. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    Thanks. What did you find exactly in the minidump? The USB stick is brandnew.



    Hmmm, today the monitor went black again after a startup, and the USB stick wasn't attached to the computer so it had nothing to do with that.

    The Event log gave me this error:
    0x100000d1 (0xf7f14000 0x00000005 0x00000000 0xf7787cb1)

    I have attached the new minidump. Hopefully this problem can be found.



    I was able to debug both the minidump files, and they are both pointing at the Viamraid.sys driver:

    Any ideas what I could do?
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Your minidump error is a 0xD1 and these are caused by faulty drivers or buggy software. The driver cited is viamraid.sys which is a VIA Raid Driver for Windows XP or VIA AHCI Raid Driver for WIN 2000/XP belonging to the software VIA RAID driver or viamraid by VIA.

    Either uninstall and re-install the drivers or update to the latest drivers.

    *** Let us know if this either fixed or did not fix your issues.
  5. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    Deleted double
  6. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    I need a bit of advice before I do that if you don't mind.

    I recently installed the above mentioned SATA harddisk into my computer and after that Windows XP SP3. Within the Bios in the Advanced features there is the option 'SATA-IDE'. I can disable it, set it to IDE or RAID.

    After I started installing XP setup asked for a 3rd party Raid driver so I used the lastest version at that time (two weeks ago this was the VIA V-RAID Driver v5.80c) and created a floppy. However, after a while during installation I received an error that the VIA RAID Controller 3149 didn't comply to the Windows Logo test which checks the compatibility with Windows XP (or something similar, I translated it from dutch). It gave me the same error when I used the floppy made from the 5.21A Hyperion driver.

    So I used the Raid driver from the Abit website instead of the new one.
    Everything went fine. Later I installed the chipset drivers (Hyperion v521A) and other drivers in Windows without any problems.

    A week later I was adviced to change the setting of the controller to IDE instead of RAID within the Bios because I only have one harddisk.

    I searched for all the Viamraid.sys files on my harddisk and I found these:

    -version 5.1.2600.530 (from the Abit floppy) at

    -version 5.1.6000.581 (Hyperion 521A) at

    Can there be some kind of conflict because I used two different versions? Can I safely install a new driver?
  7. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    I know nothing about RAID set-ups so I don't want to venture any guesses as to how to help you. I will say that a SATA harddrive is not an IDE harddrive. IDE is being phased out,

    The SATA harddrive should have been set to Master (or at least neutral) and set to SATA in the BIOS.

    And since your system wasn't configured to RAID there is little wonder to why that VIA Driver floppy didn't work.

    Perhaps raybay will respond later and give more knowlegeable experience. He knows tons more than I do.

    Have you tried setting your HD to SATA in the BIOS?
  8. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    There is no option for SATA, it is either IDE, RAID or Disbabled. When I set the controller to IDE the harddisk shows up in the Bios as a SATA drive, when I set it to RAID I can't find it in the Bios. The harddisk works fine though in both options.

    Unfortunately there is nothing to find in the manual about Bios settings.

    The Abit Raid floppy driver worked fine though.

    BTW There is no option to set the SATA drive to Master or Slave (which is normal).
  9. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    That is true about SATA, my bad. It gets tricky sometimes when you set SATA as the C Drive and slave an IDE. But I am aware you didn't do this. Have you tried the Abit forums (if they are still active)?
  10. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    I haven't tried the Abit forum yet, thanks for letting me know, good idea. But Abit is no longer selling motherboards anymore, so I'm not sure if they support it either. I will have a look later.

    But I personally doubt it is a Bios problem and/or RAID setting problem. I worked perfect for a few weeks without any crashes.
  11. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Well since you aren't running in RAID try uninstalling the VIA Raid drivers for Windows. Per minidumps it says this is the cause.
  12. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    I will do what you suggested. However it did not crash today as it did last two days. So maybe I will never know if it helped or not. I'll keep you guys updated.

    After I removed the VIA Raid driver my computer didn't boot anymore! I got the BSOD!
    STOP: 0x0000007B (0xF7C46524, 0xc0000034, 0x00000000, 0x00000000)

    I received the exact same error twice (also when I did try to boot in safe mode). i had to install an image I made two weeks ago but unfortunately I lost all my emails, favorites, etc. Grrrrrr. :-(
  13. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Crap! Man I'm really sorry. I feel terrible suggesting you might want to uninstall the VIA Raid driver. Here is your error


    Windows lost access to the system partition or boot volume during the startup process. Typical causes: Installing incorrect device drivers when installing or upgrading storage adapter hardware, or a virus.
  14. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    It is no big problem. I was able to find back most of my emails on my old harddisk. Pffew!

    Anyway, I removed the driver/hardware in the Device Manager. Was that the correct way to do it? Is it normal that Windows lost access to the system partion because I deleted the VIA RAID controller?

    Hopefully Raybay can tell us more if he reads this. This problem is getting on my nervs. ;-)
  15. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Take my next piece of advice for what it is. :blush: But perhaps you could post your issue in the Network & Storage forums because of the nature of your problem.

    Just a thought.
  16. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    I have done what you said. In the other thread someone gave me a tip to post the porblem on the VIA Arena forum.

    It turns out that newer versions than the VIA Hyperion v5.18A drivers are causing this problem! So hopefully problem is fixed!

    Thanks for your help so far.
  17. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Thanks for the reply! I'm feeling better. :) The minidumps did point to these drivers, but I really thought I messed you up. How did you resolve this? Roll back the driver?
  18. Anlavabeed

    Anlavabeed TS Rookie Topic Starter Posts: 53

    Well, rolling back the driver won't work, it is the only which is on the machine. I need to uninstall the current Hyperion dirvers, and then install an older version. I haven't tried it yet though, so I'm not 100% sure it is the solution. If it didn't help, I will let you know.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...