Black screen, no POST, no BIOS

Hi, when I push the power button on my Asus k50ab all I can see
is a black screen and the power light on.
1. Windows doesn't start at all.
2. Even when I tried to start with my RAM removed it's the same, only black screen,
no sound, nothing.
3. I tried to shuffle my RAM around in any possible combination is the same.
4. I also tried to start with my HDD removed, its the same.
5. I tried (quite a lot) to remove the battery, unplug the cable then
press the power button for 60 seconds and then start without the battery,
but sadly no result. Even tried it with my lid in the lowest angle possible.
6. I also tried to plug a monitor to my laptop (I did also press Fn+F8 to change
displays), but still nothing.
If anyone has any idea whats going on I'll be very thankful.
 

terry5880

Posts: 321   +3
hi dont quote me on most as not qualified and sure someone will get to u soon but can u see anything faintly in the back ground as i had that prob and notice at certain angles if i looked close enough i could see .. it turned out to be my lcd cable if screen is totally black could be number of things like cable inverter backlight or actual screen .. sure a tech will see this soon
 
no faint image

I can't see anything at all, the screen is as it's turned off. But I noticed that the screen blinks a bit in the exact moment when I press the power button.
 

terry5880

Posts: 321   +3
no power going to screen could be inverter or lcd cable or loose connection if not loose connection and 1 of others only way to find out if doing it urself is to buy the parts