Blue screen and memory dump error during playing WoW

By Liger · 5 replies
Dec 3, 2007
  1. Hey,

    about 6 months ago, I first got into playing World of Warcraft. When I first started playing it, I noticed two problems happening with the game:

    1. A lot of the interface buttons (the buttons that you click in-game to attack, use an ability etc.) were either messed up, or showed the wrong graphic.

    2. Every time I played the game, after a while the game would crash, and a blue screen would show up, saying there had been a fatal error, and that a memory dump was occurring. After this I could only switch off my computer and restart it. On restart, an error message would pop up asking if I wanted to send a report to Microsoft, but the details of the report weren't very helpful (especially to me, since I couldn't understand them at all).

    However, I managed to find a solution. After searching for a while, I remember coming across a forum, where a poster suggested getting a certain driver, and linked to it. Now not really understanding computers, I believe it was a driver, but I don't know if that would be the specific term. Anyway, on top of this I have a feeling that it was a previous version to my default driver on the computer, because I seem to remember that when installing it, the computer told me that it was less advanced than my current one.

    However, it completely fixed the problem, and I have never had problems with the game since.

    The problem is that recently, I had to completely reset my computer, and so it reverted back to its default state, including those starting drivers. Now I've installed World of Warcraft, and the same errors from before are coming up - dodgy interface buttons, and blue screens and memory dump errors. I've tried searching for that post, but I can't really find it. However, I was wondering whether, given those criteria, the people on this forum could suggest what it was that I downloaded last time. Like I said, I believe it was less advanced than the driver I have on my computer (and I do believe it was a driver, or something related to it).

    My current driver is something like: Mobile Intel® 915GM/GMS,910GML Express Chipset Family - well that might not be a driver specifically, but I think that might be where the problem lies (I hope it is, because I'm not sure where to look otherwise).

    Thanks in advance.

    P.s. I'm not sure if this is the right forum, but I'm pretty sure it's driver related, so I hope it could fit in here.
  2. Daveskater

    Daveskater Banned Posts: 1,687

    Hello, Liger, and welcome to Techspot :wave:

    Please take a moment to read the following threads to make your experience here as enjoyable as possible :)

    Message for all newcomers

    SNGX1275's Guide to making a good post/thread

    The Techspot FAQ

    If you could take a minute to fill in some of your profile information that would be helpful to all members of the forum :)
    Knowing someone's location in the world can be extremely helpful, even if you just put a country.

    Also remember to post any problems or questions that you have in the appropriate forums

    With regards to your problem, I would say you have the right forum so no worries ;)

    It sounds to me like a graphics driver is what you want. "Mobile Intel® 915GM/GMS,910GML Express Chipset Family" is your graphics card, which will be built into your motherboard. The latest drivers for your graphics can be found here. You will have to select your OS, and then a list will come up of downloads for that Operating System. Download the one from the top - this should be the latest version :)
  3. Liger

    Liger TS Rookie Topic Starter

    Thanks for the welcome. :)

    I went to the link, put in my version of XP, and selected the first result: Intel® Graphics Media Accelerator Driver for Windows* XP (exe)

    Howver, unfortunately when I ran the exe it said that the driver was not validated for my computer. :S

    Assuming that it was an older driver that I installed previoulsy to fix my problem, do you have any suggestions as to what that might have been, or where I could download it? I'll keep searching for that post in the meanwhile. :p
  4. Daveskater

    Daveskater Banned Posts: 1,687

    Ok, what pc do you have? By the looks of it you have a laptop. You can get drivers from your laptop's manufacturer then they're pretty much guaranteed to work ;)
  5. Liger

    Liger TS Rookie Topic Starter

    I do indeed have a laptop - a Dell Inspiron 1300. I'll search for drivers on the Dell website, and see what I can find there.

    EDIT: Aha! It seems that downloading a driver from Dell has worked! Thanks loads from the advice, I believe that this problem is solved. :D
  6. Daveskater

    Daveskater Banned Posts: 1,687

    Absolutely no problem, mate ;)

    Come back again if you need any more help :D

    I happen to be "one of the ones that came for help and never left" haha

    There's always something to learn with pc's and this is a great place do learn from, so the two go hand in hand really ;)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...