BSOD after standby

By catcher ยท 59 replies
Apr 6, 2010
  1. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    I still suspect its GPU related issue.

    Also, another more appropriate approach may be, to bring his ATI graphic card to your pc, and after uninstalling nvidia drivers, then reinstalling ATI drivers see what happens? If that is possible for you, I would suggest to you that you should consider this instead of the above.
  2. catcher

    catcher TS Rookie Topic Starter Posts: 49

    Two things

    I will do some tests on my and on another computer to see if I still have the same graphic problem.
    There just might be problems in a few maps so I will check some more maps / newer games and see if I have a similar problem there or not.
    Just an example, with my earlier GPU while playing certain UT2004 maps there was a clear problem, many textures looked bad and it was clear there was a problem. On the same maps on my new GPU the problem is gone in those maps. So I will test more maps and other games to be sure if the problem is gone/present.

    I will work normally on the computer and see if another BSOD will occur during the next weeks.

    For now I won't install the two programs I uninstalled back then, just to be sure they are not the cause for another crash if will occur.
  3. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Ok, please keep things update here, and let me know if you need any further assistance. Regards
  4. catcher

    catcher TS Rookie Topic Starter Posts: 49

    I left the computer on tonight, and in the morning I noticed this message:
    "windows was unable to save all the data for the file \directory\... The data has been lost. This error may be caused by a failure of your computer hardware or network connection"
    After clicking OK I got a few more messages, each with a different directory. The mouse cursor did not react but I was able to restart using the keyboard.

    I checked the event log, now I have a red X on the Application icon, and a message says its corrupted. Why did this happen?
    Under System I noticed many warnings which happened during the night.
    The most common warnings are repetitive 'DHCP' but before that I have a few 'TCPIP'
    Note the newest entry is Information about event log service being stopped, but I checked and its set to started.
    I attached the System log file.

    I don't understand what is going on anymore.

    I also noticed I have a "?" in yellow color in the "Device Manager", check screenshot of it, could it be related?
    I don't understand why such things happen, I installed all drivers after the format a month ago. Could a GPU replacement cause such problems?

    Attached Files:

  5. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Are you using SCSI Pass Through Direct (usually abbreviated as SPTD, filename/driver "sptd.sys", i.e. a part of daemon tools) ?

    Buried in these logs is this:

    The following boot-start or system-start driver(s) failed to load:

    Now I have never seen so many drivers/services failing to start at once. To rule out any HDD related issues can you please go to your HDD manufacturer's site and download diagnostic tools to thoroughly check your HDD's fitness?

    There are several issues with DHCP as well; now if you are not using DHCP you can safely stop this service from running at startup.

    Lastly about that unknown device issue, you can delete it by opening device manager, clicking on it and pressing del key. If windows find it again let it search internet for its drivers; if it can't do that, you can post its device name by right clicking on it, then going to properties, and then to details.
  6. catcher

    catcher TS Rookie Topic Starter Posts: 49

    I have daemon tools installed as I use it sometimes.

    Just after clicking OK after those messages, and before restarting, I got a popup window from startup organizer, and it showed a lot of of removed services or startup items.

    I think all is working now after restart. But what caused this?

    I will check for WD diagnostic tools and edit this line.
    For some reason I can't access western digital support page, but its main site works... I asked another person and the support site works for him.

    -I got WD Data Lifeguard Diagnostics from a friend.
    All of my 3 HDs pass 'SMART Status', as well as 'Quick Test'.
    'Extended Test' on two of the three drives also pass. I did not test the 3rd drive (which is dedicated for games installations).
    I would post the results, but there isn't any data there, just 'PASS'.

    About DHCP (is it listed as 'DHCP Client' under Services?), how do I know if I need it or not? :
    I have one computer, connected to the internet using cable - a modem and using a software dialer. Every time I reconnect I get a different IP (only last octets)
    I don't remember seeing those DHCP warnings in event log, and never so many one after the other.

    I will format, maybe the new GPU installation caused some problems... then I will see if I will notice any problems.

    *Just an update before I format: I was copying some files, then went back to firefox to browse, then it crashed and I got the same message I mentioned before. Check 'untitled' I attached for the message. The other yellow icon said something about a corrupt file.

    I have done the hdd diagnostics check... is there any other test to confirm there is no problem with the hdds?
    If its not hard drive failure, then could it be the some files in C (like the browser file the message warned about) for some reason is corrupted, and I need to delete it/reinstall the program?

    I've read that this error can be solved by either enabling or disabling hd's write caching on disk option. I check and its turned on on all of my hd's. I did not touch it so I assume that's ticked is the default windows setting.
    I guess I will try to untick it and see if its still happening... just weird that I get this message after new gpu install.

    Attached Files:

  7. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    I dont think it has (data corruption etc.) anything to do with GPU (unless the system crashes or something similar); e.g recently to trouble shoot my main pc; i checked all three different graphic cards available on a secondary PC; without any issue.

    Generally DHCP service is on by default in later incarnation of windows OS; and usually don't cause any issues. Even in your case it is not causing any of the issues you are facing I believe, probability is that it is causing some minor slow down here or there (e.g. startup). So until we are sure about what actual issue you are facing don't touch it for now.

    Now about HDD's write caching; if you disable it, it will slow down your OS, however, keep in mind that, data corruption can occur if your system suffers any of these:

    - Power issues
    - System failure / device issues
    - Improper shutdown etc.

    As you have already ran diagnostic tools from WD on your HDDs, we can side step physical issues for now; but I'll suggest you to run checkdisk on your OS hdd; you can do that by going to Start, then to Programs, Accessories and right clicking on Command Prompt, and select run as administrator. Once on command prompt type Chkdsk /r (when you run /r switch /f is automatically implied).

    Re-installing OS may eliminate some issues you are facing, but it won't make those artifacts go away in games though. Regards
  8. catcher

    catcher TS Rookie Topic Starter Posts: 49

    Before I formatted, I restarted the PC and then there was hdd check before getting to windows. I don't understand what happened to the hdds that the check was scheduled. Must be related to the hardware replacement.

    I do not understand why internet did not work properly.

    Until now I did not get any blue screens, so I hope that problem was GPU related.
    If it will be back I don't know what I will do...

    I understand it is hard for you to help me with every problem that pops up and to know if one problem is somehow related and causing another.
    It is weird that more problems happened (delayed write which never happened to me before, internet problem) after the GPU replacement.

    But for now computer seem to work fine. I will need to see if no blue screens happen during a couple of weeks, then I can assume it was GPU related.
    Do you think I can then install ZoneAlarm and Netlimiter?

    Thanks for your help until now.
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    Just as an aside re: Netlimiter.... I stumbled across Netlimiter several months ago (haven't used it much to date though) but it does look like a pretty handy tool. So would be interested to know if you determine yes or no if it's anyway related to your BSODs.. (btw.. don't know which version you're using but also noted they have some beta versions and a v3 available)
  10. catcher

    catcher TS Rookie Topic Starter Posts: 49

    I really have no idea, all I know is Archean wrote it might since a file related to NetLimiter is shown in that minidump so I uninstalled the program to see if the problem continued.
    I have been using the same version for at least a year so I assume its not the cause.

    Now that I replaced my GPU which I assume was the cause, if all works fine for a while, then I guess I will install NetLimiter again, assuming the problem was the faulty GPU.

    It's hard to believe every piece of software can cause a BSOD... especially since I don't use beta software. How it got to the minidump, if the cause was the GPU, I have no idea.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    My guess:
    > Netlimiter installs and uses a driver (and/or driver "filter") named nltdi.sys
    > The driver filter runs within the stack space of the process that BSOD'ed
    > So when looking at the minidump stack dump one sees netlimiter on the stack and it becomes a possible suspect
  12. catcher

    catcher TS Rookie Topic Starter Posts: 49

    Well a few days and no BSOD, and it seems that the graphic problem is gone as well.

    I now have ZoneAlarm installed, and will install NetLimiter again soon as well.

    So I assume the GPU was the cause for the BSODs, even though each minidump showed a different possibility.

    Thank you Archean for the patience and for your help.
  13. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    If you are using Zone Alarm (hoping you aren't using a paid version;)), I would suggest to dump it for good and use comodo or online armor they are far superior solutions IMHO and they are free :D.

    I'm glad things seems to be working out well for you now, please let us know if you need any further assistance. Regards
  14. catcher

    catcher TS Rookie Topic Starter Posts: 49

    I had a couple more BSODs while trying other software solutions...

    Could you check and let me know what they contain?

    Attached Files:

  15. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Both dumps are pointing at danew.sys - a component of DeathAdder mouse's driver.
  16. catcher

    catcher TS Rookie Topic Starter Posts: 49

    Sorry, another BSOD happened..
    I am trying to understand what is happening.

    The BSOD/minidump file was created just this morning, after it was on tonight, just when I moved the mouse to turn on the monitor (not from standby mode).

    I assume you will see this in the file, but I noticed it includes
    STOP: 0X000000D1


    Thanks you

    Attached Files:

  17. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    psched.sys is QoS Packet Scheduler in the windows network stack.

    0xD1 error is generally caused by bad drivers (in same cases it occurs because of hardware).

    Anyway, right now I would suggest you to uninstall your zonealarm again, because the actual culprit behind this bsod is vsdatant.sys (true vector device driver). Regards
  18. catcher

    catcher TS Rookie Topic Starter Posts: 49

    -I am having internet problems (occasional disconnections) and a DHCP warning in Event Viewer:
    Your computer was not able to renew its address from the network (from the DHCP Server) for the Network Card with network address 001D60AADDF7.  The following error occurred: 
    The semaphore timeout period has expired. . Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.
    It seems its happening from time to time, but much more often with ZA on.
    And having a message 'Closing Network Connection' for about a minute, whenever I restart my computer.
    Could these be related to this BSOD error and give an idea how to solve it?

    -I have updated drivers installed.
    However I just found a virus on my computer (non windows file lsass.exe, and sysdrv32.sys) which I removed, could it had something to do with the error/BSOD?

    -I can only think those viruses got to my system when I first connected to the internet with no firewall installed. Though the first thing I did was use windows update.
    Are you sure that ZA is the cause for this BSOD? Or could the viruses cause this error?

    I am also trying to figure out myself if it all leads to some problem...
  19. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    I am positive about the id of ZA's True Vector Driver being cause of your last BSOD.

    I think sometime earlier i suggested you to switch to Comodo or Online Armor. Both of these are excellent firewalls, infact IMHO they are far superior than ZA as well.
  20. catcher

    catcher TS Rookie Topic Starter Posts: 49

    It's weird more problems are starting to appear one after the other (currently DHCP error message resulting in internet problems), as until it started, I used the same programs I use now, and all worked fine.

    I wonder how can a firewall program cause a BSOD... it would be reported if there was a problem with it, or is it happening only on my system due to hardware/software installed?

    I did try Comodo Firewall but found it too complicated. I guess I will just have to learn how to use it.

    Will uninstall ZA and see regarding future problems/BSOD.

    Currently I do have some problem with internet connection whether ZA was turned on/off. I have asked on other forums regarding it (including as much detail as possible) but still can't solve the problem.
  21. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    What do you mean with internet problem (except that DHCP issue)? Also try stopping DHCP service in Services applet and see whether the error stops.

    Also badly written softwares/drivers can cause all sorts of issues including BSODs. I agree Comodo needs a bit more steep learning curve; that is why I also proposed Online Armor, both of these firewalls carry roughly same ratings. So perhaps you may give the later one a try as well.
  22. catcher

    catcher TS Rookie Topic Starter Posts: 49

    The internet problem... it might be related to issues I mentioned here, but I started this thread regarding a BSOD (which I believe was the faulty GPU) so I don't know if you could help me about it.

    Funny it started a few days after I replaced the GPU... that and other issues.

    Every hour or so (or every few minutes when ZA was on, like it was making the existing problem worse), the onboard ethernet controller (showing under Network Connections) is acting and there is no internet access, until it solves itself a minute later.
    The related messages in event viewer are:
    Your computer was not able to renew its address from the network (from the DHCP Server) for the Network Card with network address 001D60AADDF7.  The following error occurred: 
    The semaphore timeout period has expired. . Your computer will continue to try and obtain an address on its own from the network address (DHCP) server.
    Your computer has lost the lease to its IP address 172.x.x.x on the Network Card with network address 001D60AADDF7.
    This never happened before I opened this thread. Internet worked fine and there were no disconnections. This is not normal behavior. I have tried to find out the cause for this. Have tried changing network card, cable and changing settings. It still happens.
    Also under onboard Network Connection Details, 'Lease Expires' is always set to 5 minutes after the 'Lease Obtained'.

    Anyway, regarding that BIOS, it just happened again.
    Although it happened before I uninstalled ZoneAlarm, I did not have ZoneAlarm on while it happened.
    It was very weird... computer was working fine four hours (since my last reply) until just a few minutes ago I turned off the monitor, and 5 minutes later I turned it on and saw the blue screen... Like it happened because I turned off/on the monitor!

    I attached the minidump, it also contained info about psched.
    Now I have ZA uninstalled, will see what will happen next :/

    So many problems... like some faulty hardware is causing all of them or something. Frustrating.

    Attached Files:

  23. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Again 0xD1, with vsdatant.sys as the culprit (part of ZA); either it didn't installed correctly or left some stuff behind I guess.

    Secondly, probability is your internet connection required DHCP enabled; however, if you stop DHCP service in services applet, and select its start up mode as manual, instead of auto ;then restart your computer; and try to connect your computer with internet again and see what happens.

    Sorry I may be bit slow to respond in next couple of days due to couple of important meetings, which are scheduled to run well into evenings; but I will try to have a look in whenever possible to see whether things improve for you.
  24. catcher

    catcher TS Rookie Topic Starter Posts: 49

    ZA is uninstalled so I will see if the psched BSOD is solved.
    Do you think it would help the company solve it, if I let the them know about this BSOD and send them minidump?

    DHCP Client Service is set to automatic (XP default setting), so I will set it to Manual and see if it will help.
    Update: I changed it to Manual and restarted. Then LAC tried to acquire network address forever and there was no internet access, so I changed DHCP Client service back to to automatic. Any idea why this internet disconnection/DHCP errors are happening? Anything else to try? I'm lost as i've tried to change network card/cable/modem.

    I don't know if it matters, but should IPSEC Services be set to manual/automatic? I also applied some the following reg fix 'DisableIPSEC.reg' according to ISP instructions:
    Also, 2 other warnings in Event Viewer that might be related to internet disconnection issue, they happen occasionally, but not at the time of the disconnection and DHCP warning/error event viewer messages:
    The server was unable to find a free connection 37 times in the last 60 seconds.  This indicates a spike in network traffic.  If this is happening frequently, you should consider increasing the minimum number of free connections to add headroom.  To do that, modify the MinFreeConnections and MaxFreeConnections for the LanmanServer in the registry.
    TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts.
    In the past I did not have issues with ZA older version, and also did not have such a DHCP/ internet disconnection issue with the same ISP so its weird these problem start now.

    I appreciate you helping me, take your time and reply when you have the time.
  25. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    There is no harm in forwarding such information to ZA, perhaps they will act and fix their broken stuff improving the experience of all of their users. I will get back to you about network related issues asap.

    I think disabling IPSec service on the contrary may result in connectivity issues. Have they given any reason for asking you to disable this service?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...