Tech Stocking Stuffers: 18 awesome gifts under $50

BSOD Bad Pool Caller Error

By Lyle K ยท 21 replies
Jan 2, 2006
  1. I built this computer six weeks ago and had no problems for a month! The first sign of problems came just before Christmas with random crashes and lock-ups!
    It appeared to be a video card error and I pursued that avenue for a while, even sent the card back to the manufacturer (with there approval) for replacement. In the meantime, I bought another video card (so that I can SLI them when both get here) of the same manu. and model. I installed it, updated the drivers and all seemed well... For about 2 hrs! Then I got more crashes. I downloaded MEMTEST and found that one of my 512mb RAM cards was showing errors. I moved them to a different slot and tried again... No luck, so I removed one and the errors quit in Memtest. I thought I had the problem!
    Yesterday, I got this new error (the one in the header), since this one is a new type of error that I have never seen on this system, I thought I would get some help!!
    The system is:
    AMD Athlon 64 3500+
    Abit A8N-SLI mobo
    1GB RAM (Currently using 512MB)
    eVGA Nvidia 7800GT Video card
    DVD/CD ROM combo

    The error message is:
    Technical Info:
    ***STOP: 0x000000c2 (0x00000007, 0x00000cd4, 0x00000000, 0xfb913b78)

    Any help would be appreciated, as I have reached my level of experience!!
    I have attached the last four or five minidumps. Keep in mind that the earliest ones may have occurred prior to me removing the bad RAM!

    Attached Files:

  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Here is an MS article on the 0xc2 stop message, maybe that may lead you somewhere.

    You dumps point to:

    nv4_mini.sys "GetUlongFromAddress: unable to read from 80562970"
    ^^nvidia driver.

    BugCheck 10, caused by cmudau.sys
    ^^looks like an audio driver

    BugCheck 1000007F- cause by ntoskrnl.exe
    ^^ likely before ram

    BugCheck 4E- probably caused by memory_corruption

    GetUlongFromAddress: unable to read from 80562970. caused by dxg.sys
    ^^not sure what dxg.sys is for

    That may give you something to research. It would be good to get a few fresh dumps from AFTER taking ram out, just to be sure. I checked these in no particular order.
  3. Lyle K

    Lyle K TS Rookie Topic Starter

    Interesting, the drivers were all updated in the last twenty-four hours and I have had at least one crash since!
    The minidumps are dated... one from yesterday and two from today!
    I will do some more reading but am unsure which direction to go!

    Dxg.sys appears to be a Directx graphics driver.
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    I saw one from today, Jan2, that is the one for:

    GetUlongFromAddress: unable to read from 80562970
    Probably caused by : dxg.sys < dxg+9389 >

    You got two of thos GetUlong errors, likely related. But if it's a directx file, I just wonder if it might be a fluke. Bad RAM could certainly cause the rest of those errors.

    I would do all your Windows updates (including of course the latest DirectX).
    And it might be a good idea to run System File Checker. You'll need your Windows CD. Click Start-Run and type sfc /scannow. This will replace any corrupt files in Windows.

    good luck
  5. Lyle K

    Lyle K TS Rookie Topic Starter

    Ok... Will give it a shot and I'll update too. I suspect I'm up to date but will check.
    I'll get back to you soon!
  6. Lyle K

    Lyle K TS Rookie Topic Starter

    Ran sfc and checked windows update, also, d/led and installed the latest update for directx. Rebooted and started playing a game. It lasted about 20 minutes and crashed!
    Same error, the last parameter changed to: 0xfe1b1008

    The minidump file is attached!
  7. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Ok, this one crashed from "kmixer.sys"
    This is the Windows Kernel mode audio mixer.

    The bugcheck was C2, or 0x000000C2 "BAD_POOL_CALLER"

    Check out this MS page:

    Got the link from this page (do a search for "C2", you'll find the section with bad_pool_caller)

    After reading those it may help more.

    You may want to replace the kmixer file, or update your audio drivers, or both. However, BAD_POOL_CALLER is also RAM error. I wonder if you're just feeling repercussions of a bad stick of RAM?
  8. Lyle K

    Lyle K TS Rookie Topic Starter

    I updated the audio drivers today, along with every other driver I could think of!
    The memory came as two 512mb cards, one, I know is bad and is not in the computer. The other...... dunno!
    I'll take a look at the sites in your last post and then attempt to get a few more crashes, so you can see more dumps!
    Fun stuff!
  9. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Also note kmixer is the "windows" kernel audio mixer. Not your actual sound card. Which is why you might consider extracting this file off the XP CD again. But if you crashes keep showing up in random files, it may still be a memory issue.
    However, Directx and kmixer may be kissing cousins so they could be related (multimedia).
  10. Lyle K

    Lyle K TS Rookie Topic Starter

    Got a different error this time!
    ***STOP: 0x00000019 (0x00000020, 0xfba85000, 0xfba85b68, 0x0b6d0000)

    Minidump attached again!

    It seems to happen the most when I exit a 3D environment, ie, a game!
  11. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    haha, this time it says:

    BugCheck 19, {20, fba85000, fba85b68, b6d0000}
    Probably caused by : cmudau.sys ( cmudau+5d7bb )

    I can't find any trustworthy info on this file. Though it does look like an audio driver again. Something is very fishy with your audio! Do you have onboard sound or a sound card? If you have a card, try removing it. Or if you have onboard sound, try disabling. You will have to play games with no sound, but if it doesn't crash, we'll know who the culprit is. Try disabling ALL your sound hardware.
  12. Lyle K

    Lyle K TS Rookie Topic Starter

    Well, I have both!
    And to add insult to injury, I also have a USB sound driver.
    The on-board sound is disabled... I never have loaded the drivers for it.
    I have a Sound Blaster audilugy 2 (sp) card. Its drivers are up to date.
    I also have a set of 5.1 speaker headphones that uses a usb port and another set of drivers. Its drivers are current also.
    I notice that when I plug in the headphones, the SB icon on the task bar goes away and the USB headphone icon appears, also, the sound switches from the speakers to the headphones automatically.
    I will try it without sound tonight and get back to you. I'm going to change out the memory as well.
    Been doing a lot of reading on this forum and am very impressed!
    One question, based on the system I posted, plus another GB of RAM, what size PSU should I have???

    Thanks for the help!!!
  13. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Excellent, turn off all those drivers and just see what happens.

    As for your PS, maybe Sharam could give some advice :)
    But in general, if you're talking 64-bit with SLI, and 2GB of RAM, you would do well with a high quality, high output 500W+
    You may get away with a 400w-450w IF it is a high quality PS.
    Expect to pay ~$80-~$150us for a PS like those. Possibly more if you opt for some fancy features.
    Check out the PSes on Check out Antec's web site as well.
  14. Lyle K

    Lyle K TS Rookie Topic Starter

    I removed the sound card, checked the on-board sound and made sure it was disabled. Removed all the drivers and software for the sound card and the headphones.
    I didn't get around to replacing the memory, will do that tonight. So I still have 512mb's of RAM (which is suspect!).
    Played for awhile last night tried everything that I've done in the past...
    No crashes!

    I'm still skeptical and will continue to test tonight before reinstalling any sound devices. I'll keep you posted.

    On the PSU issue...
    I am running a Rosewill 500w unit. The spec.'s meet everything I have read for a high end system. I just wanted to get an unbiased perspective before telling you what I'm using!
    I didn't find much info about the Rosewill units, but one article mentioned them to be of good quality and reliable. And it received good reviews from the site I bought it from (which doesn't mean much!) Any thoughts?

    Just looked at the spec.'s for Rosewill again... It appears to only have one PCI-E 6pin connector. That's not good! I may need to upgrade after all!
  15. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    There are special power supplies specifically for SLI setups, with proper output capacity and dual power plugs to handle the extra load. You would probably do well to replace just for this alone.
    Look for a PS that is "SLI Ready" or some such.

    Otherwise, 500w is good for the wattage alone, but it doesn't mean you have high amps as well.
    Here is a couple power supply calculators to see how much you need:
  16. Lyle K

    Lyle K TS Rookie Topic Starter

    Got the other video card and the new memory today and installed.
    Set my system up to SLI and tried a few games without sound... All seems well.
    I reinstalled the sound card and its drivers. Tried a few games and again all seemed well.
    After playing for a bit, I unplugged my joysticks 120v power cord and immediately got a system crash! Maybe a coincidence but I attached the file for you to look at!
    The error was IRQL OPEN AND CLOSE or something like that... I didn't write it down.
    Minidump attached.
  17. Sodisna

    Sodisna TS Rookie

    Maker sure you have SPyware and Antivirus programs. Something like this happend to me. I had a heap of spyware. Got so bad I had to format. Anywho, if not that, make sure you fully install your drivers. Also, always restart after you install drivers, even if it doesn't ask you to. Sorry, couldn't be of more help.=P
  18. Lyle K

    Lyle K TS Rookie Topic Starter

    No spyware!
    Another new error!
    STOP: 0x000000D1 (0x00000000, 0x00000002, 0x00000000, 0xf4985343)
    ha10kx2k.sys - address f4985343 base at f4904000 datestamp 3f94fbac

    This pointed to a Creative Driver problem, so I updated the drivers and will try again. The minidump is a ttached for your info.

    Everythings seems to come back to sound card or driver issues!??!
  19. Sodisna

    Sodisna TS Rookie

    Hm...If it's your sound card drivers, I'd suggest getting another on and see what happens.
  20. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    The first dump pointed to imhidusb.sys, which appears to be some kind of USB driver for a racing wheel or some other device. Maybe your usb audio thing?

    The 2nd one is of course your Sound Blaster. We're still pointing to audio and usb! Maybe that card really is bad, or at least has deep driver corruption.
  21. Lyle K

    Lyle K TS Rookie Topic Starter

    Well, d/led and installed the latest drivers for the sound blaster and I have not reinstalled the usb audio headphones. I believe these two items may conflict with each other!
    The other error occurred when I unplugged my joystick, so I think it was just one of those things!
    I haven't had a crash in a while but am still not sure if everything is good... I'll keep posting, if an error comes up!
    In the meantime, thanks for the help!
  22. avioza

    avioza TS Booster Posts: 114   +51

    Sound Blaster Cards and Bluescreens

    I have had several issues over the past years with sound cards freezing my PC in one case without even a bluescreen to diagnose. Nothing made sense... it came down to the soundblaster card. Your onboard audio will work fine ill bet.

    Thats eventually what I did despite the poor quality. And tossed the card, it was lower end though. I'm surprised its happening with Audigy as well...
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...