Buffalo hard drive not recognised by MacBook

By AdamJohn
Nov 27, 2014
Post New Reply
  1. I have a three-year-old Buffalo 1TB external hard drive. It has always worked fine and hasn't been used very often (once every few months for back-ups). It contains thousands of files totalling maybe a few hundred G. This week my Macbook refuses to recognise the existence of the hard drive. The hard drive has power, is motoring, but there is no icon on the macbook, nothing in disk utility etc, and no sign it exists. I have tried both the USB ports available on the macbook. The hard drive has a 1 SATA drive. The macbook is running OSX 10.5.8. Is this a software update issue or is this a self-destruct thing?
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Doesn't sound good. What happens when you connect it to a different computer?

    The enclosure could have died and left the actual drive itself ok. I'd consider opening it and pulling out the drive itself and placing it in a dock.

    I hope your data isn't gone, but this needs to be a lesson to everyone, never keep important data in only one location.
    jobeard likes this.
  3. Techpumpkin_WD

    Techpumpkin_WD TS Member

    Hi there,
    You can also try using a different USB cable or to connect it to a different machine. It's also a good idea to run the manufacturer's diagnostic tool.
    Good luck!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...