Bugcheck Error (8086) ntoskrnl.exe ( nt!KeWaitForMultipleObjects+43 )

By Baron_Nogood ยท 20 replies
Jul 18, 2005
  1. Hi,

    When playing some multiplayer games my computer will suddenly reboot itself. I did a bugcheck analysis of the minidump and it came up with this. I can't make hide nor hair of it so would appreciate a look by an expert :).

    The crash only occurs when I am running Battlefield 1942 but never occured on my previous machines. The crash has occured on 8 occasions, every time I was playing a game online. I can't remember if it reset itself during any other game. It always relates to ntoskrnl.exe


    Abit AA8 Mobo
    2 x Corsair Value 512MB DDR 2 (533)
    PIV 3ghz (LGA775)
    Antec 480W PSU
    Gigabyte Geforce 6600GT

    Microsoft (R) Windows Debugger Version 6.5.0003.7
    Copyright (c) Microsoft Corporation. All rights reserved.

    Loading Dump File [C:\WINNT\Minidump\Mini071805-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Symbol search path is: C:\Symbols\symbols
    Executable search path is:
    Unable to load image ntoskrnl.exe, Win32 error 2
    Windows 2000 Kernel Version 2195 (Service Pack 4) MP (2 procs) Free x86 compatible
    Kernel base = 0x80400000 PsLoadedModuleList = 0x80485b00
    Debug session time: Mon Jul 18 23:09:01.187 2005 (GMT+1)
    System Uptime: not available
    Unable to load image ntoskrnl.exe, Win32 error 2
    Loading Kernel Symbols
    Loading unloaded module list
    Loading User Symbols
    * *
    * Bugcheck Analysis *
    * *

    Use !analyze -v to get detailed debugging information.

    BugCheck 8086, {0, 0, 0, 0}

    Probably caused by : ntoskrnl.exe ( nt!KeWaitForMultipleObjects+43 )

    Followup: MachineOwner

    0: kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    Unknown bugcheck code (8086)
    Unknown bugcheck description
    Arg1: 00000000
    Arg2: 00000000
    Arg3: 00000000
    Arg4: 00000000

    Debugging Details:



    BUGCHECK_STR: 0x8086

    LAST_CONTROL_TRANSFER: from 00000000 to 8042be0b

    eb47bc60 00000000 00000000 00000000 00000000 nt!KeWaitForMultipleObjects+0x43

    8042be0b ?? ???


    FOLLOWUP_NAME: MachineOwner

    SYMBOL_NAME: nt!KeWaitForMultipleObjects+43


    IMAGE_NAME: ntoskrnl.exe



    FAILURE_BUCKET_ID: 0x8086_nt!KeWaitForMultipleObjects+43

    BUCKET_ID: 0x8086_nt!KeWaitForMultipleObjects+43

    Followup: MachineOwner
  2. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    Just had a thought about this one. Windows doesn't think I am using two processors does it?

    "Windows 2000 Kernel Version 2195 (Service Pack 4) MP (2 procs) Free x86 compatible"

    There is an option in my BIOS which relates to multiple processors which I believe is enabled (it recommends that it is disabled for any XP based system, however I have Win 2K SP4 (With rollup update)). Could this be causing this error?
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    I have W2K/SP4 on my PC as well, but I've never seen that MP (multi-processor?) (2 procs) or anything like it on my (single CPU) PC.
    Unless you have 2 physical CPUs, disable that option.

    Give us your PC specs just in case.
  4. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    It is actually installed as such. Under "Devices", "Computer" it has "ACPI Multiprocessor PC"...according to my IT guru, that is because the HT tech on the P4s pass off the one processor as two...hum.

    Anyhoo...I loaded BIOS optimum defaults then the only thing I did was disable onboard sound and change my SATA drive from IDE to AHCI mode...(Windows was installed with relevant drivers for that). Not sure what the prob is, but hopefully setting the bios to the way it was before should help...if not I'll be back. Should anyone understand what an 8086 is, or can explain what is going on when the machine is "Waiting for multiple objects" then I would appreciate that!
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Windows 2000 supports MultiProcessors, as well as Intel's HyperThreading, BUT W2K does not distinguish between physical and logical processors, it simply fills out the license limit using the first processors counted by the BIOS.
    The 8086 was the first 16-bit CPU that Intel made, and the original base for newer CPUs such as 80186 (rare), 80286 (the famous AT), 80386 (first 32-bit and FPU), 80486 (Pentium) and currently 80586 (P4).

    I don't understand the mumbojumbo about 'waiting for....'
    A search on the web confuses even more.

    Have you tried playing it with HT OFF?
  6. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    I have two cases which simulate to your case and they are hardware problem. According to my experience, you cannot base on a minidump to conclude the problem. You need to process 5 to 6 minidumps and analyze the failing pattern in order to conclude the problem. Software error is usally consisent and it always fails at the same instruction address. Hardware error usually occurs randomly and your windows will crash with different bugcheck code at different instruction address.

    kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If a kernel debugger is available get the stack backtrace.
    Arg1: e816f000, memory referenced
    Arg2: 00000002, IRQL
    Arg3: 00000001, value 0 = read operation, 1 = write operation
    Arg4: 804e40c9, address which referenced memory

    Debugging Details:

    WRITE_ADDRESS: e816f000


    804e40c9 8902 mov [edx],eax




    LAST_CONTROL_TRANSFER: from bf8aec51 to 804e40c9

    TRAP_FRAME: f85d5a10 -- (.trap fffffffff85d5a10)
    ErrCode = 00000002
    eax=820a82a0 ebx=820a8270 ecx=0000000a edx=e816f000 esi=81eb9da8 edi=00000000
    eip=804e40c9 esp=f85d5a84 ebp=f85d5ab4 iopl=0 nv up ei pl nz na po nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010206
    804e40c9 8902 mov [edx],eax ds:0023:e816f000=????????
    Resetting default scope

    f85d5ab4 bf8aec51 00000007 82112438 00000001 nt!KeWaitForMultipleObjects+0x23f
    f85d5d30 bf8c8594 f85c54a8 00000002 f85d5d54 win32k!RawInputThread+0x4f3
    f85d5d40 bf800ff4 f85c54a8 f85d5d64 006dfff4 win32k!xxxCreateSystemThreads+0x60
    f85d5d54 804df06b 00000000 00000022 00000000 win32k!NtUserCallOneParam+0x23
    f85d5d54 7c90eb94 00000000 00000022 00000000 nt!KiFastCallEntry+0xf8
    WARNING: Frame IP not in any known module. Following frames may be wrong.
    006dffe0 00000000 00000000 00000000 00000000 0x7c90eb94

    bf8aec51 391df08d9abf cmp [win32k!gdwUpdateKeyboard (bf9a8df0)],ebx


    FOLLOWUP_NAME: MachineOwner

    SYMBOL_NAME: win32k!RawInputThread+4f3

    MODULE_NAME: win32k

    IMAGE_NAME: win32k.sys


    STACK_COMMAND: .trap fffffffff85d5a10 ; kb

    FAILURE_BUCKET_ID: 0xA_W_win32k!RawInputThread+4f3

    BUCKET_ID: 0xA_W_win32k!RawInputThread+4f3

    Attach the output of your minidump so I can confirm which hardware component is faulty.
  7. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    My error has been consistent. It is always 8086 with all 0 arguments, and it is always ntoskrnl.exe. It has occured 8 times and is the only error I have had.

    I also remember a random error message I kept getting which was "Device=ffffffff", which has now ceased.

    One time after reboot due to this error, my post screen and windows start up screens were different sizes and I had to manually adjust them to fit on my monitor, could it be my monitor drivers (which Win 2K SP4 rollup really didn't like)?
  8. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Maybe faulty m/b is the culprit. Zip two to three minidumps and attach the zip file here.
  9. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    Attached. All instances of same error + DxDiag report. I'd be interested for any feedback.

    Attached Files:

  10. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    I think this is memory corruption and stack trace is corrupt as well. The memory corruption may be caused by hardware or software problem. The stack trace has the footprint of iaStor.sys.

    1. Upgrade SATA drive iaStor.sys
    2. Upgrade or de-install Zone Alarm as your version has known bug
    vsdatant vsdatant.sys Wed Apr 20 05:37:55 2005 (42657A33)
    refer the following case
    problem owner Sonica
    problem owner Debelion
  11. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    Thanks very much for that help cpc, most appreciated. I will try all of the above.
  12. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Do you have any update of the problem?
  13. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    Played BF1942 last night...no crash and I was on for a long time...so maybe it is sorted. I'll report back with any problem!

  14. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Do you mean after you uninstall Zone Alarm and the problem is resolved?
  15. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    It certainly looks that way
  16. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Besides uninstall ZoneAlarm, do you upgrade iaStor.sys as well?
  17. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    No, I don't know if there was a need to upgrade iastor, however I did install an Intel Utility for managing AHCI drives that wasn't present before. This seemed to do the trick. I'll do some proper tests on it tonight, but as far as I can see the problem has gone. Teething problems with my self built machine no less!

    Thanks again for your help, I'll post any errors I get here should they reoccur.
  18. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Thanks for your reply. I get an similar problem at another forums and he does not install ZoneAlarm. BTW could you tell me which intel utility that you install?
  19. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

  20. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

    Thanks a lot. There have several cases at other forum failed with bugcheck code 8086. Your solution may help them to resolve their problem.
  21. Baron_Nogood

    Baron_Nogood TS Rookie Topic Starter Posts: 38

    Let me know if it helps, I would be interested.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...