Can not connect to Internet

By Ambam00 ยท 22 replies
Feb 29, 2008
  1. Greetings,

    I am unable to connect to the internet with any program (IE, firefox, yahoo! messenger, real player, etc). I am running windows XP pro (unregistered version). the only thing I did today is download and run ccleaner (at my beau's insistence, he's and IT person for the local college). I think this effected something, he says it didn't. Regardless, I can not get on the internet or connect in any way (so I'm using a spare computer to find information). We have a home network and DSL. All other computers connect fine. The lights on the wire from the router to my computer turn on properly when plugged in (the cord isn't bad). I don't know what to do. I will post what ever information is requested, but as you can probably tell I am not the most computer literate. I can successfully ping the IP and DNS in cmd prompt, but can not ping any external sites (google, yahoo, etc). Please help if you can.

    Very lost,

  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Start -> Run -> inetwiz

    Or go to a command prompt and type in:

    ipconfig /release

    and then

    ipconfig /renew
  3. Ambam00

    Ambam00 TS Rookie Topic Starter

    still not working


    I did the inetwiz and told it to set up through the lan, it went through all the steps but still doesn't work.

    I tried to use the cmd prompt of ipconfig /release and recieved the following error message:

    The operation failed as no adapter is in the state permissible for this operation.

    Any other suggestions?


  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Go to Start->Control Panel->System->Hardware->Device Manager, and see if the network adapter or simple communication adapter are flagged in red or yellow... which is probably does based on the ipconfig/release.

    Run ipconfig /renew

    You may need to download and replace your drivers for the ethernet adapter... and you may have to reinstall your modem.
  5. Ambam00

    Ambam00 TS Rookie Topic Starter

    No problems shown in device manager. I don't have a modem, I have DSL (I do use a router). I can connect to other computers on the LAN, just not the internet. I will try uninstalling and reinstalling my ethernet card (its a VIA Rhine II Fast Ethernet Adapter)

  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Also confirm in bios if disabled there too (actually not sure if that'll be it)
  7. Ambam00

    Ambam00 TS Rookie Topic Starter

    The lan part works, the internet doesn't. I can access other computers and have other computers access mine. Its really confusing. Bios showed properly active.
  8. Hodsocks

    Hodsocks TS Guru Posts: 382

    I assume other pc's on the LAN can connect to the internet OK and you can get into the software on your router with the troublesome pc.

    Forgive me for asking but being in the UK am not sure of your DSL setup, do you have a router connected to a cable modem or is it a router with built in modem?
  9. Ambam00

    Ambam00 TS Rookie Topic Starter

    The problem is apparently something to do with registering with the DNS? Does this mean anything to anyone?
  10. Ambam00

    Ambam00 TS Rookie Topic Starter

    ok, I can not access the router from the computer. I can still access other computers on the LAN. Other computers can connect just fine. I've installed the newest drivers for my ethernet card, this did not change anything. Should I try replacing the card entirely? ITs a Router connected to a DSL modem.

    Replaced the ethernet card. This did not fix the problem. LAN still works fine, just can't get online.
  11. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    let's see how your TCP is configured;
    run->cmd /k ipconfig /all

    past the results in your follow-up
  12. Ambam00

    Ambam00 TS Rookie Topic Starter

    cmd ipconfig /all shows:

    Widows IP Configuration

    Host Name........Fingerloop
    Primary DNS Suffix....
    Node Type.....Mixed
    IP Routing Enabled...NO
    WING Proxy Enabled...NO

    Ethernet Adapter Local Area Connection 4:

    Connection Specific DNS suffix......
    Description...:3Com 3C905TX-based Ethernet Adapter <generic>
    Physical Address...:00-60-97-B5-61-54
    Dhcp Enabled...No
    IP address.....:
    Subnet mask...:
    Default Gateway...:

    The /k command caused an error message, this is the regular ipconfig /all. Hope this is what you wanted.
  13. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    hum; you should have a DNS just under the Gateway (addresses will be different)
            Subnet Mask . . . . . . . . . . . :
            Default Gateway . . . . . . . . . :
            DHCP Server . . . . . . . . . . . :
            DNS Servers . . . . . . . . . . . :
    also you don't have DHCP set active, so the configuration is fouled up.

    use View Network Connections
    find the Lan
    right click->properties
    find and select Tcp/Ip ; click Properties button

    set DHCP for both IP and DNS

    click OK, OK until the window closes

    get the CMD prompt via run->cmd

    ipconfig /release
    ipconfig /renew

    (you should now have a DNS entry from the ipconfig /all
    if so, follow with this)

    ipconfig /flushdns
    net stop "DNS Client"
    net start "DNS Client"
  14. Ambam00

    Ambam00 TS Rookie Topic Starter

    ok, I followed all of the steps, and it does show a DNS server address now on ipconfig, but it still will not access the internet. also, despite adding the address in both the IP and DNS sections of the LAN, the config still shows DHCP as not enabled. My computer would not let me do ipconfig /release gave me the "no adapter is in the state permissible for this operation" error. Also, I can sucessfully ping all the addresses given. just not external (ie: google) addresses. Silly question: should the DNS and default gateway have the same address ( ? If not how do I know what to put in the DNS address?

    Ok just checked with the Beau (who put this whole lan thingy together) He says we are not using Dhcp we are using static IPs. Don't know if this helps or not, but thats what he said.
  15. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    don't add my address, get DHCP working

    DNS is not the same thing as gateway
    The static addresses ARE the problem. An ISP can change them and you'll have fits making it work :(
    you have no 'internet access' because ping will not work either.
    If that doesn't work, the the browser and your email will not work.

    it appears that the error above is your primary problem.

    the Private Message sent earlier explains DNS operations:
    In your command prompt enter IPCONFIG /ALL
    Near the bottom you will see (usually) two lines associated with the label DNS Servers . .
    Whenever your system requests site-by-name, the operation flows like this:

    Request --> Gateway --> DNS address
    Returns the ip-address thereof <-- Gateway <-- DNS
    Request ip-address --> Gateway --> off into the WWW
    Reply from <-- Gateway <--

    4:- Now prove that your browser can find pages using a name rather than an ip-address:
  16. Ambam00

    Ambam00 TS Rookie Topic Starter

    the Lan to Router uses the static IP address. The router to DSL modem uses Dhcp. The static IP addresses are working fine for all the other computers. We tried changing which LAN port I was accessing, and still recieved the same error. For some reason, the computer can use the router, but not go from the router to the modem, and changing the port on the router that is accessed did not help.
  17. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    listen carefully; you have no DNS address on the failing system.

    there are two ways to get it:
    1- use DCHP from the NIC to the router OR
    2- manually enter the DNS address​
    if the other systems are accessing urls and email, then COPY their DNS address
    into the NIC of the failing system.

    There's nothing else I can do from here if you will not take suggestions -- good luck.
  18. Ambam00

    Ambam00 TS Rookie Topic Starter

    I did manually enter the DNS address. Problem was still not solved. I used the same DNS that is working on the other computers.
  19. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    do you still see
    "no adapter is in the state permissible for this operation" error.
    attempting run->cmd /k ipconfig /release; ipconfig /renew ?
  20. Ambam00

    Ambam00 TS Rookie Topic Starter

    why do you have /k in the line? My computer doesn't recognize that.
  21. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    hum; /k says KEEP the command prompt window after running the **whatever**.

    Please post your OS and hardware specs; there's a disconnect on what you're reporting and how each system gets configured.
  22. Ambam00

    Ambam00 TS Rookie Topic Starter

    Ran a system restore to an earlier date (wednesday) because the computer worked then. I had to manually update the IP information on the LAN, and restart and it works. McAfee is unhappy, says that files are missing. Other than that, I can get on the internet. I am updating mcafee now, and am going to download ccleaner again. If it messes up again, I'll let you know. Oh, and I'm killing McAfee and getting Avast.
  23. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    VERY GOOD :wave:

    AVG Free 7.5 is very good choice too :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...