Cannot enter BIOS using Del key - DFI LanParty UT NF4 SLI-DR Expert motherboard

I've got this legendary socket 939 motherboard DFI LP UT SLI-DR Expert chipset nForce4 SLI almost new only one SATA port is somewhat messed up missing those plastic parts from both sides , bought this baby really cheap ~ 55 $ from well known Romanian e-bay like site , and I put it on my FX-60 dual core ( yeah,THAT one! ) and some KINGSTON value memory and tried to boot my rig.Here is my problem now:this board is working those 4 red diagnostic LEDS start 4,3,2 next only one left so no "4 LEDs of death" syndrome for me
and the onboard speaker beeps ONCE which I know is always a good thing
but I cannot enter BIOS to setup as I need Del key on my PS2 keyboard is NOT working as it should I press the key and the result is 0 nada nothing
, first I see the boot logo from DFI after that I see this error message "CMOS checksum error - defaults loaded , press F1 to continue or Del to enter setup" and when I press Del I get nothig and when I press F1 key sometimes I see this message "Verifying Pool Data and Backup CMOS OK!" and other times I see "Sil3114 SATA RAID Press Ctrl-S or F4 to enter RAID utility".One more thing to add is that I can actually use boot menu selection using Esc key to selct HDD,CD-ROM or some other option and this board actually can boot using CD/DVD I already tried UBCD rescue CD and some Linux live distros to see if it's not a problem with my FX-60 processor and I'm happy that it is working well is all good no problem here actually I've seen it's name and working frequency ~ 2616 Mhz at POST, please help me to solve this problem with my mobo.