Cannot renew IP address even after format

By chamilo
May 28, 2009
  1. Hello there,

    My computer has been having this very weird connection problem since last week. It comes and goes for the past weeks. At first I thought it was a virus problem so I formatted my computer. But the problem is still there even after the format. My computer is connected to a wireless router through an Ethernet cable.

    After the format I figured maybe it was the router or modem's problem so I power cycled both of them but no luck. Then I tried to connect to the internet with my laptop. Both wired and wireless work on my laptop so it must be a problem on my desktop.
    *I can connect any time on my laptop so it must not be a problem of ISP, modem or router.
    *I had also tried plugging the cable straight into the modem with my desktop when there is a connection problem but it won't work.
    *The same problem occurs before AND after format.

    Every time after a restart or shutdown the LAN connection info in the network place will be correct and it shows that I'm connected. But then it either works or it won't. When it doesn't work I will renew the IP but then it will not work anymore.

    I had isolated the problem down to the hardware of my desktop. Is there any way I can figure out which part is failing on my desktop?
  2. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Given your circumstances I'd guess that it's either a screwy driver/some other software fluke or a faulty NIC.

    Granted, you reinstalled the OS but if your software setup is identical to before, you'd potentially experience the same anomalies.

    If it's hardware related it's probably either your NIC or Ethernet cable. Your NIC is likely integrated - and one that connects via PCI would probably run you $12 give or take at WalMart. I'd swap out the Ethernet cable before making any purchases, just for the hell of it.
  3. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    EVERY router out of the box has a firmware update and once updated this problem
    is usually corrected.

    the problem is in the software control for release/renew
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...