Can't delete backup folder in Vista

Not open for further replies.


Posts: 51   +0
Hi gang,

So I am running Windows Vista Home on my new Gateway laptop. A couple of weeks ago I had to do a restore and chose to backup the files at the same time. It created a folder on the hard drive called "backup". In this folder, is everything that was on my hard drive before the restore - including the Program Files, Users and Windows folders. I'm ready to delete this folder (as it's taking up about 20GB) but it won't delete. It has let me delete everything except those three folders and their contents. I've even been able to delete some of the sub-folders of Program Files, but not the folder it's self.

I found an article that mentioned that I had to take "ownership" of the folders before I could delete them. I followed the instructions on how to do this, and I think I did that successfully. But I still can't delete them. The error message says it's just unable to delete the folders.

Any ideas? Thanks.
I also have a Gateway PC, running Vista... and I experienced the EXACT same situation of having to recover/reinstall Vista and ending up with folders in C:\BACKUP that could not be deleted.

Below are the steps that I took to change ownership and control permissions for the troublesome folders/files. (NOTE: I don't know if this will make any difference, but I had turned off the "User Controls" for my Vista account. My Vista account had Administrative privileges. My Vista desktop "theme" has been set to a classic start menu and classic folders.)

You'll need to use Windows Explorer to navigate to the location of the folder you want to delete... then follow these steps.

1. Right click on folder (Context menu appears.)
2. Select "Properties" ("[Folder Name] Properties" dialog appears.)
3. Click the "Security" tab.
4. Click "Advanced" button (Advanced Security Settings for [Folder Name] appears.)
5. Click "Owner" tab.
6. Click "Edit" button.
7. Click new owner's name in "Change owner to" box.
8. Click box to check "Replace owner on subcontainers and objects".
9. Click "Apply" button. ("Changing ownership of..." progress message appears.)
10. Click "Yes" to acknowledge "Windows Security" warning.
11. Click OK to close topmost "Advanced Security Settings" dialog.
12. Click "Permissions" tab (first tab) on current "Advanced Security Settings" dialog.
13. Click "Edit" button.
14. Click to select the Administrator in the "Permission Entries" box.
15. NOTE: If "Administrator" appears more than once, select the one that has "Subfolders and files only" in the "Apply To" column.
16. Click Edit button. ("Permission Entry for [Folder Name]" dialog appears.)
17. Click to check "Apply these permissions to objects..." option.
18. Click to check ALL the boxes in the "Allow" column.
19. Click "OK" (Dialog box closes, return to "Advance Security Settings" dialog.)
20. Click to check "Include inheritable permissions..." option.
21. Click to check "Replace all existing inheritable permissions..." option.
22. Click "Apply" button. ("Windows Security" confirmation dialog appears.)
23. Click "Yes" to confirm that you wish to continue.
24. Watch progress indicator on the "Windows Security: Setting security information..." dialog.
25. When all security information has been applied, the progress indicator dialog will close automatically.
26. You are now at the "Advanced Security Settings for [Folder Name]" dialog box... the "Permissions" tab should be visible.
27. Click "OK" and the dialog box closes, revealing the previous dialog box.
28. Click "OK" and the dialog box closes, revealing the "Properties" dialog box.
29. Click "OK" and the "Properties" dialog box closes.
30. Return to Windows Explorer and delete the folder.

Good Luck!!!

Write and let me know how it worked for you. (email removed)

Hi, I have the exact same problems, but I'm usuing XP, not Vista. I figured these directions would be at least pretty similar to the ones I need, but right after step 2 I am lost. I have no security tab, just three tabs named "General," "Sharing," and "Customize." There is an "Advanced" button in the General tab, but it does not have any options having to do with "Owner."

Any ideas? For some reason, this is the third time my computer has had to reboot in a year, and I would like to delete the old "Backup" folders.

Thanks for the help!!


Posts: 143   +0
erinp06... u need to start your own thread for a solution to your problem.
but nywys
i think the your problem is that you havent unchecked "simple sharing"
for this
go to "my computer>tools>folder options"
go to "view" tab
scroll to the bottom and uncheck "Use simple file sharing (Recommended)"
now you should get the "security" tab in the properties of any folder on a NTFS drive.
This worked great on my Gateway GM5664,thanks! I been trying since 4-08 to delete this backup 20gb folder,I cam here from Google search.Plus I joined just to say Thanks Allen2007

I just wanted to say thank you allen. i been trying for a year.. okay.. exxaggerating. LOL.. but a very long time

this was flawless.
Not open for further replies.