Can't delete video

By Doctor Gallop ยท 82 replies
Jan 18, 2017
Post New Reply
  1. sukhwant singh

    sukhwant singh TS Enthusiast Posts: 66   +10

    One more thing you can try. putting the file with same name in same directory to replace that file. and try deleting it.. I can remember old days when unable to delete autorun.info files from usb drive. so creating a new file with same name and replacing it always worked for me..
     
  2. KIPtheLIP

    KIPtheLIP TS Rookie

    Have you tried a file shredder program like spybot has? https://www.safer-networking.org/secure-shredder/

    Also as others have said maybe boot to a linux based program and bypass Windows. I can navigate my hard drive and delete files using BitDefender Search and Rescue boot CD.

    You might also try putting that hard drive into another computer, initializing it, browse to the file and try to delete it that way.
     
  3. Igrecman

    Igrecman TS Maniac Posts: 212   +123

    Just download any Ubuntu live CD or other Linux distro like Knoppix. Boot on the CD or DVD, and then you'll have no problem deleting or renaming any problematic files on any drive, even those protected by Windows.
    A similar problem happens to me sometimes when I unzip an archive that was made on a Mac.
     
  4. alabama man

    alabama man TS Maniac Posts: 369   +236

    Use linux. Bootable USB linux stick is easy to make and useful in loads of problem situations.
     
  5. Kibaruk

    Kibaruk TechSpot Paladin Posts: 3,286   +901

    Lol could you let him try one of the few tens of suggestions before keep on suggesting?? lol
     
    NightAngel79 likes this.
  6. Thannos

    Thannos TS Member Posts: 22   +7

    Restart your computer then try going back and deleting it. It may be temporarily in use by another background process or program and cannot delete until that ceases. This can happen from time to time without giving you an error stating so.
     
  7. Kibaruk

    Kibaruk TechSpot Paladin Posts: 3,286   +901

    He clearly states that the only way to stop the forever copy is by a restart, so you could always read first.
     
  8. OutlawCecil

    OutlawCecil TS Maniac Posts: 269   +141

    Some good recommendations from people here! Here's what I do, in order. Start with 1 and work your way down if it's not working.

    1. Try an unlocker such as this... http://www.majorgeeks.com/files/details/unlocker.html
    2. Try taking ownership, then delete it again. http://www.howtogeek.com/howto/wind...ership-to-explorer-right-click-menu-in-vista/
    3. Try a program that will restart your PC and delete the file before windows fully loads (before an application has a chance to lock it down) http://www.downloadcrew.com/article/31604-reboot_delete_file_ex
    4. Worse case scenario, make yourself a bootable CD/USB such as Hiren's or FalconFour, boot into Mini XP or something similar, browse your OS drive and delete the file. This will work 99.999% of the time.
     
    bigpygme1, bazz2004 and MaXtor like this.
  9. MaXtor

    MaXtor TS Booster Posts: 149   +39

    Follow OutlawCecil's advice. I've been using Unlocker for years and it works 98% of the time. If Unlocker fails, it will even offer to reboot Windows and delete before your desktop loads. Otherwise you'll likely need to access the harddrive from another OS (such as Mini XP as OutlawCecil mentioned).
     
    bazz2004, veLa and OutlawCecil like this.
  10. turismozilla

    turismozilla TS Addict Posts: 173   +55

    I would boot a Linux live system and delete the file Windows won't let me delete. Next Windows boot, Windows would be like... "Oh,man, what happened? I had a file here I was having so much fun with just a couple of minutes ago, where did it go?"
     
    MaXtor likes this.
  11. rvnwlfdroid

    rvnwlfdroid TS Booster Posts: 177   +41

    Like the last post, personally I always find it easiest to boot to a dos prompt (Hiren's boot cd or something similar) and delete those stubborn files from the dos prompt.
     
  12. Doctor Gallop

    Doctor Gallop TS Booster Topic Starter Posts: 227   +11

    Thank you, thank you thank you! I downloaded the 'Lockhunter' and it deleted it immediately! It went to the recycling bin and then I restarted my PC....and that "ghost" file was gone! Thank you again, aMerkuri
     
  13. David Belkin

    David Belkin TS Enthusiast Posts: 31   +26

    Hi, try to boot in safe mode and see if you can delete the file that way.
    If everything you try fails to get rid of the file, get a copy of Ubuntu, boot up with it and delete the file using Ubuntu.
     
  14. Wizwill

    Wizwill TS Enthusiast Posts: 60   +16

    1st set your user profile to Administrator status.
    2nd Find file (may be actually in Temp or Downloads)
    3rd If file is in a folder, open and delete contents, starting at deepest level, then delete empty file folder
    4th check folder attributes. May need to change to allow deletion.

    Set the browser to save all downloads to a designated folder to prevent this mess in the future
     
    Last edited: Jan 27, 2017
  15. fktech

    fktech TS Addict Posts: 223   +60

    Safe mode.
     
  16. Thannos

    Thannos TS Member Posts: 22   +7

    I'm sorry, but I didn't see that anywhere in the original question or in any of the responses leading up to my comment.
     
  17. p51d007

    p51d007 TS Evangelist Posts: 1,304   +648

    Sometimes I just say screw it, reboot the computer and whatever locked it, will let go, then it will delete.
     
  18. Kibaruk

    Kibaruk TechSpot Paladin Posts: 3,286   +901

    Yeah me neither, I was actually going to suggest the same until I read the rest of the thread =P it's funny though, everyone is saying the same thing over and over again "try unlocker" and then a post below "try unlocker" and then a new post appears "try unlocker" lol.
     
  19. Wincrazy

    Wincrazy TS Rookie

    Chrome is the nastiest free browser that exits. It runs many programs in the background that suck up system resources without telling you.

    That file is probably being used (therefore 'locked') by one of those background processes. Try stopping all of them. You'll need to Google how to do this.
     
  20. p51d007

    p51d007 TS Evangelist Posts: 1,304   +648

    And you don't have to be an a** either. I have a HUGE head cold and have been fighting an upper respiratory infection most of the week and missed that part.
     
  21. N.Taylor

    N.Taylor TS Rookie

    Reboot into safe mode..then try deleting or search the net for 'Take Ownership' script
     
  22. Kibaruk

    Kibaruk TechSpot Paladin Posts: 3,286   +901

    Oh my bad I'm so sorry, had no idea you had a HUGE head cold and have been fighting an upper respiratory infection!! My reply would've been so super totally different if that had been the case...
     
  23. jimmy.j

    jimmy.j TS Rookie

    I had this once and it took me many hours and days of research. Finally, I found a really smart poster who sent me to the command prompt ( as administrator ) and worked my way to the directory where I knew the name of the file OR something from the properties ( like date of file) from a rt click and I was able to del / delete the file. Good luck but I think you will solve the issue.
     
  24. kiwijohn

    kiwijohn TS Rookie

    I suppose this is a stupid question, but are you operating as administrator?
     
  25. AllanP

    AllanP TS Rookie

    Being a dual booter with Linux; I just boot to linux and delete it there. You can boot to a Linux USB and do the same.
     

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...