Can't run MsConfig from Troubleshooter. Auto Repair runs every boot

By Mugsy ยท 54 replies
Jan 18, 2018
Post New Reply
  1. What a pain. "Disk Cleanup" refused to remove my "Windows.old" folder, so I decided to do it manually by booting into Safe Mode with Command Prompt (via MsConfig, checking "Safe Boot" with "No GUI".)

    But when the computer reboots, it automatically attempts a repair on its own (fails) and boots into the Win10 Troubleshooter. All attempts to Repair via the Troubleshooter fail. Thanks to "Disk Cleanup", I no longer have any Restore Points.

    Now I can't run MsConfig to boot normally again (it keeps telling me I "don't have permission" to run it from the Troubleshooter Command Prompt".)

    I am NOT about to reinstall Windows just to fix this problem. Everything was working fine before I ran "Cleanup." Is there a way to run MsConfig as Admin from the Troubleshooter (or perhaps change the boot setting manually w/o it?)

    TIA
     
  2. jobeard

    jobeard TS Ambassador Posts: 11,355   +1,054

    I Believe, forcing three reboots will drop win/10 into Recovery.
    Choose Troubleshoot -> Advanced ->Startup.

    Can't do much there, but DO restart and use F4 to get the familiar Safe Mode.
     
  3. DavidBailey

    DavidBailey TS Maniac Posts: 380   +183

    Once booted into the 10 Troubleshooter you might want to try pressing Ctrl + Alt + Delete to see if any options appear.
    It may take a few seconds for any to appear.
    If any do appear, one should be Task Manager.

    From it, if it shows up, you might be able to run msconfig elevated.

    [​IMG]
    [​IMG]
    [​IMG]

    It might not work but is worth trying.
     
  4. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    Thanks for the replies.

    Jo: F4 & F8 don't seem to have any effect on the tablet. I was able to get into the BIOS from the Troubleshooter and disable "Quickboot" so I can get into the bios whenever I want, but there's nothing there to help me. :(

    David: Trying AltCtrlDel from the Troubleshooter does nothing. It's loading before Windows, so there is no Task Manager GUI to bring up. :(

    Is there a way to run Msconfig "as Admin" from the console? It won't let me unless I am. (Or maybe a way to make the same changes to the boot type that Msconfig makes, except by hand? I can run Regedit from the console.)
     
  5. jobeard

    jobeard TS Ambassador Posts: 11,355   +1,054

    Yes, on Win/10 F4 and 8 don't respond as previously known. That's why I posted the convoluted solution to get into Save Mode - - which is supported by MS.
     
  6. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    Thanks, but for some reason, even selecting "Safe Mode" from the Tshooters blue boot menu, the Troubleshooter continues to load attempting "Automatic Repair".
     
  7. jobeard

    jobeard TS Ambassador Posts: 11,355   +1,054

    HMM; let it repair then...
     
  8. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    If that worked, would I be here? :D
     
  9. jobeard

    jobeard TS Ambassador Posts: 11,355   +1,054

    You have so many adverse symptoms, it's not clear that was attempted - - it so please excuse me.
     
  10. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    Yeah. To recap:

    This all began as a MINOR INCONVENIENCE with Windows changing my background wallpaper too frequently (with every boot and after only 10 minutes despite being set higher.) I contacted MS tech support (my first mistake) and they told me to upgrade to the latest release (after general problem-solving failed.)

    Wanting to do this "right" and low on space on the tiny tablet, I ran "Disk Cleanup" first to get rid of "Windows.old" before attempting the upgrade (which would have created another "Windows.old".) It removed all my Restore Points but could not remove "Windows.old".

    I decided I would attempt to remove "Windows.old" from Safe Mode, so I ran MsConfig and set it to use "Safe Boot with no GUI" and rebooted (mistake #2.)

    When I rebooted, the computer started going straight into the Troubleshooter. Not realizing I'd never be able to get back into Windows, I proceeded to delete "Windows.old" by hand from the Troubleshooter Console window (rd /s /q "c:\Windows.old") which was successful.

    But when I exited to reboot, it again went straight into the Troubleshooter claiming it was attempting to Diagnose & Repair my PC. Checking my C: drive, I can verify all of my files are intact. Windows simply won't boot and I have no idea why. My "minor inconvenience" is now a "major headache". :(
     
  11. DavidBailey

    DavidBailey TS Maniac Posts: 380   +183

    Can you get into the bios ?
    I ask because if the boot menu is enabled it will have an F key assigned to press at start up to display the boot manager from which you can choose what to boot from.
    Then if you had a usb or dvd to boot from you might effect repairs that way.
    Just a thought. :)

    EDIT---Added picture---
    screenshot_23.
     
    Last edited: Jan 19, 2018
  12. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    I was able to alter the boot delay so it gives me the option of entering the BIOS, but neither F4 nor F8 have any effect (pressed repeatedly before the Win10 logo inevitably appears.)

    Regardless, the Troubleshooter has an option to boot from a USB drive, but I don't have a repair utility for Win10 (only Win7). Actually, I have a free Win10 repair disk iso that I put on a flash drive, but all it did was load an early version of the Win10 Troubleshooter. :)
     
  13. DavidBailey

    DavidBailey TS Maniac Posts: 380   +183

    Did some research !
    Found a Power Shell cmd that should do the trick.

    powershell -Command "Start-Process cmd -Verb RunAs"

    You say you can get a cmd prompt but not an elevated cmd prompt ?
    Type the above cmd into the cmd window & press Enter.
    Type it correctly or it won't work.
    Wait a while & an Administrator Command Prompt should appear.
    See picture---

    screenshot_24.

    Good luck. :)
     
  14. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    Big thanks on the research, but the Command Prompt in the Troubleshooter already says "Administrator" on the titlebar. but when I try to run Msconfig, it still says I need Admin permission (???). And the Troubleshooter reports "powershell is not a recognized command".

    Frustrated, I decided to simply attempt a "Reset this PC". Big surprise. That doesn't work either ("There was a problem. No changes made.")

    So I've downloaded a fresh copy of the Win10 iso from MS and will attempt to use it to reinstall Windows. I'm concerned though I could lose my registration (this tablet didn't include a Win10 "serial" or "product activation" number with it, so I have no idea what it is if I need it.

    Hopefully, it will be able to do a repair w/o it. What a pain!
     
    DavidBailey likes this.
  15. DavidBailey

    DavidBailey TS Maniac Posts: 380   +183

    I guess the cmd was meant for a computer in good working order.
    Sorry it didn't help. :(
     
  16. jobeard

    jobeard TS Ambassador Posts: 11,355   +1,054

    I've explained previously that Win/10 doesn't support F4 or F8 as was true in prior systems AND tried to lead you to the round about means to still get to Save Mode. I can only lead you to the water...
     
  17. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    Hey Jo,

    I am aware F4/F8 don't work with a Win10 machine. If you note my reply at 11:52 yesterday, attempting to launch "Safe Mode" doesn't work. It just takes me back to the Troubleshooter. :(

    But please note in your first reply above, you wrote: "but DO restart and use F4 to get the familiar Safe Mode."

    That doesn't sound like someone saying "F4 doesn't work." :eek:
     
  18. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    [LOL] It WAS in good working order before this nightmare started!

    Who knew "Disk Cleanup" was so dangerous?

    I just attempted to reinstall Windows 10 from an thumbdrive with the Win10 cd on it (correct version) and that too refused to install!

    My only other option would be to totally wipe the HD and reinstall from scratch, but that would void the warranty (assuming it's hasn't been a year yet), so back to the store it goes! :(
     
  19. jobeard

    jobeard TS Ambassador Posts: 11,355   +1,054

    CONTEXT Bro, Context.
    F8 worked at boot time in other systems. Win/10 drives you thru three restarts, a troubleshooting advance, then restart
    B E F O R E f4 & f8 are usable again. Really convoluted. They should have stuck with F8 at boot imo.
     
  20. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    You don't need to go through all that just to launch Safe Mode. The Troubleshooter offers "Boot Options", providing you with a boot menu (now in blue) upon restart that includes "4. Safe Mode." And the Troubleshooter is the one thing I'm not having trouble accessing. :(
     
  21. DavidBailey

    DavidBailey TS Maniac Posts: 380   +183

    Confusing,
    A usb with a CD on it ?

    This post---

    https://www.techspot.com/community/...fter-factory-reset.243219/page-2#post-1656152

    is on page 2 of a thread.
    You might want to start at page 1 & read the whole thread.
    Since you have a command prompt you could extract the W10 iso to a usb drive & use the cmd prompt to open the setup.exe file to install W10.
     
    holdum323 likes this.
  22. holdum323

    holdum323 TS Guru Posts: 1,244   +382

  23. holdum323

    holdum323 TS Guru Posts: 1,244   +382

  24. holdum323

    holdum323 TS Guru Posts: 1,244   +382

  25. Mugsy

    Mugsy TS Guru Topic Starter Posts: 445   +32

    Win10 ISO copied to a bootable flash drive.
     
    DavidBailey likes this.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...