1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

CMOS/Checksum error continues after battery replacement

By somnamblst ยท 17 replies
Mar 9, 2003
  1. I am readying an old PC I built (686 Cyrix 200 Mhz) to give to a brother who has never had or tried a computer but is expressing some curiosity. Long story short I discovered several issues when I powered up this PC to ready it for a car ride to Florida that is leaving soon.
    1. CMOS battery/Checksum error, removed old 2032 battery
    2. I also removed a non functioning primary slave Seagate HD
    3. Installed new battery
    4. On reboot HD was not detected, auto and user defined HD did not work, system kept reverting to 9/1/1996 date. CMOS/Checksum errors continue despite new battery. Also moved jumper on HD to reflect single drive status.
    5. Swapped power supply from CD to primary master HD (Western Digital) resulting in HD being detected. Used a different power supply cable for CD resulting in CD but no HD. Removed jumper from HD completely and tried a 3rd source for power to CD which worked, HD and CD detected, continued CMOS/Checksum errors mean Plug and Play enabling in CMOS is not being retained and must be enabled through setup to continue booting.

    AND with the cover off and the tight fit of swapping things in a desktop I also noticed that the CPU fan is not spinning. I am not sure when this happened, I was feeling heat on my hand all along as I manipulated cables. Good thing the cover is off. This fan is attached to the power cable I have attached to HD which meanes that it used to be piggybacking off CD drive not HD. My motherboard manual (FIC PA-2006) indicates that the CPU fan can be powered at a 3 pin connector on board to the left of CPU.

    CMOS/Checksum: Any ideas on how to resolve this issue? I can't send a newbie a PC that needs CMOS tweaking everytime it boots up. My bios is Award.


  2. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    Perhaps the CMOS jumper is in the incorrect position, making poor contact, or there is no CMOS jumper at all.

    You can probably get a jumper diagram online, by searching the model number. If you have that manual, then that will probably do as well. Just look for where it should be and then double check to make sure it is in the right position.

    I know newer computers won't even turn on with CMOS jumper in the wrong place, but older systems seem to differ.

    Another possible explanation would be circuitry damage, in which case you may have to buy a new motherboard. Somehow that battery is not giving the CMOS power.

    And a far-fetched third explanation would be it was not "year-2000" compatible. LoL. Maybe it freaks out on the date... Just random speculation though.
  3. Nic

    Nic TechSpot Paladin Posts: 1,519

    Sounds quite confusing all the things you tried.:confused:

    :cool: Checklist ...

    1. Is the replacement battery *fresh* (3 volts for CR2032)?
    2. Reset CMOS (via jumper).
    3. Go through all bios settings and check they are suitable.
    a) Try selecting LOAD BIOS DEFAULTS setting first.
    b) PnP Configuration Setup\Reset Configuration Data
    - Set this to 'Enabled'.
    4. Try reseating all components and connections.

    If all else fails then its perhaps the mainboard could have been damaged by 'static' if adequate precausions were'nt taken while working on it.:blush:
  4. somnamblst

    somnamblst TS Rookie Topic Starter

    The motherboard is a FIC PA-2006. The PC was last in use in Dec., 02 so I don't think it is a Y2k issue. When I was rushing to get this PC ready for it's car trip to FL one of the early things I did when faced with a no HD detected error was to reset bios and cmos to default setings in CMOS. I do have the motherboard manual but as of yet have spotted no refererence to a CMOS jumper or CMOS reset function but the diagram has very small type and is hard to read so maybe I just haven't spotted it. The 2032 battery is a Duracell from Walgreen's with a best if used by 2007 date, but that doesn't necessarily mean that it isn't defective. I did have to bend the battery clip up to extract the old battery, but I bent it back down and I do have positive up as indicated on the battery clip holder. The main problem on bootup with continued CMOS/Checksum error is that it hangs on Plug and Play detection for a sound card and I have to enter CMOS and reenable Plug and Play OS since the CMOS battery is not retaining this info. When I reset bios to default I think I may have overwritten a bios update that I have a vague recollection of. I do remember it was something I at least checked into as I remembered that Phoenix took over Award Bios. I have bought myself some more time though as I am sending the monitor to FL via car and will ship the PC later. I still have to replace that Cyrix CPU fan also.

  5. somnamblst

    somnamblst TS Rookie Topic Starter

    PS: I actually think the CPU fan not spinning is a power cable problem and since it is an available much easier to reach option I think I would prefer to power the fan from the 3 pin connector on the MB.

  6. Nic

    Nic TechSpot Paladin Posts: 1,519

    somnamblst ...
    The main problem on bootup with continued CMOS/Checksum
    error is that it hangs on Plug and Play detection for a sound card
    and I have to enter CMOS and reenable Plug and Play OS since
    the CMOS battery is not retaining this info. When I reset bios to
    default I think I may have overwritten a bios update that I have a
    vague recollection of. I do remember it was something I at least
    checked into as I remembered that Phoenix took over Award Bios.

    Firstly, updating your bios has nothing to do with bios settings.:confused:
    Bios settings are simply how you configure the bios for your system.

    Secondly, I'd like to say "OOPS" :blush: - When you say you updated your bios, I hope that you don't mean that you installed a newer bios for your mainboard. The reason I say this is that I have just checked the FIC website and there are *NO* bios updates available for your mainboard.

    You must remember that you cannot simply update an Award bios with another Award bios. The bios is *SPECIFIC* to your mainboard model and cannot be used with any other mainboard.

    Did your PC work correctly after the bios update?

    If not, then it looks like you have found the problem. This would certainly explain the CMOS checksum error.

    FIC PA-2006 Bios Updates - There are NONE!

    Actually, I'm just kidding (maybe). :grinthumb
    Although the FIC website doesn't show any bios updates as being available, if you examine their ftp you'll find all available bios for their mainboards. You might want to go through it and check your mainboard to see what version you require. Good Luck!

    Here's the link ...
    FIC PA-2006 Mainboard Bios

    PS: Sorry if I sound a little sarcastic (seriously), but I've got a dose of the *giggles* today and I currently can't control myself.:D :D :D

    Also, if you really did install an incorrect bios, then you've been pretty lucky, as it seems that there is enough in common with your last bios that your machine will still boot (kind of). You may even be able to correct the problem and reinstall the original bios, which would be good news indeed, as normally an incorrect bios would render most machines completely inoperative and only fit for the waste bin.
  7. somnamblst

    somnamblst TS Rookie Topic Starter

    Quite all right. IF I did update the bios it would have been so long ago that I don't remember. I mainly remember checking into it, as I do remember being aware that Phoenix has acquired Award. Hey I know just enough to get myself in trouble so bear with me.

    My bios is: (I wrote this down in case someone asked) Award Mod Bios v4.51PG Award Plug and Play Bios extension v1.0A1996 617j90M

    On the FIC FTP server I see a zip file for that bios, would reloading my bios possibly help if it is somehow corrupt?

    Susan - who even though she has built two PCS in her life is really just a bumbler who keeps trying stuff until something works and by then she doesn't remember which thing it was that resolved the issue.
  8. somnamblst

    somnamblst TS Rookie Topic Starter

    And since it would probably be better to send a used computer to a new home that does not have recoverable deleted files, why don't I just use that app I downloaded kill something and then reinstall Win 98 on the off chance that my CMOS problem would be resolved. Hey I said I was a bumbler who trys lots of stuff.

  9. Nic

    Nic TechSpot Paladin Posts: 1,519

    That bios is pretty old so you might want to take a look in the 'y2k' subdirectory for a 'year 2000' compliant version. According to the readme.txt file the version you need (if your mainboard has usb) is '6.2000J90M.bin' (I am guessing that the 'M' in the filename is for usb - just like your current bios).

    Seeing as you do appear to have a correct bios, I still can't understand why you get a CMOS error. You can try installing the updated bios and with any luck you'll be back in business again.:D

    Oh, and theres nothing wrong with being a 'bumbler' as you'll never learn anything if your afraid to try - trust me. ;) Anyways, if you keep trying then one day you might just get lucky.:D

    If you need any more help just let us know, and be sure tell us how you get on.:cool:

    Actually, theres an even newer version '6201J90M.BIN' in
    the int13 subdirectory that you may want to try.

    Note: Reinstalling Win98 will have no effect on your bios error as the bios is part of the 'hardware' and the error occurs long before any OS is loaded.
  10. Nodsu

    Nodsu TS Rookie Posts: 5,452   +6

    I'm pretty scared to say this, but with all the power cable trouble with the HDs and fans, it just might be a PSU problem..
  11. StormBringer

    StormBringer TS Maniac Posts: 2,218

    I'm having trouble making heads or tails of everything that has been tried and where the actual problem is, but it sounds like part of the problem may be a faulty CMOS battery holder, or a bad connection on the battery holder.

    Another note: I believe it was Award who bought Pheonix, not the other way around.
  12. somnamblst

    somnamblst TS Rookie Topic Starter

    By PSU do you mean Power Supply? I put a new power supply in a year ago when the fan got so obnoxously loud I could not stand it anymore. So the power supply is actually the newest thing.

  13. somnamblst

    somnamblst TS Rookie Topic Starter

    I wondered about that myself. I was unable to slide that bad 2032 battery out sideways so I bent the clip holding it in contact with my fingernail (no I did not use a screw driver) I bent it back down of course when I installed the new one. I did have to rub the old battery in order to read the 2032. It wasn't corroded but it had like a foggy look to it. If there is a problem with that aspect I guess I could try an external CMOS battery as I assume CMOS Battey holders are soldered?

    Before I go that route I am going to:

    1. Try a second 2032 battery and if that doesn't work:
    2. I am going to try a new bios or reload the current. My PA-2006 MB has connectors reserved for future upgrade for linking with peripherals that support USB, connector pinheads are not installed on this board currently.


    That battery does feel loose. I just booted using a pencil eraser to push down on the battery clip but it did not help. looking for coorosion on contacts next...

    It looks a little dusty in the area that the underside (negative) side of the battery contacts with. I'm going to try to blow it off.
  14. Nic

    Nic TechSpot Paladin Posts: 1,519

    You'll need a new bios to fix your date problem (y2k bug).:D
  15. somnamblst

    somnamblst TS Rookie Topic Starter

    OK, the latest. Removing the new 2032 CMOS battery, brushing away a small amount of dust and pushing the battery clip down more resulted in the CMOS/Checksum error going away for awhile. After Scandisk ran after successful no CMOS error bootup, I got a:

    While initializing device IOS: ERROR Real mode system memory allocation failed

    and my PC started in Safe Mode, yada, yada, yada.

    Rebooted a few more times and CMOS/Checksum error is back but system memory allocation error did not.

    However I did fix the fan problem, it wasn't conneted to any power supply (baby AT cases are very difficult to see what's what without a flashlight) so I am leaving PC on for 24 hrs to see if this helps. Tis PC used to be on all the time and had been turned off since early Dec. so maybe this will resolve my issues. Will keep youposted on additional progress.


  16. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    Progress is good. I should have thought of cleaning the contact. :)
  17. somnamblst

    somnamblst TS Rookie Topic Starter


    Our system administrator suggested I try cleaning the contact on the battery holder with rubbing alcohol and a que tip. The battery holding clip has a + sign on it meaning positive side faces up. I don't suppose they would have screwed that up and got it backwards. I'm not sure why but I was having display problems also, it kept reverting to 16 colors even though Control Panel settings/System claimed the driver was loaded. I installed the hardware specific driver from Win98 and that took care of that.

    Since it is very hard to get the battery out and the metal clip that exerts pressure on the battery keeping it in contact with the battery holder almost has to be tugged upward as you are removing a battery I can't help thinking that the battery is not getting adequate contact. I have not yet determined whether that battery holder is attached to the MB with solder or if it is has a screw. Maybe I could replace the battery holder.

  18. StormBringer

    StormBringer TS Maniac Posts: 2,218

    The battery holder is soldered to the mobo. The battery holder can be replaced. If you can replace it yourself, or know someone who will not charge you to replace it, you'll be ok. If you would have to pay someone to replace it, then it may not be cost effective.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...