1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Compaq 7400 lost DIAGS

By MaryRedmond ยท 7 replies
Apr 27, 2009
  1. Last posts I saw are about 2005 - files no longer available on HP site to download DIAGS creation file.

    Laptop: Armada 7400-6266-T-4000-D-0-1 - secondhand- function keys didn't do anything when I bought it. 4 gb HDD (IBM TravelStar). 64mb RAM, swappable floppy and CD-ROM

    OS - W2Kpro

    Event- virus /spyware infection about 7 months ago - virus removed by computer repair tech guy .... then ....performance SLOW - so HDD formatted and OS re-installed.

    The problem - running out of disk space and can't do a decent defrag. Asked tech guy to upgrade to 10 or 20 or 30 gb HDD. He cloned the original HDD to the new one - it would not boot. He has tried everything he can think of and has given up.

    I had downloaded System ROMpaq - he did not find it bootable. I tried to create a boot disk - I could not seem to make a bootable disk - with the old DOS boot files, got a message about NTLDR not found ....

    WIndows sees 2 gb, not 4. Administrator options in Control Panel shows primary partition is 2 gb, rest is "Unallocated" - no DIAGS partition.

    I have read all of the posts I can find. Tried to find the DIAGS file on HP and got a no longer available message.

    So .. the old HDD boots fine but without being able to install the BIOS on another HDD, can't upgrade AND then boot the laptop.

    If I could make a boot diakette that worked, maybe we could find a way to install the DIAGS partition and BIOS on the HDD ... if the files are still available.

    Any help would be most welcome ... baby steps, please ...

  2. lamo

    lamo TS Rookie

  3. MaryRedmond

    MaryRedmond TS Rookie Topic Starter

    Thanks -

    The file is too big for a diskette so downloaded to a small USB drive - don't know if it will do the job but I appreciate your posting the link. I will let you know ...

  4. lamo

    lamo TS Rookie

    wait a minute, you have direct instructions with this file, which can be read in link, i've provided. this laptop won't boot from usb drive(lack of USB legacy support).
  5. MaryRedmond

    MaryRedmond TS Rookie Topic Starter

    You are right - totally missed that.

  6. MaryRedmond

    MaryRedmond TS Rookie Topic Starter

    Thanks, lamo and update ...

    Ok, so I have the setup diskette. When I select install setup, I get the "no diagnostics partition, run PC diagnostics" message. When I searched for restore diagnostics partition, the links suggested had expired. There are HP sites for Compaq diagnostics for Windows but the instructions - not so clear to me.

    One post suggested I needed version 10.40 and I can't find it.

    I do have a Win 95 boot floppy with the DOS utilities including fdisk and for that matter, I have old installation diskettes for 3.1 and DOS.

    Any idea what might be my next best step ...?



    Update - posted 2 May 2009 at 5:31 Eastern Standard time

    I was able to find sp12906 and dozens of earlier and later sps on a Compaq archive site - Too new - I can't post the link yet - I will let you know if it works.


    May 3, 12:49

    I am still stuck - used SP12906 to create a diagnostics diskette - it wouldnt boot - booted with Win 95 floppy - the diags disk gave me an error message when I tried to create diags partition - "not booted with diagnostics disk" and I couldn't proceed. I downloaded the SP to create the version 10.40 diskette. That one will boot and setup can see the 10 gb drive but when I ask the diagnostics disk to create the partition, it says that there is insufficient room on the hard drive. Fdisk shows no partitions - I tried formatting the presumably blank HDD - I still get the message that there is insufficient space ...
  7. lamo

    lamo TS Rookie

    you need to erase hdd to install BIOS partition. search again carefully at HP web site. i can't believe, that they erased old support files for this laptop.
    actually, i did these procedures long time ago, and i didn't save these files :(
  8. MaryRedmond

    MaryRedmond TS Rookie Topic Starter

    Thanks, Iamo -

    I think I may be making a little progress. The old files are available from ftp archive sites under HP and Compaq and the 10.40 version of the diags file seems to work - at least it boots the laptop.

    The HDD I am trying to install is, I think, previously used and, I am guessing, from what I can see in searching all the terms I can think of, that it may have a hidden partition - IBM seems to have used that in, at least, some laptops. Hitachi has a download of Ftool available but I may try Hiren's boot CD tools first - will give it a try on the weekend. I am guessing that removing the hidden partition, if it exists, may resolve the problem. It would probably be occupying at least part of the first 2 gb space that the diags partition wants.


    May 15, 2009 -

    Problem solved ... removed the hidden partition with the partition magic tool on Hiren CD ..used the 10.39 version of the diags disk and the setup disk and .... I have the BIOS F10 ...! Yes! Thanks for the support, lamo!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...