Could not repair windows installation

By Mabu
Jul 11, 2009
  1. Summary: I am trying to repair a Windows XP installation, but the repair process hangs just after the first reboot the one following the text-mode file copy.

    Detalis now.
    I'm trying to follow acrobat's "state-of-the-art" post format.

    First, my PC specs:
    Motherboard ASUSTeK P5B, with AMI BIOS Rev. 1604
    Intel Core 2 Duo E6420 (Stock speeds)
    ASUSTeK GeForce 6200 TurboCache PCI Express
    2x 2 GB Kingston DDR2 PC2-5300 4-4-4-12
    1x 320 GB Western Digital Sata drive WDC WD3200JS-00PDB0

    1) Everything is at its stock speed. Nothing has ever been overclocked.
    2) Entire PC is two years.

    Problem (aka The full, long and sad story):
    My fully-functional-and-updated WinXP-SP3 installation was working fine.
    Probably I took a bad virus, indeed all of this started with Kaspersky Internet Security 2009 (KIS) not starting at all: not at windows startup and not if manually "launched".
    I found a strange (=strange name, unusual file location, unusual file position in process-tree displayed by ProcessExplorer) process running in memory, uploaded it to Kaspersky Online Scan Service and it resulted infected by a trojan.
    I restarted in safe mode and deleted the culprit.
    Then I uninstalled and reinstalled KIS from scratch but it still didnt work.
    After a week trying to get this fixed with Kaspersky support, something new happened: everytime I logged in, I received a "Generic Host Process for Win32 Service" crash.
    Unfortunately the service crashing was RPC Service, so a 60 seconds countdown was the only time I had to troubleshoot before rebooting.
    This happened both in "normal" and in "safe mode".
    I still wasn't alarmed, so I didn't take detailed notes about error codes and stuff.
    I just guessed some system file was corrupt and tried to repair the Windows installation from WinXP SP2 CD (the only setup CD I have).
    The repair method I used is the following:
    1.boot off WinXP Setup CD
    2.choose to install, not to repair, ad first choice
    3.when it searches for previous WinXP installations, it detected my C:\WINDOWS install I decidere to "R"-"Repair"
    The text-mode file copy completed flawlessly.
    After the first reboot, the setup GUI is shown and here I am stuck.
    It says "39 min to completion" forever.
    System doesn't properly "hang", because scroll bar animations and commercial texts (you know... "more power"... eheh) are changing.
    But installation doesn't go further.

    What I have tried
    Googling around I found this kind of errors can be due to a WIDE range of causes: from popped capacitors, to broken RAM, to dust, to corrupt software.
    So I tried the following:
    1.checked for popped capacitors: MOBO looks OK
    2.dissipators and fans are quite clean, however I cleaned them
    3.unplugged and plugged PCI-Express VGA (MOBO doesn't have integrated video card)
    4.removed 1 ram stick, then the other, then swapped them.

    Not being able to fix the installation, I tried to do a fresh new install on D:\ partition (it was luckily empty).
    The idea was to try to confirm or exclude a software error due to the existing installation I was trying to repair.
    But I got stuck againg, in the same point of the repair process.

    I was sure it was the RAM, so I ran a 9-hrs overnight memtest while both sticks were installed and I got 0 (!!) errors.

    So I decided to build a new WinXP SP3 CD and I did it this way:
    1.downloaded SP3 from microsoft all original drivers CD that shipped with my hardware my previous WinXP SP2 CD.
    4.using nLite and the 3 preceding items I built a new WinXP SP3 CD with my hardware drivers already on it.

    Using this CD I was able to complete the new fresh install on D:\

    So I thouht that was going to let me repair also my original C:\ install, but it still hangs in the same point: after first reboot.

    So now I am here posting for help, attaching setup logs produced by the repair attempts done with this home-built WinXP SP3 + hardware drivers CD.

    Only other thing I can mention
    WinXP-based boot CDs, such as UBCD4WIN 3.5, run flawlessly.

    Reported by SIW:
    SYSTIN: 36°C
    CPUTIN: 34°C
    AUXTIN: 119°C (what is this? anyone knows?)

    CPU FAN: 2900 rpm

    Intel Core 2 Duo E6420, Core #0: 27°C
    Hard Disk: 34°C

    So what help do I need:
    In the final analysis I'd like to repair my existing WinXP C:\ Installation, first because I want to understand what happened and second because, even if I have now a new and working D:\ install, I'd like to avoid reinstalling everything.
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    I wonder - could it be a hard-disk bad spot ? You do not mention a full HDD read/write test, and I think you should at least eliminate that possibility.

    Despite that, it is still likely to be an infection. Some are next to impossible to remove, because they actually reside in the boot sector and although you squash their manifestation in memory and HDD, they are not dead, and it is impossible to boot live or safe mode without it being present in memory.

    I had one like that at work, and was able to get rid of it because sufficient of what I could see happenening made it possible to identify the description of the virus, from which web-sites were able to guide me to likely names of files and locations. I was lucky. In most such cases, the only remedy is full wipe-and-install, often to the partition level.

    That is why I am suggesting a full HDD test (from UBCD), so you can be pretty sure both it is not the cause of the trouble, and in case of need, a reinstall is not going to hit a bad spot on the disk and stall.

    Oh, and if the HDD test succeeds, and you can boot to safe mode, it might just be worth running sfc for which you will need a slipstreamed SP3 CD which you have - not many people do. As per usual, system file checker is a fine idea, abysmally implemented by MS.
  3. Mabu

    Mabu TS Rookie Topic Starter

    "In most such cases, the only remedy is full wipe-and-install, often to the partition level."

    Yeah, I was not lucky :(

    That's what I had to do.

    Anyway... thx for your help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...