1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Could not start the windows firewall/internet

By rp748 ยท 50 replies
Oct 23, 2004
  1. Old Tech

    Old Tech TS Rookie

    Thanks rp748 your information did the trick on the Laptop I was repairing
    and all is A OK now. Us Old guys can learn a lot from you young fellas.
    thanks again to all for your great assistance.
  2. DraGKK

    DraGKK TS Rookie

    Same problem here.

    "Error 1075: the dependency service does not exist or has been marked for deletion"

    i tried reseting the socket and also setting the service to automatic... iT stills can't start... please help... thankzalot
  3. mrdyer

    mrdyer TS Rookie

    Enable Windows Firewall

    Click 'start'
    click 'run'
    type 'regedit' enter
    click 'edit, find'
    type "\SystemRoot\C:\WINDOWS\System32\svchost.exe -k netsvcs"
    click 'find next'

    when you find it right click then modify

    change the value to "C:\WINDOWS\System32\svchost.exe -k netsvcs"

    hit F3

    change the value to "C:\WINDOWS\System32\svchost.exe -k netsvcs"

    now start the firewall from control panel.
  4. DraGKK

    DraGKK TS Rookie

    Thanks for the reply dude, i appreciate it... However when i type regedit in the run, some thing just pop up and immediately closes it.. Sadly... HaHaz...
  5. ratman

    ratman TS Rookie


    New to the forum and have read the entire thread. I have the same "Windows cannot start the Windows Firewall/Internet Connection Sharing (ICS) service" message (though no subsequent Error # messages).

    I have tried nearly every solution listed so far, but to no avail. My case seems different that those listed in that it just happened after years of working on the network/internet with no problems, i.e. this is not a new SP2 installation. I actually don't use the Windows Firewall -- we use PC-cillin for antivirus and firewall protection -- but have tried to access Windows Firewall because of my initial problem.

    My issue is that I can no longer connect to our internal network. I have run every diagnostic possible through XP and have uninstalled a variety of softwares which might influence the network connection, again to no avail. The odd part is that I CAN connect to the internet which is only available through the network.

    Can anybody help?
  6. N3051M

    N3051M TS Evangelist Posts: 2,094

    You mean other pcs in your network right?
    check your IP addresses match up (except for the machine number at the end eg. 192.168.0.x)
    check that the pc is on the same workgroup?
  7. ratman

    ratman TS Rookie

    Correct, I mean other pc's and our server (used for data storage only), all of which are on the network.

    Everything on my pc is set up correctly for the network -- I reran the Network Wizard just to be sure.

    The problem started when I downloaded new spyware (ewido). First, it slowed my boot cycle, from login to usable Windows desktop, to almost 5 minutes. I removed it and PC-cillin and ran most of the fixes found on this and Microsoft's websites. Since then, I've reinstalled PC-cillin and am getting intermittent network connection. This morning when I logged in, it worked. Then, after a Microsoft update, I rebooted and the network "could not be found". I rebooted again, and now it seems to be working -- but will it work the next time I reboot ..........
  8. N3051M

    N3051M TS Evangelist Posts: 2,094

    so you've previously have a spyware problem before?
    I suggest going through these instructions first to eliminate the possibility of any hidden nasties. Be sure to rename the Hijackthis program to HiJackThis1991.exe and open a new thread in the Security and Web section.

    Have you tried to use some registry cleaner such as CCleaner?
    are your IP addresses static or automatic? If its auto then set it to static...
  9. ratman

    ratman TS Rookie

    Thanks for the reply.

    I've done all this cleanup already on another forum (I found techspot when I googled the firewall problem). Unfortunately, the HijackThis log revealed nothing of relevance.

    What will changing my IP address status do?

    And, by the way, this morning, no network connection again after it working all day yesterday. When I try to run the Network Wizard, it errors out.
  10. N3051M

    N3051M TS Evangelist Posts: 2,094

    Well from what you're describing (restarting the pc then it picked up the network etc) it may sound like the network isn't resolving, so it may be using a different address (just guessing here)

    Can you write down what error it is? all info could be relevant..
    Download CCleaner (google for it) and run it. It would help a tiny bit if at all..

    If you still get problems, then try reinstalling your NIC:
    Go to device manager and find your network adaptor tree.
    -expand it and click on the one you use to connect to the network.
    -uninstall/remove it.
    -reboot the pc and let windows reinstall it or if you've downloaded updated ones from the web for your NIC then point it to those drivers.
  11. ratman

    ratman TS Rookie

    I ran CClean early on with this problem (going on now for almost 2 weeks) and I run PC Confidential nearly every day.

    After my post earlier this morning, my connection "magically" appeared, meaning I made no changes to the system. Nonetheless, I reinstalled the NIC and changed the IP status as you recommended.

    As far as the error messages go, it's pretty much just "cannot find network" (or something similar) whenever I click on a networked drive in Explorer .............
  12. N3051M

    N3051M TS Evangelist Posts: 2,094

    sorry for taking so long replying (lost the link :D) but did you get it fixed?
  13. ratman

    ratman TS Rookie

    Thanks for getting back with me. No, it is not fixed. My network connection is hit or miss -- some days it connects but others, like this morning, it doesn't until I reboot. And even then it's not guaranteed and I see no pattern as to when it will or won't connect.

    I am getting the following error message pretty regularly now and assume it is part (or all) of the problem:

    "Generic Host Process for Win32 Services has encountered a problem and needs to close"

    I have tried all remedies as suggested by Microsoft KB to no avail. Any other suggestions?

    OK, so today is the worst day so far. I have rebooted several times and still cannot connect to the network.

    One other symptom that happens occasionally is that the Windows Security Center icon comes up warning me that I don't have antivirus and firewall protection running -- which, of course, I do. I've checked the PC-cillin settings and all appears normal.

    One more wrinkle -- I uninstalled my NIC, rebooted and tried to run the Network Wizard, but it errored out. This has never happened before when running the wizard ...............
  14. N3051M

    N3051M TS Evangelist Posts: 2,094

    maybe its starting to go out.. try using a PCI NIC adaptor..

    EDIT: hmm.. i just thought of something.. have you tried to boot in safe mode with networking option? that or using a linux live cd can help you determine if it truly is a hardware problem..

    Oh yeh.. there's an edit button.. use it :)

    I did :p
  15. ratman

    ratman TS Rookie

    OK, two items:

    1) I am able to access the shared files on my computer through other workstations on the network. So I can see, but not out .....

    2) Per your suggestion, I started my computer in Safe mode with networking and voila! I could access the network.

    So what does this mean?
  16. N3051M

    N3051M TS Evangelist Posts: 2,094

    If it works in safe mode (reboot and see if its good again, since in normal you said its on/off etc) then it would be software fault or driver faults..

    Drivers, i can't remember if you've tried updating them or not.. but yeh, its either update or if this started happening when you've updated, rolling back to the previous version..

    Software, if its a startup program/process,
    Start>Run>msconfig>Diagnostic Startup>[OK]
    Reboot and see if its better now, and reboot again etc to check for consistancy because of your problem..
    If its better, then go back to msconfig and select selective startup and tick one of the boxes that are currently unticked, reboot etc. untill you run into the problem then go to the relevant tab and enable one by one untill you find the cause. There maybe multiple causes so may need to go through it twice etc.

    Its long and arduous but that'll tell you exaclty whats buggin your system up..
  17. ratman

    ratman TS Rookie

    After successfully accessing the network by booting in Safe mode, I rebooted normally and continued to encounter the same problem. What used to be hit or miss in making the connection is now at a 100% failure rate. Of the 10 or so boots/reboots in the past 2 days, I have not been able to access the network any time. Interestingly, even though I cannot connect to my networked drives, I don't get the icon and message stating that fact.

    In Device Manager I checked the driver for the NIC and it said I have the most updated driver. I don't recall ever updating the driver so I don't know if I can "roll back" to a previous version.

    I ran the Diagnostic Startup to no avail. I did, however, get the "Could not connect to all network drives" message and icon. Because nothing worked, I had to reset the startup to Normal, I then rebooted, then changed back to Selective Startup and I'm back to where I was before.

    Any other suggestions? By the way, I'm still getting the "Generic Host Process" error message .............

    Late Friday update -- decided to check my LAN properties and when I clicked on the Advanced tab I got the following:
    "Windows cannot display the properties of this connection. The WMI information might be corrupted. To correct this, use System Restore." Unfortunately, I cannot run System Restore because at some point while troubleshooting this, I turned it off and (d'oh!) never turned it back on.
  18. N3051M

    N3051M TS Evangelist Posts: 2,094

    well since we can narrow it down to a windows problem there is one trump card i can think of.. but like any system wide change, i suggest a backup in order, as per norm.

    If you use Mapped Network drives, try disabling or getting rid of it for now and see if it stabelise..

    Theres a few network utility fixers around, i just can't remember the name (maybe winsock or LSP something..) so you can try google for em and see if they do anything..

    Start>Run>cmd >sfc /scannow (note the space between sfc and /). You will need your windows XP disc for this. Its like chkdisk but scans the windows files to see if anythings corrupted or what and if it finds something will try to replace it with the original from the CD.

    Thats short of a windows repair, last option is your reformat x_x
  19. ratman

    ratman TS Rookie

    Well, I'm guessing I've done all I can do.

    Per your suggestion, I ran a couple of network utility fixers (had actually run winsock before) to no effect. I then ran the sfc /scannow command with the xp disk in place, but nothing came up (i.e. there were no prompts to replace any files).

    So I'm thinkin' it's time to reinstall xp?
  20. N3051M

    N3051M TS Evangelist Posts: 2,094

    Well i'm certainly out of ideas.. unless someone else got any the floors open..

    safe mode works that means either driver fault, software, registry or other stuff that happens during normal mode.. and we've pretty much covered all of the things i can think off..

    Backup and reinstall i think will save you some time.. install all your drivers first then check to see if its stable.. then software one by one etc. Maybe you can find out what it is causing it preemptivly so you can make a workaround before its too late...
  21. ratman

    ratman TS Rookie

    Thanks for your input -- it figures I would have a "stumper".

    Quick question about reinstall: When I insert the Dell reinstallation disk, it tells me that I have a newer version (i.e. SP2) than the version on the CD (SP1) and that I should reboot from the CD. However, when I reboot, it just goes into the normal startup -- am I missing something?
  22. N3051M

    N3051M TS Evangelist Posts: 2,094

    Its basicaly looking at the date/whats on the disc versus whats on your PC.. Of course if you have a old disc its going to be SP1/minus updates since its shiped the same time as what windows updates were released etc. while windows on your PC is going to be up to date.

    You still can reinstall it over your current Windows (it will wipe everyting, so backup) and it will revert back to SP1. Then you can download or get a SP2 CD and just run it as an update to bring it back to date.

    Otherwise you can try making a SP2 slipstreamed disc...
  23. roy50

    roy50 TS Rookie

    After "wading" through tons of MS docs...to no avail, I came across your solution and it worked perfectly. Thanks!
  24. whirlpool

    whirlpool TS Rookie

    Thanks for the support, I don't profess to know much and forums like this really help
    just to let you know I had another issue causing the ICS from starting.

    I was heavily infected thanks to a link that was forwarded by a friend!
    upshot was that it took me 6 hours to remove the bleeding spywhatever and a further day mucking about going thru everything on these three pages

    after this did not work I used a hammer and tickled the beast

    there is a service called "Windows management instrumentation" and it had been turned off

    needless to say I have followed many other tips found across this website - so thanks :approve:
  25. Fiver

    Fiver TS Rookie

    error 1075


    I had the error 1075 to and I fixed it by deleting DependOnService from




    but I still can't get the Virus Protection cheking service in Security Center to work.

    Is the checker a separate service and if it is what's it called?
    I can't find it :|

    can anyone help?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...